aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-11-05 21:56:51 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-14 08:42:03 +0000
commitb98fda5bda16a63854ba0eb0314b58b258b99ab3 (patch)
tree39732039f7da9282ce2ed053d10d01ef2bda2425
parentf8d13bb1cce3aa323a9da32d47d91c557aa88009 (diff)
downloadalpine_aports-b98fda5bda16a63854ba0eb0314b58b258b99ab3.tar.bz2
alpine_aports-b98fda5bda16a63854ba0eb0314b58b258b99ab3.tar.xz
alpine_aports-b98fda5bda16a63854ba0eb0314b58b258b99ab3.zip
main/texinfo: upgrade to 6.7
Add patch to avoid including libintl.h with --disable-nls.
-rw-r--r--main/texinfo/APKBUILD13
-rw-r--r--main/texinfo/fix-build-without-NLS.patch24
2 files changed, 32 insertions, 5 deletions
diff --git a/main/texinfo/APKBUILD b/main/texinfo/APKBUILD
index 53200e1cc6..8e985ed7d0 100644
--- a/main/texinfo/APKBUILD
+++ b/main/texinfo/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=texinfo 2pkgname=texinfo
3pkgver=6.6 3pkgver=6.7
4pkgrel=2 4pkgrel=0
5pkgdesc="Utilities to work with and produce manuals, ASCII text, and on-line documentation from a single source file" 5pkgdesc="Utilities to work with and produce manuals, ASCII text, and on-line documentation from a single source file"
6url="https://www.gnu.org/software/texinfo/" 6url="https://www.gnu.org/software/texinfo/"
7arch="all" 7arch="all"
@@ -10,7 +10,8 @@ license="GPL-3.0-or-later"
10depends="perl" 10depends="perl"
11makedepends="ncurses-dev perl-dev" 11makedepends="ncurses-dev perl-dev"
12subpackages="$pkgname-doc" 12subpackages="$pkgname-doc"
13source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz" 13source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
14 fix-build-without-NLS.patch"
14builddir="$srcdir/$pkgname-$pkgver" 15builddir="$srcdir/$pkgname-$pkgver"
15 16
16build() { 17build() {
@@ -18,7 +19,8 @@ build() {
18 ./configure \ 19 ./configure \
19 --build=$CBUILD \ 20 --build=$CBUILD \
20 --host=$CHOST \ 21 --host=$CHOST \
21 --prefix=/usr 22 --prefix=/usr \
23 --disable-nls
22 make 24 make
23} 25}
24 26
@@ -30,4 +32,5 @@ package() {
30 gzip "$pkgdir"/usr/share/info/* 32 gzip "$pkgdir"/usr/share/info/*
31} 33}
32 34
33sha512sums="96e0764d0808152d3662e65c3287fb0f86ed918912cdc036380637dbadaacd6a489b516543c07b08105686575e8d495a945f73e23ff0909d5a0f12026e4131e0 texinfo-6.6.tar.xz" 35sha512sums="da55a0d0a760914386393c5e8e864540265d8550dc576f784781a6d72501918e8afce716ff343e5c2a0ce09cf921bfaf0a48ecb49f6182a7d10e920ae3ea17e7 texinfo-6.7.tar.xz
361c33d8c8bf24ec139fa2a283e12d42a260027d354061d348b66f1d2ef4636573cb88442299595af946366c9e9cc5511450a32d1a1fb827bee30f38a7558b3edb fix-build-without-NLS.patch"
diff --git a/main/texinfo/fix-build-without-NLS.patch b/main/texinfo/fix-build-without-NLS.patch
new file mode 100644
index 0000000000..105650c856
--- /dev/null
+++ b/main/texinfo/fix-build-without-NLS.patch
@@ -0,0 +1,24 @@
1--- a/tp/Texinfo/XS/parsetexi/api.c
2+++ b/tp/Texinfo/XS/parsetexi/api.c
3@@ -25,7 +25,9 @@
4
5 #undef context
6
7+#if defined(HAVE_LIBINTL_H)
8 #include <libintl.h>
9+#endif
10
11 #include <stdlib.h>
12 #include <stdio.h>
13--- a/tp/Texinfo/XS/parsetexi/errors.c
14+++ b/tp/Texinfo/XS/parsetexi/errors.c
15@@ -14,7 +14,9 @@
16 along with this program. If not, see <http://www.gnu.org/licenses/>. */
17
18 #include <config.h>
19+#if defined(HAVE_LIBINTL_H)
20 #include <libintl.h>
21+#endif
22
23 #include <stdlib.h>
24 #include <stdarg.h>