aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-01-20 19:04:11 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-21 23:57:00 +0100
commit8ca0c58545fa65a70d9f3c97b9cbdf9f3e02a4c0 (patch)
tree3864bec101a302c9adf1228afe64e63b341fdf85
parent63ed47c009a949274dcc4b053ecda1cbd005e097 (diff)
downloadalpine_aports-8ca0c58545fa65a70d9f3c97b9cbdf9f3e02a4c0.tar.bz2
alpine_aports-8ca0c58545fa65a70d9f3c97b9cbdf9f3e02a4c0.tar.xz
alpine_aports-8ca0c58545fa65a70d9f3c97b9cbdf9f3e02a4c0.zip
main/openssl: enable tests on s390x, modernize
-rw-r--r--main/openssl/APKBUILD30
1 files changed, 12 insertions, 18 deletions
diff --git a/main/openssl/APKBUILD b/main/openssl/APKBUILD
index 2b90a1caa6..37c722ce2e 100644
--- a/main/openssl/APKBUILD
+++ b/main/openssl/APKBUILD
@@ -2,9 +2,9 @@
2pkgname=openssl 2pkgname=openssl
3pkgver=1.1.1d 3pkgver=1.1.1d
4_abiver=${pkgver%.*} 4_abiver=${pkgver%.*}
5pkgrel=3 5pkgrel=4
6pkgdesc="Toolkit for Transport Layer Security (TLS)" 6pkgdesc="Toolkit for Transport Layer Security (TLS)"
7url="https://www.openssl.org" 7url="https://www.openssl.org/"
8arch="all" 8arch="all"
9license="OpenSSL" 9license="OpenSSL"
10replaces="libressl" 10replaces="libressl"
@@ -17,9 +17,6 @@ source="https://www.openssl.org/source/openssl-$pkgver.tar.gz
17 man-section.patch 17 man-section.patch
18 CVE-2019-1551.patch 18 CVE-2019-1551.patch
19 " 19 "
20case "$CARCH" in
21s390x) options="$options !check";; # FIXME: test hangs
22esac
23 20
24 21
25# secfixes: 22# secfixes:
@@ -37,7 +34,6 @@ esac
37 34
38build() { 35build() {
39 local _target _optflags 36 local _target _optflags
40 cd "$builddir"
41 37
42 # openssl will prepend crosscompile always core CC et al 38 # openssl will prepend crosscompile always core CC et al
43 CC=${CC#${CROSS_COMPILE}} 39 CC=${CC#${CROSS_COMPILE}}
@@ -46,16 +42,16 @@ build() {
46 42
47 # determine target OS for openssl 43 # determine target OS for openssl
48 case "$CARCH" in 44 case "$CARCH" in
49 aarch64*) _target="linux-aarch64" ;; 45 aarch64*) _target="linux-aarch64" ;;
50 arm*) _target="linux-armv4" ;; 46 arm*) _target="linux-armv4" ;;
51 mips64*) _target="linux64-mips64" ;; 47 mips64*) _target="linux64-mips64" ;;
52 # explicit _optflags is needed to prevent automatic -mips3 addition 48 # explicit _optflags is needed to prevent automatic -mips3 addition
53 mips*) _target="linux-mips32"; _optflags="-mips32" ;; 49 mips*) _target="linux-mips32"; _optflags="-mips32" ;;
54 ppc64le) _target="linux-ppc64le" ;; 50 ppc64le) _target="linux-ppc64le" ;;
55 x86) _target="linux-elf" ;; 51 x86) _target="linux-elf" ;;
56 x86_64) _target="linux-x86_64"; _optflags="enable-ec_nistp_64_gcc_128" ;; 52 x86_64) _target="linux-x86_64"; _optflags="enable-ec_nistp_64_gcc_128" ;;
57 s390x) _target="linux64-s390x";; 53 s390x) _target="linux64-s390x";;
58 *) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;; 54 *) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
59 esac 55 esac
60 56
61 # Configure assumes --options are for it, so can't use 57 # Configure assumes --options are for it, so can't use
@@ -74,12 +70,10 @@ build() {
74} 70}
75 71
76check() { 72check() {
77 cd "$builddir"
78 make test 73 make test
79} 74}
80 75
81package() { 76package() {
82 cd "$builddir"
83 make DESTDIR="$pkgdir" install 77 make DESTDIR="$pkgdir" install
84 # remove the script c_rehash 78 # remove the script c_rehash
85 rm "$pkgdir"/usr/bin/c_rehash 79 rm "$pkgdir"/usr/bin/c_rehash