aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-28 15:27:43 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-28 15:30:28 +0200
commit20ff62966a769feb71a12a16d53831cce9fe0179 (patch)
tree1f208ee5adc30a10b67d517f3169b9fd4d46b184
parent2547117f8594952cf3ba12e9d22bec5026c1b342 (diff)
downloadalpine_aports-20ff62966a769feb71a12a16d53831cce9fe0179.tar.bz2
alpine_aports-20ff62966a769feb71a12a16d53831cce9fe0179.tar.xz
alpine_aports-20ff62966a769feb71a12a16d53831cce9fe0179.zip
community/gnome: split gnome-apps into gnome-apps-core and gnome-apps-extra
That way users can install gnome-apps-core to get core apps like gnome-terminal without installing all GNOME apps
-rw-r--r--community/gnome/APKBUILD94
1 files changed, 54 insertions, 40 deletions
diff --git a/community/gnome/APKBUILD b/community/gnome/APKBUILD
index 65986c7df2..50a6a2d79f 100644
--- a/community/gnome/APKBUILD
+++ b/community/gnome/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Rasmus Thomsen <oss@cogitri.dev> 2# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
3pkgname=gnome 3pkgname=gnome
4pkgver=3.36.0 4pkgver=3.36.0
5pkgrel=4 5pkgrel=5
6pkgdesc="GNOME (Base) meta package" 6pkgdesc="GNOME (Base) meta package"
7url="https://www.gnome.org" 7url="https://www.gnome.org"
8arch="x86 x86_64 armv7 aarch64" # GNOME isn't available on all arches yet 8arch="x86 x86_64 armv7 aarch64" # GNOME isn't available on all arches yet
@@ -12,6 +12,7 @@ depends="
12 chrome-gnome-shell 12 chrome-gnome-shell
13 gdm 13 gdm
14 gnome-backgrounds 14 gnome-backgrounds
15 gnome-control-center
15 gnome-getting-started-docs 16 gnome-getting-started-docs
16 gnome-initial-setup 17 gnome-initial-setup
17 gnome-keyring 18 gnome-keyring
@@ -39,66 +40,35 @@ if [ "$CARCH" != "armv7" ]; then
39 depends="$depends bolt" 40 depends="$depends bolt"
40fi 41fi
41 42
42subpackages="$pkgname-apps:_apps $pkgname-games-collection:_games" 43subpackages="$pkgname-apps-core:_apps_core $pkgname-apps-extra:_apps_extra $pkgname-games-collection:_games"
43 44
44package() { 45package() {
45 mkdir -p "$pkgdir" 46 mkdir -p "$pkgdir"
46} 47}
47 48
48_apps() { 49_apps_core() {
49 pkgdesc="Additional GNOME apps meta package" 50 pkgdesc="Additional core GNOME apps meta package"
51 # From https://wiki.gnome.org/Design/Apps
50 depends=" 52 depends="
51 baobab
52 brasero
53 celluloid
54 cheese
55 dconf-editor
56 eog 53 eog
57 epiphany 54 epiphany
58 evince
59 evolution 55 evolution
60 deja-dup 56 evince
61 devhelp
62 easytag
63 file-roller
64 fractal
65 geary
66 gedit 57 gedit
67 gedit-plugins 58 gedit-plugins
68 ghex
69 gitg
70 gnome-authenticator
71 gnome-books
72 gnome-boxes
73 gnome-builder
74 gnome-calculator 59 gnome-calculator
75 gnome-calendar 60 gnome-calendar
76 gnome-characters
77 gnome-clocks 61 gnome-clocks
78 gnome-contacts 62 gnome-contacts
79 gnome-disk-utility 63 gnome-disk-utility
80 gnome-documents
81 gnome-feeds
82 gnome-games
83 gnome-latex
84 gnome-maps 64 gnome-maps
85 gnome-music
86 gnome-obfuscate
87 gnome-passwordsafe
88 gnome-photos
89 gnome-podcasts
90 gnome-power-manager
91 gnome-screenshot 65 gnome-screenshot
92 gnome-shortwave
93 gnome-software 66 gnome-software
94 gnome-sound-recorder 67 gnome-software-plugin-apk
95 gnome-system-monitor 68 gnome-system-monitor
96 gnome-terminal 69 gnome-terminal
97 gnome-tweaks 70 gnome-tweaks
98 gnome-weather 71 gnome-weather
99 gnote
100 gparted
101 gpaste
102 grilo 72 grilo
103 grilo-plugins 73 grilo-plugins
104 gst-plugins-bad 74 gst-plugins-bad
@@ -116,18 +86,62 @@ _apps() {
116 gvfs-fuse 86 gvfs-fuse
117 gvfs-gphoto2 87 gvfs-gphoto2
118 gvfs-avahi 88 gvfs-avahi
89 nautilus
90 totem
91 "
92
93 mkdir -p "$subpkgdir"
94}
95
96_apps_extra() {
97 pkgdesc="Additional GNOME apps meta package"
98 replaces="gnome-apps" # splitted into gnome-apps-core and gnome-apps-extra
99 provides="gnome-apps=$pkgver-r$pkgrel"
100 depends="
101 baobab
102 brasero
103 celluloid
104 cheese
105 dconf-editor
106 deja-dup
107 devhelp
108 easytag
109 file-roller
110 fractal
111 geary
112 ghex
113 gitg
114 gnome-apps-core
115 gnome-authenticator
116 gnome-books
117 gnome-boxes
118 gnome-builder
119 gnome-characters
120 gnome-documents
121 gnome-feeds
122 gnome-games
123 gnome-latex
124 gnome-music
125 gnome-obfuscate
126 gnome-passwordsafe
127 gnome-photos
128 gnome-podcasts
129 gnome-power-manager
130 gnome-shortwave
131 gnome-sound-recorder
132 gnote
133 gparted
134 gpaste
119 meld 135 meld
120 orca 136 orca
121 peek 137 peek
122 polari 138 polari
123 rhythmbox 139 rhythmbox
124 nautilus
125 seahorse 140 seahorse
126 simple-scan 141 simple-scan
127 shotwell 142 shotwell
128 sound-juicer 143 sound-juicer
129 sushi 144 sushi
130 totem
131 transmission 145 transmission
132 vinagre 146 vinagre
133 vino 147 vino