aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-27 15:29:24 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-27 21:26:49 +0000
commit2a5fb9d42c59642d41e5b3641fc9df8852d842a4 (patch)
tree693e620b203e8bbfe83309ec0c87df0fd02c8e36
parentfa1e986bde1e5ed86e680383e9b99b8685b49e3c (diff)
downloadalpine_aports-2a5fb9d42c59642d41e5b3641fc9df8852d842a4.tar.bz2
alpine_aports-2a5fb9d42c59642d41e5b3641fc9df8852d842a4.tar.xz
alpine_aports-2a5fb9d42c59642d41e5b3641fc9df8852d842a4.zip
community/ripgrep: re-introduce fish completion
fish upstream removed bat and rg in 3.1.1, it means whenever there is a conflict we **MUST** use the upstream provided files
-rw-r--r--community/ripgrep/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/ripgrep/APKBUILD b/community/ripgrep/APKBUILD
index 07b404eb83..b4ff8e79a6 100644
--- a/community/ripgrep/APKBUILD
+++ b/community/ripgrep/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: André Klitzing <aklitzing@gmail.com> 2# Maintainer: André Klitzing <aklitzing@gmail.com>
3pkgname=ripgrep 3pkgname=ripgrep
4pkgver=12.0.1 4pkgver=12.0.1
5pkgrel=0 5pkgrel=1
6pkgdesc="ripgrep combines the usability of The Silver Searcher with the raw speed of grep" 6pkgdesc="ripgrep combines the usability of The Silver Searcher with the raw speed of grep"
7url="https://github.com/BurntSushi/ripgrep" 7url="https://github.com/BurntSushi/ripgrep"
8arch="all !s390x !mips !mips64" # limited by cargo 8arch="all !s390x !mips !mips64" # limited by cargo
@@ -12,28 +12,31 @@ checkdepends="xz"
12subpackages="$pkgname-doc 12subpackages="$pkgname-doc
13 $pkgname-bash-completion:bashcomp:noarch 13 $pkgname-bash-completion:bashcomp:noarch
14 $pkgname-zsh-completion:zshcomp:noarch 14 $pkgname-zsh-completion:zshcomp:noarch
15 $pkgname-fish-completion::noarch
15 " 16 "
16source="$pkgname-$pkgver.tar.gz::https://github.com/BurntSushi/ripgrep/archive/$pkgver.tar.gz" 17source="$pkgname-$pkgver.tar.gz::https://github.com/BurntSushi/ripgrep/archive/$pkgver.tar.gz"
17 18
18build() { 19build() {
19 cargo build --release --features 'pcre2' 20 cargo build --release --locked --features 'pcre2'
20} 21}
21 22
22check() { 23check() {
23 cargo test 24 cargo test --release --locked --features 'pcre2'
24} 25}
25 26
26package() { 27package() {
27 install -Dm755 "target/release/rg" "$pkgdir/usr/bin/rg" 28 install -Dm755 "target/release/rg" "$pkgdir/usr/bin/rg"
28 install -Dm644 "target/release/build/ripgrep-"*/out/rg.1 \ 29 install -Dm644 "target/release/build/ripgrep-"*/out/rg.1 \
29 "$pkgdir/usr/share/man/man1/rg.1" 30 "$pkgdir/usr/share/man/man1/rg.1"
31
32 install -Dm644 "$builddir"/target/release/build/ripgrep-*/out/rg.fish \
33 -t "$pkgdir"/usr/share/fish/completions
30} 34}
31 35
32bashcomp() { 36bashcomp() {
33 depends="" 37 depends=""
34 pkgdesc="Bash completions for $pkgname" 38 pkgdesc="Bash completions for $pkgname"
35 install_if="$pkgname=$pkgver-r$pkgrel bash-completion" 39 install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
36
37 mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/ 40 mkdir -p "$subpkgdir"/usr/share/bash-completion/completions/
38 install -Dm644 "$builddir/target/release/build/ripgrep-"*/out/rg.bash \ 41 install -Dm644 "$builddir/target/release/build/ripgrep-"*/out/rg.bash \
39 "$subpkgdir/usr/share/bash-completion/completions/rg" 42 "$subpkgdir/usr/share/bash-completion/completions/rg"