aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-04-27 06:44:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-04-27 06:45:58 +0000
commit2eb2dada1a855d3d43d8867f0605b9ed42cbb6af (patch)
treed9241c12b621a8f12b88a43da1c738b1251e5b61
parente9c0f62f68ae7415f7dad299f277762f704f3fed (diff)
downloadalpine_aports-2eb2dada1a855d3d43d8867f0605b9ed42cbb6af.tar.bz2
alpine_aports-2eb2dada1a855d3d43d8867f0605b9ed42cbb6af.tar.xz
alpine_aports-2eb2dada1a855d3d43d8867f0605b9ed42cbb6af.zip
main/libxml2: store patch in aports tree
upstream patch may get new checksum when they update git version, since git version is a part of the footer in the patch. Store the patch in the aports tree to avoid checksum errors.
-rw-r--r--main/libxml2/APKBUILD2
-rw-r--r--main/libxml2/libxml2-CVE-2020-7595.patch32
2 files changed, 33 insertions, 1 deletions
diff --git a/main/libxml2/APKBUILD b/main/libxml2/APKBUILD
index d1eab89f8f..ab2d18b9c1 100644
--- a/main/libxml2/APKBUILD
+++ b/main/libxml2/APKBUILD
@@ -14,7 +14,7 @@ subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-utils
14 py3-$pkgname:_py3" 14 py3-$pkgname:_py3"
15options="!strip" 15options="!strip"
16source="http://xmlsoft.org/sources/libxml2-$pkgver.tar.gz 16source="http://xmlsoft.org/sources/libxml2-$pkgver.tar.gz
17 libxml2-CVE-2020-7595.patch::https://gitlab.gnome.org/GNOME/libxml2/commit/0e1a49c8907645d2e155f0d89d4d9895ac5112b5.patch 17 libxml2-CVE-2020-7595.patch
18 revert-Make-xmlFreeNodeList-non-recursive.patch 18 revert-Make-xmlFreeNodeList-non-recursive.patch
19 libxml2-2.9.8-python3-unicode-errors.patch 19 libxml2-2.9.8-python3-unicode-errors.patch
20 " 20 "
diff --git a/main/libxml2/libxml2-CVE-2020-7595.patch b/main/libxml2/libxml2-CVE-2020-7595.patch
new file mode 100644
index 0000000000..3dd6774976
--- /dev/null
+++ b/main/libxml2/libxml2-CVE-2020-7595.patch
@@ -0,0 +1,32 @@
1From 0e1a49c8907645d2e155f0d89d4d9895ac5112b5 Mon Sep 17 00:00:00 2001
2From: Zhipeng Xie <xiezhipeng1@huawei.com>
3Date: Thu, 12 Dec 2019 17:30:55 +0800
4Subject: [PATCH] Fix infinite loop in xmlStringLenDecodeEntities
5
6When ctxt->instate == XML_PARSER_EOF,xmlParseStringEntityRef
7return NULL which cause a infinite loop in xmlStringLenDecodeEntities
8
9Found with libFuzzer.
10
11Signed-off-by: Zhipeng Xie <xiezhipeng1@huawei.com>
12---
13 parser.c | 3 ++-
14 1 file changed, 2 insertions(+), 1 deletion(-)
15
16diff --git a/parser.c b/parser.c
17index d1c31963..a34bb6cd 100644
18--- a/parser.c
19+++ b/parser.c
20@@ -2646,7 +2646,8 @@ xmlStringLenDecodeEntities(xmlParserCtxtPtr ctxt, const xmlChar *str, int len,
21 else
22 c = 0;
23 while ((c != 0) && (c != end) && /* non input consuming loop */
24- (c != end2) && (c != end3)) {
25+ (c != end2) && (c != end3) &&
26+ (ctxt->instate != XML_PARSER_EOF)) {
27
28 if (c == 0) break;
29 if ((c == '&') && (str[1] == '#')) {
30--
312.24.1
32