aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-27 16:29:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-27 16:30:17 -0300
commit660321b4443624b5a078274e3278b72d5876f45b (patch)
tree7c124dd24cfcdd143c5c885898ed875fe43ba875
parent7743651eb99fb78b593e7d9cb15b8c96aaecbbdd (diff)
downloadalpine_aports-660321b4443624b5a078274e3278b72d5876f45b.tar.bz2
alpine_aports-660321b4443624b5a078274e3278b72d5876f45b.tar.xz
alpine_aports-660321b4443624b5a078274e3278b72d5876f45b.zip
main/xorg-server: underlink libfb.so as autotools does
fixes #11395
-rw-r--r--main/xorg-server/APKBUILD6
-rw-r--r--main/xorg-server/link-libshadow.patch31
2 files changed, 35 insertions, 2 deletions
diff --git a/main/xorg-server/APKBUILD b/main/xorg-server/APKBUILD
index 6418687b26..20581cc853 100644
--- a/main/xorg-server/APKBUILD
+++ b/main/xorg-server/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=xorg-server 3pkgname=xorg-server
4pkgver=1.20.8 4pkgver=1.20.8
5pkgrel=1 5pkgrel=2
6pkgdesc="X.Org X servers" 6pkgdesc="X.Org X servers"
7url="https://www.x.org/wiki" 7url="https://www.x.org/wiki"
8arch="all" 8arch="all"
@@ -52,6 +52,7 @@ makedepends="
52 " 52 "
53source="https://www.x.org/releases/individual/xserver/xorg-server-$pkgver.tar.bz2 53source="https://www.x.org/releases/individual/xserver/xorg-server-$pkgver.tar.bz2
54 xwayland-glx.patch 54 xwayland-glx.patch
55 link-libshadow.patch
55 " 56 "
56 57
57# secfixes: 58# secfixes:
@@ -166,4 +167,5 @@ xwayland() {
166 mv "$pkgdir"/usr/bin/Xwayland "$subpkgdir"/usr/bin/ 167 mv "$pkgdir"/usr/bin/Xwayland "$subpkgdir"/usr/bin/
167} 168}
168sha512sums="ab0ec0fcbf490c61558b9297f61b58fd2dedb676c78bef6431dc9166054743b43a0091b88a8b3f4e81d1f539909440ee7e188a298cefabe13ea89159639cd805 xorg-server-1.20.8.tar.bz2 169sha512sums="ab0ec0fcbf490c61558b9297f61b58fd2dedb676c78bef6431dc9166054743b43a0091b88a8b3f4e81d1f539909440ee7e188a298cefabe13ea89159639cd805 xorg-server-1.20.8.tar.bz2
169004c9a7d920af8825a311d32433bf64190d45583d57bb20b3c5ef39d8011ced7bf17b73296e56078ca791e6cd923594dacfe3fbf7af7c98934627e34559c85d8 xwayland-glx.patch" 170004c9a7d920af8825a311d32433bf64190d45583d57bb20b3c5ef39d8011ced7bf17b73296e56078ca791e6cd923594dacfe3fbf7af7c98934627e34559c85d8 xwayland-glx.patch
171d0f723e6033a77faec118adc64e9d4749270724cbb2b86ca5ff796e1fbaef2d01ebcbb2904d48132b58f3ecf0781b2583744b671b17b7d51a1748f4b461932b0 link-libshadow.patch"
diff --git a/main/xorg-server/link-libshadow.patch b/main/xorg-server/link-libshadow.patch
new file mode 100644
index 0000000000..48f8cd1bc9
--- /dev/null
+++ b/main/xorg-server/link-libshadow.patch
@@ -0,0 +1,31 @@
1From a530b6e8923f2b9153a773c8618a1e2f41619288 Mon Sep 17 00:00:00 2001
2From: Adam Jackson <ajax@redhat.com>
3Date: Tue, 30 Apr 2019 18:01:27 -0400
4Subject: [PATCH] meson: Fix libshadow.so linkage
5
6Don't link against fb, it's the driver's responsibility to load that
7first. Underlinking like this is unpleasant but this matches what
8autotools does.
9
10Fixes: xorg/xserver#540
11---
12 hw/xfree86/dixmods/meson.build | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/hw/xfree86/dixmods/meson.build b/hw/xfree86/dixmods/meson.build
16index 835d23215..0562b630f 100644
17--- a/hw/xfree86/dixmods/meson.build
18+++ b/hw/xfree86/dixmods/meson.build
19@@ -34,7 +34,7 @@ shared_module(
20 c_args: xorg_c_args,
21 dependencies: common_dep,
22 link_whole: libxserver_miext_shadow,
23- link_with: [fb, e],
24+ link_with: e,
25
26 install: true,
27 install_dir: module_dir,
28--
292.22.0
30
31