aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-06-25 00:08:15 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 04:38:48 +0000
commit30066783874efa0045cbf8ef2b730b4edbe2dfa7 (patch)
tree0ad189c65270c52e5f26560908023b0977aedd7c
parentd845fd2b834f749605bd9b610d3be9e42d9ff4a9 (diff)
downloadalpine_aports-30066783874efa0045cbf8ef2b730b4edbe2dfa7.tar.bz2
alpine_aports-30066783874efa0045cbf8ef2b730b4edbe2dfa7.tar.xz
alpine_aports-30066783874efa0045cbf8ef2b730b4edbe2dfa7.zip
community/perl-ffi-platypus-lang-cpp-demangle-xs: new aport
-rw-r--r--testing/perl-ffi-platypus-lang-cpp-demangle-xs/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/perl-ffi-platypus-lang-cpp-demangle-xs/APKBUILD b/testing/perl-ffi-platypus-lang-cpp-demangle-xs/APKBUILD
new file mode 100644
index 0000000000..b223a9ac7a
--- /dev/null
+++ b/testing/perl-ffi-platypus-lang-cpp-demangle-xs/APKBUILD
@@ -0,0 +1,36 @@
1# Automatically generated by apkbuild-cpan, template 3
2# Contributor: Timothy Legge <timlegge@gmail.com>
3# Maintainer: Timothy Legge <timlegge@gmail.com>
4pkgname=perl-ffi-platypus-lang-cpp-demangle-xs
5#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
6_pkgreal=FFI-Platypus-Lang-CPP-Demangle-XS
7pkgver=0.03
8pkgrel=0
9pkgdesc="Demangle C++ symbols using the C++ ABI API"
10url="https://metacpan.org/release/FFI-Platypus-Lang-CPP-Demangle-XS/"
11arch="all"
12license="GPL-1.0-or-later OR Artistic-1.0-Perl"
13depends="perl"
14makedepends="perl-dev perl-extutils-cppguess"
15checkdepends="perl-test2-suite"
16subpackages="$pkgname-doc"
17source="https://cpan.metacpan.org/authors/id/P/PL/PLICEASE/FFI-Platypus-Lang-CPP-Demangle-XS-$pkgver.tar.gz"
18builddir="$srcdir/$_pkgreal-$pkgver"
19
20build() {
21 export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
22 PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
23 make
24}
25
26check() {
27 export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
28 make test
29}
30
31package() {
32 make DESTDIR="$pkgdir" install
33 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
34}
35
36sha512sums="8d4fe6d0d732805493e77940b80a9280776f4914c18430c6120673890ceda195959d4a15f6a984fb8d977b1322f2b0ed605bf8bbf5a35961f6a0d344a80c32fa FFI-Platypus-Lang-CPP-Demangle-XS-0.03.tar.gz"