aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-06-26 01:39:27 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 03:16:36 +0000
commit426c7ae7455141a3bed1875ac77cf673ee11a574 (patch)
tree75f472bea533438fba5ac6acb33590347d4d2d8c
parentfaac869d552a3f7e46697fe6d7d71fc14e620ebc (diff)
downloadalpine_aports-426c7ae7455141a3bed1875ac77cf673ee11a574.tar.bz2
alpine_aports-426c7ae7455141a3bed1875ac77cf673ee11a574.tar.xz
alpine_aports-426c7ae7455141a3bed1875ac77cf673ee11a574.zip
testing/ginkgo: new aport
https://onsi.github.io/ginkgo/ BDD-style Go testing framework
-rw-r--r--testing/ginkgo/APKBUILD36
-rw-r--r--testing/ginkgo/pie-and-race-conflict.patch12
2 files changed, 48 insertions, 0 deletions
diff --git a/testing/ginkgo/APKBUILD b/testing/ginkgo/APKBUILD
new file mode 100644
index 0000000000..9ed733c7a4
--- /dev/null
+++ b/testing/ginkgo/APKBUILD
@@ -0,0 +1,36 @@
1# Contributor: Michał Polański <michal@polanski.me>
2# Maintainer: Michał Polański <michal@polanski.me>
3pkgname=ginkgo
4pkgver=1.13.0
5pkgrel=0
6pkgdesc="BDD-style Go testing framework"
7url="https://onsi.github.io/ginkgo/"
8options="chmod-clean"
9arch="all !mips !mips64" # limited by go
10license="MIT"
11makedepends="go"
12source="$pkgname-$pkgver.tar.gz::https://github.com/onsi/ginkgo/archive/v$pkgver.tar.gz
13 pie-and-race-conflict.patch
14 "
15
16export GOPATH="$srcdir"
17
18build() {
19 go build -v -ldflags "-s -w" -o bin/ginkgo ./ginkgo
20}
21
22check() {
23 go test ./...
24}
25
26package() {
27 install -Dm755 bin/ginkgo "$pkgdir"/usr/bin/ginkgo
28}
29
30cleanup_srcdir() {
31 go clean -modcache
32 default_cleanup_srcdir
33}
34
35sha512sums="d926651bd84b5157b19e48bc532ea7806e01ac2db235dfb908ca228fa9becf19ff30b613a822f247a38dc780a169338161603db019480428f9d228dc85317c0e ginkgo-1.13.0.tar.gz
366d8a1ad1160ccede8eeda204277bb974b9a678efaa5624ab03d8eb204202c26c60e37b3aadd6e6368ac2d57cd073720f9faf4e397bcebb50bc643f680ca45534 pie-and-race-conflict.patch"
diff --git a/testing/ginkgo/pie-and-race-conflict.patch b/testing/ginkgo/pie-and-race-conflict.patch
new file mode 100644
index 0000000000..2c020e308c
--- /dev/null
+++ b/testing/ginkgo/pie-and-race-conflict.patch
@@ -0,0 +1,12 @@
1Upstream: No
2Reason: Skip test that can't be run with -buildmode=pie
3--- a/integration/flags_test.go
4+++ b/integration/flags_test.go
5@@ -106,6 +106,7 @@ var _ = Describe("Flags Specs", func() {
6 })
7
8 It("should run the race detector when told to", func() {
9+ Skip("-buildmode=pie not supported when -race is enabled")
10 if !raceDetectorSupported() {
11 Skip("race detection is not supported")
12 }