aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTerror <miguel.a.terron@gmail.com>2020-06-26 04:38:41 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-06-26 04:38:41 +0000
commit4295cbb6c42c1689edf03e7046bfafab580a37a3 (patch)
tree3c74eae2372271156b830d6604a5f80d0a67bc60
parent8d1291b81256f4169eaf0907e75dd763859a93ca (diff)
downloadalpine_aports-4295cbb6c42c1689edf03e7046bfafab580a37a3.tar.bz2
alpine_aports-4295cbb6c42c1689edf03e7046bfafab580a37a3.tar.xz
alpine_aports-4295cbb6c42c1689edf03e7046bfafab580a37a3.zip
testing/mdnsd: new aport
-rw-r--r--testing/mdnsd/APKBUILD50
-rw-r--r--testing/mdnsd/mdnsd.confd11
-rw-r--r--testing/mdnsd/mdnsd.initd21
3 files changed, 82 insertions, 0 deletions
diff --git a/testing/mdnsd/APKBUILD b/testing/mdnsd/APKBUILD
new file mode 100644
index 0000000000..160f52b935
--- /dev/null
+++ b/testing/mdnsd/APKBUILD
@@ -0,0 +1,50 @@
1# Contributor: Miguel Terron <miguel.a.terron@gmail.com>
2# Maintainer: Miguel Terron <miguel.a.terron@gmail.com>
3pkgname=mdnsd
4pkgver=0.10
5pkgrel=0
6pkgdesc="Embeddable Multicast DNS Daemon"
7url="https://github.com/troglobit/mdnsd"
8arch="all"
9license="BSD-3-Clause"
10subpackages="
11 $pkgname-doc
12 $pkgname-libs
13 $pkgname-static
14 $pkgname-openrc
15 "
16source="
17 mdnsd.confd
18 mdnsd.initd
19 https://github.com/troglobit/mdnsd/releases/download/v$pkgver/mdnsd-$pkgver.tar.xz
20 "
21
22build() {
23 ./configure \
24 --build=$CBUILD \
25 --host=$CHOST \
26 --prefix=/usr \
27 --sysconfdir=/etc \
28 --mandir=/usr/share/man \
29 --localstatedir=/var \
30 --without-systemd
31 make
32}
33
34check() {
35 make check
36}
37
38package() {
39 make DESTDIR="$pkgdir" install
40
41 install -m755 -D "$srcdir"/$pkgname.initd \
42 "$pkgdir"/etc/init.d/$pkgname
43 install -m644 -D "$srcdir"/$pkgname.confd \
44 "$pkgdir"/etc/conf.d/$pkgname
45}
46
47sha512sums="
48c4ff3b6c27b4411753bea0bd63ecda31be47283c5375f81d38f351839fe15c8897001be2c8adcc7f2943179437135b482d4d629be841bc1bfb634040da823501 mdnsd.confd
498a4fb736263ec05aa439f320091a43dfea64fb7e89fd0af5ada3981d0461009f55e1ac598a143a9458063eaf117e1b7b788463f0af316153fa6bfea864019a99 mdnsd.initd
50aced00adda9ce9d915cd51d74f4249ae4be1917b679f8750262b505908b70cffbec6235fdc01a14d66171607f078e2378f2d2f3cc605abc9213857232d687c93 mdnsd-0.10.tar.xz"
diff --git a/testing/mdnsd/mdnsd.confd b/testing/mdnsd/mdnsd.confd
new file mode 100644
index 0000000000..12ff6016ae
--- /dev/null
+++ b/testing/mdnsd/mdnsd.confd
@@ -0,0 +1,11 @@
1# /etc/conf.d/mdnsd: config file for /etc/init.d/mdnsd
2
3# -a ADDR Address of service/host to announce, default: auto
4# -i IFACE Interface to announce services on, and get address from
5# -l LEVEL Set log level: none, err, notice (default), info, debug
6# -n Run in foreground, do not detach from controlling terminal
7# -p Persistent mode, retry if the socket or interface is lost
8# -s Use syslog even if running in foreground
9# -t TTL Set TTL of mDNS packets, default: 1 (link-local only)
10
11MDNSD_OPTS="-p -n"
diff --git a/testing/mdnsd/mdnsd.initd b/testing/mdnsd/mdnsd.initd
new file mode 100644
index 0000000000..7bb9f49b5b
--- /dev/null
+++ b/testing/mdnsd/mdnsd.initd
@@ -0,0 +1,21 @@
1#!/sbin/openrc-run
2
3description="embeddable multicast DNS daemon"
4command="/usr/sbin/mdnsd"
5command_args="${MDNSD_OPTS}"
6command_background="yes"
7command_user="daemon:daemon"
8
9pidfile="/run/${RC_SVCNAME}.pid"
10extra_started_commands="reload"
11
12depend() {
13 need net
14 after firewall
15}
16
17reload() {
18 ebegin "Reloading ${RC_SVCNAME}"
19 start-stop-daemon --signal HUP --pidfile "${pidfile}"
20 eend $?
21}