aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2020-06-25 16:03:26 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-25 16:03:26 +0000
commitab431934e6fac1d1bf076a8efc9ec83f27aa625f (patch)
tree7fd8757f72e96acd35ec8a851358cfcf972e5cf4
parent5c935c31d14360b2181e4b4bd3322ea7efd4d760 (diff)
downloadalpine_aports-ab431934e6fac1d1bf076a8efc9ec83f27aa625f.tar.bz2
alpine_aports-ab431934e6fac1d1bf076a8efc9ec83f27aa625f.tar.xz
alpine_aports-ab431934e6fac1d1bf076a8efc9ec83f27aa625f.zip
testing/qhull: upgrade to 2020.1
* install licence file * make APKBUILD the same as cmake template
-rw-r--r--testing/qhull/APKBUILD30
1 files changed, 19 insertions, 11 deletions
diff --git a/testing/qhull/APKBUILD b/testing/qhull/APKBUILD
index eac7832b21..4e0750ef7b 100644
--- a/testing/qhull/APKBUILD
+++ b/testing/qhull/APKBUILD
@@ -1,8 +1,7 @@
1# Contributor: Holger Jaekel <holger.jaekel@gmx.de> 1# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
2# Maintainer: Holger Jaekel <holger.jaekel@gmx.de> 2# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
3pkgname=qhull 3pkgname=qhull
4pkgver=2019.1 4pkgver=2020.1
5_tarver=7.3.2
6pkgrel=0 5pkgrel=0
7pkgdesc="Calculate convex hulls and related structures" 6pkgdesc="Calculate convex hulls and related structures"
8url="https://www.qhull.org/" 7url="https://www.qhull.org/"
@@ -14,23 +13,32 @@ subpackages="
14 $pkgname-dev 13 $pkgname-dev
15 $pkgname-doc 14 $pkgname-doc
16 " 15 "
17source="http://www.qhull.org/download/qhull-${pkgver%.*}-src-$_tarver.tgz" 16source="qhull-$pkgver.tar.gz::https://github.com/qhull/qhull/archive/$pkgver.tar.gz"
18builddir="$srcdir/$pkgname-$pkgver/build"
19 17
20build() { 18build() {
21 cmake .. \ 19 if [ "$CBUILD" != "$CHOST" ]; then
22 -DCMAKE_BUILD_TYPE=None \ 20 CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
21 fi
22 cmake -B build \
23 -DCMAKE_INSTALL_PREFIX=/usr \ 23 -DCMAKE_INSTALL_PREFIX=/usr \
24 -DCMAKE_SKIP_INSTALL_RPATH=YES 24 -DCMAKE_INSTALL_LIBDIR=lib \
25 make 25 -DBUILD_SHARED_LIBS=True \
26 -DCMAKE_BUILD_TYPE=None \
27 -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
28 -DCMAKE_C_FLAGS="$CFLAGS" \
29 -DCMAKE_SKIP_INSTALL_RPATH=YES \
30 $CMAKE_CROSSOPTS
31 make -C build
26} 32}
27 33
28check() { 34check() {
29 ctest 35 cd build && ctest
30} 36}
31 37
32package() { 38package() {
33 make DESTDIR="$pkgdir" install 39 make -C build DESTDIR="$pkgdir" install
40
41 install -Dm644 $builddir/COPYING.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
34} 42}
35 43
36sha512sums="efcaf2af45f3c401f5f677cac8e3ffc056f870bf62f852982ca880282c428920fad13071017b8d8b7b6fc416380c6f3fe6973aa0b37a2322c234774325b14f1c qhull-2019-src-7.3.2.tgz" 44sha512sums="aa9d97564290718a0983d252dd88193533264c97987942848d5b78d0dec33e27c71a7e909f520955368f8be2799a00844ffb47c49717aee072b949aace0f37da qhull-2020.1.tar.gz"