aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-06-25 12:42:57 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-06-25 13:40:42 +0200
commitca90b828c5af1c4356bd8906ea894f29acfab327 (patch)
tree7dc510942df03195b8ae94c6c070cbbca9cba98c
parentc81fc03004ea991381d9405d269f5173b8531591 (diff)
downloadalpine_aports-ca90b828c5af1c4356bd8906ea894f29acfab327.tar.bz2
alpine_aports-ca90b828c5af1c4356bd8906ea894f29acfab327.tar.xz
alpine_aports-ca90b828c5af1c4356bd8906ea894f29acfab327.zip
community/go: use setrlimit patch from upstream CL
Contrary to the currently used patch, this patch also includes the required change for MIPS. See also: https://gitlab.alpinelinux.org/alpine/aports/-/commit/c8faf6518d1b40b83a6f1bd3610da2d3f437a862
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/go/fix-setrlimit-hang.patch38
2 files changed, 35 insertions, 7 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 8b1f68ccc8..6d775e507d 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@
4pkgname=go 4pkgname=go
5# go binaries are statically linked, security updates require rebuilds 5# go binaries are statically linked, security updates require rebuilds
6pkgver=1.14.3 6pkgver=1.14.3
7pkgrel=2 7pkgrel=3
8pkgdesc="Go programming language compiler" 8pkgdesc="Go programming language compiler"
9url="https://golang.org/" 9url="https://golang.org/"
10arch="all !mips64" 10arch="all !mips64"
@@ -149,4 +149,4 @@ sha512sums="ab7454cf5e364a4b8d3035320bb8af5a3064accba51cb98211d2ba8afb116d07cedd
149ab4aa83d8a9bf10bbb93ad029095b47c6eea7d5532703d84449884039116e07897871649feb1df8128f10257cbdb5d7eb03820ab0f1a3f60315e195302f6e516 disable-flaky-gc-test.patch 149ab4aa83d8a9bf10bbb93ad029095b47c6eea7d5532703d84449884039116e07897871649feb1df8128f10257cbdb5d7eb03820ab0f1a3f60315e195302f6e516 disable-flaky-gc-test.patch
150dc255153a3c09766c10e613fa5ec90e870382dc24129c96c69e0adbeb46383b7dafc72b68376dcb7250fc34f44da26bfbb329d255d744f2f6ab09f5fdb278d40 0001-Fix-FTBFS-on-HOME-managed-with-git.patch 150dc255153a3c09766c10e613fa5ec90e870382dc24129c96c69e0adbeb46383b7dafc72b68376dcb7250fc34f44da26bfbb329d255d744f2f6ab09f5fdb278d40 0001-Fix-FTBFS-on-HOME-managed-with-git.patch
151bdc3c25c9138d0c01bc2493fcb8395f8e8c40970328c22915f8008fcc093abb5d6184ee24b7a3b78fb164ebc55bff3174c0bca1ac767467d9244498a0e52760c fix-rlimit-syscall-aarch64-armv7.patch 151bdc3c25c9138d0c01bc2493fcb8395f8e8c40970328c22915f8008fcc093abb5d6184ee24b7a3b78fb164ebc55bff3174c0bca1ac767467d9244498a0e52760c fix-rlimit-syscall-aarch64-armv7.patch
152ad91c22b3e2653871e490079e7f00cde916eeebd3f0f3fed3999a813527d238438d236169018f119b6b532994bc5f14d2b4fd16814e2edbe558d6bdbf1e8a393 fix-setrlimit-hang.patch" 152c20c126ce12f9a5190784f2a772a47658f375e44fb67884a0450ec3bbd0db61a978388b4c862bd80234e579bab58fd55b6306f3953acda11fd58603799b2e3b3 fix-setrlimit-hang.patch"
diff --git a/community/go/fix-setrlimit-hang.patch b/community/go/fix-setrlimit-hang.patch
index 7f3622d67d..928b0ff461 100644
--- a/community/go/fix-setrlimit-hang.patch
+++ b/community/go/fix-setrlimit-hang.patch
@@ -1,16 +1,44 @@
1By: tteras 1From: https://go-review.googlesource.com/c/go/+/236518/
2Based on https://www.openwall.com/lists/musl/2018/10/09/3 2
3See also: https://github.com/golang/go/issues/39343
4
5From 0f805dbee221cfb91e43e8a1facd77485a2ebd2a Mon Sep 17 00:00:00 2001
6From: George Tsilias <tsiliasg@gmail.com>
7Date: Thu, 04 Jun 2020 23:11:56 +0300
8Subject: [PATCH] runtime: handle signal 34 for musl setgid
9
10It has been observed that setgid hangs when using cgo with musl.
11This fix ensures that signal 34 gets handled in an appropriate way,
12like signal 33 when using glibc.
13
14Fixes #39343
15
16Change-Id: I89565663e2c361f62cbccfe80aaedf290bd58d57
17---
3 18
4diff --git a/src/runtime/sigtab_linux_generic.go b/src/runtime/sigtab_linux_generic.go 19diff --git a/src/runtime/sigtab_linux_generic.go b/src/runtime/sigtab_linux_generic.go
5index b26040b803..851148d049 100644 20index b26040b..38d6865 100644
6--- a/src/runtime/sigtab_linux_generic.go 21--- a/src/runtime/sigtab_linux_generic.go
7+++ b/src/runtime/sigtab_linux_generic.go 22+++ b/src/runtime/sigtab_linux_generic.go
8@@ -45,7 +45,7 @@ var sigtable = [...]sigTabT{ 23@@ -45,7 +45,7 @@
9 /* 31 */ {_SigThrow, "SIGSYS: bad system call"}, 24 /* 31 */ {_SigThrow, "SIGSYS: bad system call"},
10 /* 32 */ {_SigSetStack + _SigUnblock, "signal 32"}, /* SIGCANCEL; see issue 6997 */ 25 /* 32 */ {_SigSetStack + _SigUnblock, "signal 32"}, /* SIGCANCEL; see issue 6997 */
11 /* 33 */ {_SigSetStack + _SigUnblock, "signal 33"}, /* SIGSETXID; see issues 3871, 9400, 12498 */ 26 /* 33 */ {_SigSetStack + _SigUnblock, "signal 33"}, /* SIGSETXID; see issues 3871, 9400, 12498 */
12- /* 34 */ {_SigNotify, "signal 34"}, 27- /* 34 */ {_SigNotify, "signal 34"},
13+ /* 34 */ {_SigSetStack + _SigUnblock, "signal 34"}, /* SIGSYNCCALL (musl); see https://www.openwall.com/lists/musl/2018/10/09/3 */ 28+ /* 34 */ {_SigSetStack + _SigUnblock, "signal 34"}, /* musl SIGSYNCCALL; see issue 39343 */
14 /* 35 */ {_SigNotify, "signal 35"}, 29 /* 35 */ {_SigNotify, "signal 35"},
15 /* 36 */ {_SigNotify, "signal 36"}, 30 /* 36 */ {_SigNotify, "signal 36"},
16 /* 37 */ {_SigNotify, "signal 37"}, 31 /* 37 */ {_SigNotify, "signal 37"},
32diff --git a/src/runtime/sigtab_linux_mipsx.go b/src/runtime/sigtab_linux_mipsx.go
33index 81dd231..51ef470 100644
34--- a/src/runtime/sigtab_linux_mipsx.go
35+++ b/src/runtime/sigtab_linux_mipsx.go
36@@ -42,7 +42,7 @@
37 /* 31 */ {_SigNotify, "SIGXFSZ: file size limit exceeded"},
38 /* 32 */ {_SigSetStack + _SigUnblock, "signal 32"}, /* SIGCANCEL; see issue 6997 */
39 /* 33 */ {_SigSetStack + _SigUnblock, "signal 33"}, /* SIGSETXID; see issues 3871, 9400, 12498 */
40- /* 34 */ {_SigNotify, "signal 34"},
41+ /* 34 */ {_SigSetStack + _SigUnblock, "signal 34"}, /* musl SIGSYNCCALL; see issue 39343 */
42 /* 35 */ {_SigNotify, "signal 35"},
43 /* 36 */ {_SigNotify, "signal 36"},
44 /* 37 */ {_SigNotify, "signal 37"},