aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-06-25 00:06:15 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 04:38:48 +0000
commitd845fd2b834f749605bd9b610d3be9e42d9ff4a9 (patch)
tree8ce13db7bcff45ed3969eb447e9538aac70b1313
parent4295cbb6c42c1689edf03e7046bfafab580a37a3 (diff)
downloadalpine_aports-d845fd2b834f749605bd9b610d3be9e42d9ff4a9.tar.bz2
alpine_aports-d845fd2b834f749605bd9b610d3be9e42d9ff4a9.tar.xz
alpine_aports-d845fd2b834f749605bd9b610d3be9e42d9ff4a9.zip
community/perl-extutils-cppguess: new aport
-rw-r--r--testing/perl-extutils-cppguess/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/perl-extutils-cppguess/APKBUILD b/testing/perl-extutils-cppguess/APKBUILD
new file mode 100644
index 0000000000..ae3405fccc
--- /dev/null
+++ b/testing/perl-extutils-cppguess/APKBUILD
@@ -0,0 +1,36 @@
1# Automatically generated by apkbuild-cpan, template 3
2# Contributor: Timothy Legge <timlegge@gmail.com>
3# Maintainer: Timothy Legge <timlegge@gmail.com>
4pkgname=perl-extutils-cppguess
5#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
6_pkgreal=ExtUtils-CppGuess
7pkgver=0.21
8pkgrel=0
9pkgdesc="guess C++ compiler and flags"
10url="https://metacpan.org/release/ExtUtils-CppGuess/"
11arch="noarch"
12license="GPL-1.0-or-later OR Artistic-1.0-Perl"
13depends="perl perl-capture-tiny"
14makedepends="perl-dev"
15checkdepends="perl-capture-tiny perl-module-build"
16subpackages="$pkgname-doc"
17source="https://cpan.metacpan.org/authors/id/E/ET/ETJ/ExtUtils-CppGuess-$pkgver.tar.gz"
18builddir="$srcdir/$_pkgreal-$pkgver"
19
20build() {
21 export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
22 PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
23 make
24}
25
26check() {
27 export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
28 make test
29}
30
31package() {
32 make DESTDIR="$pkgdir" install
33 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
34}
35
36sha512sums="e48e4815ac9db4e8bb91de101f1d22aed95c770cf6fa2ea5e38094643fe96bc9fe69b0e5a76ba8aa53a653753f93526edab8b1604d864bb2b3a50223617f84d9 ExtUtils-CppGuess-0.21.tar.gz"