aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-06-23 20:35:15 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2020-06-25 16:52:50 +0000
commitf5d3a4f59e553e876d4edd26102c1ecb63aec213 (patch)
tree18b17bd33a7c312868e67d233f5165ad90e7940b
parentff454f56bc12effedea3870fc665aab844343234 (diff)
downloadalpine_aports-f5d3a4f59e553e876d4edd26102c1ecb63aec213.tar.bz2
alpine_aports-f5d3a4f59e553e876d4edd26102c1ecb63aec213.tar.xz
alpine_aports-f5d3a4f59e553e876d4edd26102c1ecb63aec213.zip
community/chezmoi: remove shell completion definitions
they are built-in into abuild now
-rw-r--r--community/chezmoi/APKBUILD44
1 files changed, 10 insertions, 34 deletions
diff --git a/community/chezmoi/APKBUILD b/community/chezmoi/APKBUILD
index 6d0bc3c472..25b4c31d15 100644
--- a/community/chezmoi/APKBUILD
+++ b/community/chezmoi/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org> 2# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
3pkgname=chezmoi 3pkgname=chezmoi
4pkgver=1.8.2 4pkgver=1.8.2
5pkgrel=0 5pkgrel=1
6pkgdesc="Manage your dotfiles across multiple machines, securely." 6pkgdesc="Manage your dotfiles across multiple machines, securely."
7url="https://www.chezmoi.io/" 7url="https://www.chezmoi.io/"
8arch="all !mips !mips64" # go missing 8arch="all !mips !mips64" # go missing
@@ -11,9 +11,9 @@ makedepends="go"
11options="!check chmod-clean" # no test suite 11options="!check chmod-clean" # no test suite
12subpackages=" 12subpackages="
13 $pkgname-doc 13 $pkgname-doc
14 $pkgname-bash-completion:bashcomp:noarch 14 $pkgname-bash-completion
15 $pkgname-zsh-completion:zshcomp:noarch 15 $pkgname-zsh-completion
16 $pkgname-fish-completion:fishcomp:noarch 16 $pkgname-fish-completion
17 " 17 "
18source="$pkgname-$pkgver.tar.gz::https://github.com/twpayne/chezmoi/archive/v$pkgver.tar.gz" 18source="$pkgname-$pkgver.tar.gz::https://github.com/twpayne/chezmoi/archive/v$pkgver.tar.gz"
19 19
@@ -33,6 +33,12 @@ build() {
33 33
34package() { 34package() {
35 install -Dm0755 chezmoi "$pkgdir"/usr/bin/chezmoi 35 install -Dm0755 chezmoi "$pkgdir"/usr/bin/chezmoi
36 install -Dm0644 completions/chezmoi-completion.bash \
37 "$pkgdir"/usr/share/bash-completion/completions/$pkgname
38 install -Dm0644 completions/chezmoi.zsh \
39 "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
40 install -Dm0644 completions/chezmoi.fish \
41 "$pkgdir"/usr/share/fish/completions/$pkgname.fish
36} 42}
37 43
38doc() { 44doc() {
@@ -41,36 +47,6 @@ doc() {
41 cp "$builddir/docs/"* "$subpkgdir/usr/share/doc/chezmoi" 47 cp "$builddir/docs/"* "$subpkgdir/usr/share/doc/chezmoi"
42} 48}
43 49
44bashcomp() {
45 pkgdesc="additional scripts for bash like shell completion"
46 depends=""
47 install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
48
49 cd "$builddir"
50 install -Dm0644 completions/chezmoi-completion.bash \
51 "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
52}
53
54zshcomp() {
55 pkgdesc="additional scripts for zsh like shell completion"
56 depends=""
57 install_if="$pkgname=$pkgver-r$pkgrel zsh"
58
59 cd "$builddir"
60 install -Dm0644 completions/chezmoi.zsh \
61 "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
62}
63
64fishcomp() {
65 pkgdesc="additional scripts for fish like shell completion"
66 depends=""
67 install_if="$pkgname=$pkgver-r$pkgrel fish"
68
69 cd "$builddir"
70 install -Dm0644 completions/chezmoi.fish \
71 "$subpkgdir"/usr/share/fish/completions/$pkgname.fish
72}
73
74cleanup_srcdir() { 50cleanup_srcdir() {
75 go clean -modcache 51 go clean -modcache
76 default_cleanup_srcdir 52 default_cleanup_srcdir