aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-06-25 20:31:20 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 03:16:25 +0000
commitfaac869d552a3f7e46697fe6d7d71fc14e620ebc (patch)
tree1fcfc60e49efed0799461fc773aea6b05fb9b4e4
parent11e50cab8231a87361a73492a342da422eb3293f (diff)
downloadalpine_aports-faac869d552a3f7e46697fe6d7d71fc14e620ebc.tar.bz2
alpine_aports-faac869d552a3f7e46697fe6d7d71fc14e620ebc.tar.xz
alpine_aports-faac869d552a3f7e46697fe6d7d71fc14e620ebc.zip
main/ansible: remove no-op check function
The check function wasn't really running any tests. This change removes a false sense of security.
-rw-r--r--main/ansible/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/main/ansible/APKBUILD b/main/ansible/APKBUILD
index b0442b50a8..b096cbc0e2 100644
--- a/main/ansible/APKBUILD
+++ b/main/ansible/APKBUILD
@@ -7,6 +7,7 @@ pkgver=2.9.9
7pkgrel=0 7pkgrel=0
8pkgdesc="A configuration-management, deployment, task-execution, and multinode orchestration framework" 8pkgdesc="A configuration-management, deployment, task-execution, and multinode orchestration framework"
9url="https://ansible.com/" 9url="https://ansible.com/"
10options="!check" # TODO: enable tests
10arch="noarch" 11arch="noarch"
11license="GPL-3.0-or-later" 12license="GPL-3.0-or-later"
12depends="python3 py3-yaml py3-paramiko py3-jinja2 py3-markupsafe py3-pycryptodome" 13depends="python3 py3-yaml py3-paramiko py3-jinja2 py3-markupsafe py3-pycryptodome"
@@ -49,10 +50,6 @@ build() {
49 python3 setup.py build 50 python3 setup.py build
50} 51}
51 52
52check() {
53 python3 setup.py check
54}
55
56package() { 53package() {
57 python3 setup.py install --prefix=/usr --root="$pkgdir" 54 python3 setup.py install --prefix=/usr --root="$pkgdir"
58 55