aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-03 10:48:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-03 10:48:23 +0000
commit34788a604e8c3058f21aa06b38ffc7c1d8f2fa84 (patch)
treef26ce3eaefb191d63ad12517ee50f2d6f60edf7b
parentf8fca444a81516116a29279b09a401f9482c806e (diff)
downloadalpine_aports-34788a604e8c3058f21aa06b38ffc7c1d8f2fa84.tar.bz2
alpine_aports-34788a604e8c3058f21aa06b38ffc7c1d8f2fa84.tar.xz
alpine_aports-34788a604e8c3058f21aa06b38ffc7c1d8f2fa84.zip
testing/openlldp: build fix in lxc
configure script checks for /proc/dev/net which is not there in lxc
-rw-r--r--testing/openlldp/APKBUILD27
-rw-r--r--testing/openlldp/procfs.patch19
2 files changed, 40 insertions, 6 deletions
diff --git a/testing/openlldp/APKBUILD b/testing/openlldp/APKBUILD
index 651f90c288..868c8870a7 100644
--- a/testing/openlldp/APKBUILD
+++ b/testing/openlldp/APKBUILD
@@ -1,26 +1,32 @@
1# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org> 1# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
2pkgname=openlldp 2pkgname=openlldp
3pkgver=0.4a 3pkgver=0.4a
4_realver=0.4alpha 4_realver=${pkgver/a/alpha}
5pkgrel=2 5pkgrel=2
6pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)" 6pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)"
7url="http://openlldp.sourceforge.net/" 7url="http://openlldp.sourceforge.net/"
8arch="all" 8arch="all"
9license="GPL" 9license="GPL"
10depends= 10depends=
11makedepends= 11makedepends="autoconf automake"
12install= 12install=
13subpackages="" 13subpackages=""
14source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz 14source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz
15 procfs.patch
15 $pkgname.initd 16 $pkgname.initd
16 $pkgname.confd" 17 $pkgname.confd"
17 18
18_builddir="$srcdir"/$pkgname-$_realver 19_builddir="$srcdir"/$pkgname-$_realver
19 20
20#prepare() { 21prepare() {
21# cd "$_builddir" 22 cd "$_builddir"
22# apply patches here 23 for i in $source; do
23#} 24 case $i in
25 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
26 esac
27 done
28 aclocal && autoconf && automake --add-missing || return 1
29}
24 30
25build() { 31build() {
26 cd "$_builddir" 32 cd "$_builddir"
@@ -39,5 +45,14 @@ package() {
39} 45}
40 46
41md5sums="f48ffd632b96246cbf0f5c485dea3b01 openlldp-0.4alpha.tar.gz 47md5sums="f48ffd632b96246cbf0f5c485dea3b01 openlldp-0.4alpha.tar.gz
48c1e81927d2ea0ebcfaee52e79e9122c7 procfs.patch
427e1a489d8ccdd204cac68ce87e0ce360 openlldp.initd 497e1a489d8ccdd204cac68ce87e0ce360 openlldp.initd
437ac497e5a8b2f68532816c5718f5bf62 openlldp.confd" 507ac497e5a8b2f68532816c5718f5bf62 openlldp.confd"
51sha256sums="266fd0e1a15f237cfb84ae2d225996836774ea3d4c1c2e2be3a2a6927a00f2b1 openlldp-0.4alpha.tar.gz
5257726f4157daec0388960c28a014796e8de18a6e1841565f2f64b14f5d4cd02f procfs.patch
539f40286ae7fea71c6e8396bac4bce5e132f399275e5d3d5375ad463ed6b961a2 openlldp.initd
5401b523f3f5e1e9a99518ff309eb965406452aefb5bad024e3735970af884ad6c openlldp.confd"
55sha512sums="5418678a82703a373d5aaeda924ddd34ccb002b5bfc40f243e06f8201fb5407bd46b25aea6d6e2760a1065f0928025e33dcd1dfc42dd9b436d0e5467132b176a openlldp-0.4alpha.tar.gz
561301d9d952ee0f3d8044e5eafd39ea16f9aa671597dc3fea0a57251beabd9e4f140171ddef5e32c5120d3ab42cfeb8878e863d63b4716313e4a94f24c75f0af2 procfs.patch
5793ef1fc1268321a5faf760d07758ee341ba965500c11625f52fc246580e86bff7fbd73a2c1dce276ba07a34a2468c6d4a1c0f2be6b98f425c8330573bb6baa30 openlldp.initd
583817778b61974b17940ea058a1a46f19a432689cc43ab8e9f466bf71de496a61fd9c089a2be9f621556f1376f3a6ec7b8ee35ec820ecbbae0e520bea3079b804 openlldp.confd"
diff --git a/testing/openlldp/procfs.patch b/testing/openlldp/procfs.patch
new file mode 100644
index 0000000000..56ea7b5d31
--- /dev/null
+++ b/testing/openlldp/procfs.patch
@@ -0,0 +1,19 @@
1--- ./configure.ac.orig
2+++ ./configure.ac
3@@ -188,16 +188,6 @@
4 AC_MSG_CHECKING([for platform OS])
5 AC_MSG_RESULT($platform)
6
7-AS_IF([test $framer = "linux"],
8- [ MORELIBS="${MORELIBS} -lm"
9- AC_MSG_CHECKING([for procfs support])
10- if test -r /proc/net/dev; then
11- AC_MSG_RESULT(okay)
12- else
13- AC_MSG_ERROR([You must have ProcFS enabled in your kernel!]);
14- fi],
15- [])
16-
17 AS_IF([test $framer = "generic"],
18 MORELIBS="${MORELIBS} -lwpcap -lpcap -ldnet",
19 [])