aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-03 06:04:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-03 06:04:08 +0000
commitdb344855fd58b2e4d429da927356a247106fb07b (patch)
treeadb884995ab939ca706072d1f5809184fdee4787
parentde32fae3969594f4a3cc7d80edd6cfbb332f1446 (diff)
downloadalpine_aports-db344855fd58b2e4d429da927356a247106fb07b.tar.bz2
alpine_aports-db344855fd58b2e4d429da927356a247106fb07b.tar.xz
alpine_aports-db344855fd58b2e4d429da927356a247106fb07b.zip
testing/rsyslog: remove since we have it in main already
This was moved to main with commit 0ad18dd (main/rsyslog: moved from testing, 2012-05-30) but re-appeared in testing with commit 5f32b2b2 (testing/rsyslog: upgrade to 7.4.1) appearently by mistake.
-rw-r--r--testing/rsyslog/APKBUILD114
-rw-r--r--testing/rsyslog/json-c.patch378
-rw-r--r--testing/rsyslog/rsyslog.conf87
-rw-r--r--testing/rsyslog/rsyslog.confd17
-rw-r--r--testing/rsyslog/rsyslog.initd39
-rw-r--r--testing/rsyslog/rsyslog.logrotate9
6 files changed, 0 insertions, 644 deletions
diff --git a/testing/rsyslog/APKBUILD b/testing/rsyslog/APKBUILD
deleted file mode 100644
index 45bf3737b2..0000000000
--- a/testing/rsyslog/APKBUILD
+++ /dev/null
@@ -1,114 +0,0 @@
1# Maintainer: Cameron Banta <cbanta@gmail.com>
2# Contributor: cbanta@gmail.com
3pkgname=rsyslog
4pkgver=7.4.1
5pkgrel=1
6pkgdesc="Enhanced multi-threaded syslogd with database support and more."
7url="http://www.rsyslog.com/"
8arch="all"
9license="GPLv3 LGPL-3"
10makedepends="zlib-dev gnutls-dev mysql-dev postgresql-dev net-snmp-dev
11 libnet-dev libgcrypt-dev libee-dev libestr-dev json-c-dev
12 util-linux-dev
13 autoconf automake libtool"
14subpackages="$pkgname-doc $pkgname-mysql $pkgname-pgsql $pkgname-tls $pkgname-snmp"
15source="http://www.rsyslog.com/files/download/$pkgname/$pkgname-$pkgver.tar.gz
16 json-c.patch
17 $pkgname.initd
18 $pkgname.confd
19 $pkgname.logrotate
20 $pkgname.conf"
21
22
23_builddir="$srcdir"/$pkgname-$pkgver
24
25prepare() {
26 cd "$_builddir"
27 for i in $source; do
28 case $i in
29 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
30 esac
31 done
32 libtoolize --force && aclocal && autoconf && automake --add-missing \
33 || return 1
34}
35
36build() {
37 cd "$_builddir"
38 export LDFLAGS="-lestr"
39 ./configure \
40 --disable-gui \
41 --disable-rfc3195 \
42 --enable-largefile \
43 --enable-imdiag \
44 --enable-imfile \
45 --enable-mail \
46 --enable-omprog \
47 --enable-omstdout \
48 --enable-omudpspoof \
49 --enable-zlib \
50 --enable-mysql \
51 --enable-pgsql \
52 --enable-gnutls \
53 --enable-snmp \
54 --prefix=/usr \
55 --sysconfdir=/etc \
56 --enable-cached-man-pages \
57 --mandir=/usr/share/man \
58 --infodir=/usr/share/info
59 make || return 1
60}
61
62package() {
63 cd "$_builddir"
64 make DESTDIR="$pkgdir" install
65 rm -f "$pkgdir"/usr/lib/rsyslog/*.la || return 1
66
67 install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
68 install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
69 install -m644 -D "$srcdir"/$pkgname.logrotate "$pkgdir"/etc/logrotate.d/$pkgname
70 install -m644 -D "$srcdir"/$pkgname.conf "$pkgdir"/etc/$pkgname.conf
71}
72
73mysql() {
74 pkgdesc="rsyslog mysql support"
75 mkdir -p "$subpkgdir"/usr/lib/rsyslog/
76 mv "$pkgdir"/usr/lib/rsyslog/ommysql.so "$subpkgdir"/usr/lib/rsyslog/
77}
78
79pgsql() {
80 pkgdesc="rsyslog pgsql support"
81 mkdir -p "$subpkgdir"/usr/lib/rsyslog/
82 mv "$pkgdir"/usr/lib/rsyslog/ompgsql.so "$subpkgdir"/usr/lib/rsyslog/
83}
84
85tls() {
86 pkgdesc="rsyslog tls support"
87 mkdir -p "$subpkgdir"/usr/lib/rsyslog/
88 mv "$pkgdir"/usr/lib/rsyslog/lmnsd_gtls.so "$subpkgdir"/usr/lib/rsyslog/
89}
90
91snmp() {
92 pkgdesc="rsyslog snmp support"
93 mkdir -p "$subpkgdir"/usr/lib/rsyslog/
94 mv "$pkgdir"/usr/lib/rsyslog/omsnmp.so "$subpkgdir"/usr/lib/rsyslog/
95}
96
97md5sums="8e0e868a425bfa5c2c13bdc28338e1af rsyslog-7.4.1.tar.gz
9835bebdd2ad3b9ab1249093429dc52475 json-c.patch
996b63d774eb718bc1ab91f3fb5471ade3 rsyslog.initd
1000a0aef98f677364e6178c34274df7723 rsyslog.confd
101bc43debc9ffdf66bc1409025fd3d1176 rsyslog.logrotate
10265fbf5a7a81a53a70974e3085e96cb41 rsyslog.conf"
103sha256sums="f890b56fc5122fabf79994e11bdefb26285e3415ba80c20f23bd3ce489098c96 rsyslog-7.4.1.tar.gz
10439aa50b44b4746cbf5816f98457da2125c3a833fdf6bb87f7b2c1c0961189e6a json-c.patch
105dfe1c50766df7bf862507f8f0819e01f78c3054e57e8c4db1f16b3874a04094c rsyslog.initd
106c476c2180fcceaf581d26d2da6201fbe7a2b9fc89c58456fdb3bdaf18a4cbb56 rsyslog.confd
107f0effc19bd1f1bfa367d65d6516c73509cb34545157b9e91cf6e437685dd3fe5 rsyslog.logrotate
108559a8221d2ef9376a77e08de05206f3d2214a81fa88649f5bca2a1207f8918c5 rsyslog.conf"
109sha512sums="c74de170ee83725d8e89712e9a980569e8331d776b52e773d6eeff33dff0c524691378c0d469096691846beffdaf46fab9be706873679588d0afc4cb83f9a663 rsyslog-7.4.1.tar.gz
1102f0e8443e6d76ef016b4f63b4d16fc81b58894ef7725bd661344fc175fceabccbe135c964fbbeeb1704ac04792c08b1709aa15bc84127a959891551827fedd21 json-c.patch
111e35f07e9ce499b874bcc441cb3fa1f7a1c545bc72fec24f96debfbe00dff4d0a27d987c7cc70fd160c718bd25d9a0d291c241fc527aeef897842b7c8a48b35d3 rsyslog.initd
112c216674e6867d655c2c09b6205071591ae2b1611ad5dd0346e682733abafa8a1be261fdd9bb985bb5d05d5bfa708a68262b1a94e654a2c18d352fd02d6f950a3 rsyslog.confd
113d54377ddf39197656811a84272568ea761f984e19dd04fc54f372dd04a9244e66d02b26ab33073d0344d054f031660ec611f3c7a18c266e7b68cef5e2c47f06f rsyslog.logrotate
114032ccce1850bc89fb37b4b23f1607ce73086ff2b057838a1b83e36751ee0412c537fc0c9cbc2c6e8098311e6a04569c7fc7f7dea80111e8c8623b3b0cc3cccd1 rsyslog.conf"
diff --git a/testing/rsyslog/json-c.patch b/testing/rsyslog/json-c.patch
deleted file mode 100644
index 8c5e311196..0000000000
--- a/testing/rsyslog/json-c.patch
+++ /dev/null
@@ -1,378 +0,0 @@
1diff --git a/Makefile.am b/Makefile.am
2index ed3b54b..c0093d0 100644
3--- a/Makefile.am
4+++ b/Makefile.am
5@@ -14,7 +14,7 @@ lmtcpsrv_la_SOURCES = \
6 tcps_sess.h \
7 tcpsrv.c \
8 tcpsrv.h
9-lmtcpsrv_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
10+lmtcpsrv_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
11 lmtcpsrv_la_LDFLAGS = -module -avoid-version
12 lmtcpsrv_la_LIBADD =
13
14diff --git a/action.c b/action.c
15index 259fb66..6b52d70 100644
16--- a/action.c
17+++ b/action.c
18@@ -98,7 +98,7 @@
19 #include <strings.h>
20 #include <time.h>
21 #include <errno.h>
22-#include <json/json.h>
23+#include <json.h>
24
25 #include "dirty.h"
26 #include "template.h"
27diff --git a/config.h.in b/config.h.in
28index 3682381..8c504b5 100644
29--- a/config.h.in
30+++ b/config.h.in
31@@ -349,9 +349,6 @@
32 /* Defined if debug mode is disabled. */
33 #undef NDEBUG
34
35-/* Define to 1 if your C compiler doesn't accept -c and -o together. */
36-#undef NO_MINUS_C_MINUS_O
37-
38 /* Indicator for a BSD OS */
39 #undef OS_BSD
40
41diff --git a/configure.ac b/configure.ac
42index bb0de0c..acf2cbe 100644
43--- a/configure.ac
44+++ b/configure.ac
45@@ -33,7 +33,7 @@ PKG_PROG_PKG_CONFIG
46
47 # modules we require
48 PKG_CHECK_MODULES(LIBESTR, libestr >= 0.1.5)
49-PKG_CHECK_MODULES([JSON_C], [json])
50+PKG_CHECK_MODULES([JSON_C], [json-c])
51
52 case "${host}" in
53 *-*-linux*)
54diff --git a/grammar/Makefile.am b/grammar/Makefile.am
55index d231bb4..b5476e7 100644
56--- a/grammar/Makefile.am
57+++ b/grammar/Makefile.am
58@@ -11,7 +11,7 @@ libgrammar_la_SOURCES = \
59 rainerscript.h \
60 parserif.h \
61 grammar.h
62-libgrammar_la_CPPFLAGS = $(RSRT_CFLAGS)
63+libgrammar_la_CPPFLAGS = $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
64
65 #testdriver_SOURCES = testdriver.c libgrammar.la
66 #testdriver_CPPFLAGS = $(RSRT_CFLAGS)
67diff --git a/plugins/imdiag/Makefile.am b/plugins/imdiag/Makefile.am
68index 33e86e9..b8d21ae 100644
69--- a/plugins/imdiag/Makefile.am
70+++ b/plugins/imdiag/Makefile.am
71@@ -1,6 +1,6 @@
72 pkglib_LTLIBRARIES = imdiag.la
73
74 imdiag_la_SOURCES = imdiag.c
75-imdiag_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
76+imdiag_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
77 imdiag_la_LDFLAGS = -module -avoid-version
78 imdiag_la_LIBADD =
79diff --git a/plugins/imfile/Makefile.am b/plugins/imfile/Makefile.am
80index 551639b..3c70868 100644
81--- a/plugins/imfile/Makefile.am
82+++ b/plugins/imfile/Makefile.am
83@@ -1,6 +1,6 @@
84 pkglib_LTLIBRARIES = imfile.la
85
86 imfile_la_SOURCES = imfile.c
87-imfile_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
88+imfile_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
89 imfile_la_LDFLAGS = -module -avoid-version
90 imfile_la_LIBADD =
91diff --git a/plugins/imklog/Makefile.am b/plugins/imklog/Makefile.am
92index 7d0d37c..ae84737 100644
93--- a/plugins/imklog/Makefile.am
94+++ b/plugins/imklog/Makefile.am
95@@ -10,6 +10,6 @@ if ENABLE_IMKLOG_LINUX
96 imklog_la_SOURCES += bsd.c
97 endif
98
99-imklog_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
100+imklog_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
101 imklog_la_LDFLAGS = -module -avoid-version
102 imklog_la_LIBADD =
103diff --git a/plugins/immark/Makefile.am b/plugins/immark/Makefile.am
104index 6d8ed24..782dacc 100644
105--- a/plugins/immark/Makefile.am
106+++ b/plugins/immark/Makefile.am
107@@ -1,6 +1,6 @@
108 pkglib_LTLIBRARIES = immark.la
109
110 immark_la_SOURCES = immark.c immark.h
111-immark_la_CPPFLAGS = $(RSRT_CFLAGS) -I$(top_srcdir) $(PTHREADS_CFLAGS)
112+immark_la_CPPFLAGS = $(RSRT_CFLAGS) -I$(top_srcdir) $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS)
113 immark_la_LDFLAGS = -module -avoid-version
114 immark_la_LIBADD =
115diff --git a/plugins/imtcp/Makefile.am b/plugins/imtcp/Makefile.am
116index 2665353..24ec856 100644
117--- a/plugins/imtcp/Makefile.am
118+++ b/plugins/imtcp/Makefile.am
119@@ -1,6 +1,6 @@
120 pkglib_LTLIBRARIES = imtcp.la
121
122 imtcp_la_SOURCES = imtcp.c
123-imtcp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
124+imtcp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
125 imtcp_la_LDFLAGS = -module -avoid-version
126 imtcp_la_LIBADD =
127diff --git a/plugins/imudp/Makefile.am b/plugins/imudp/Makefile.am
128index bc64b8c..8409f86 100644
129--- a/plugins/imudp/Makefile.am
130+++ b/plugins/imudp/Makefile.am
131@@ -1,6 +1,6 @@
132 pkglib_LTLIBRARIES = imudp.la
133
134 imudp_la_SOURCES = imudp.c
135-imudp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
136+imudp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
137 imudp_la_LDFLAGS = -module -avoid-version
138 imudp_la_LIBADD = $(IMUDP_LIBS)
139diff --git a/plugins/imuxsock/Makefile.am b/plugins/imuxsock/Makefile.am
140index 28f9f9e..3db3a58 100644
141--- a/plugins/imuxsock/Makefile.am
142+++ b/plugins/imuxsock/Makefile.am
143@@ -1,6 +1,6 @@
144 pkglib_LTLIBRARIES = imuxsock.la
145
146 imuxsock_la_SOURCES = imuxsock.c
147-imuxsock_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
148+imuxsock_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
149 imuxsock_la_LDFLAGS = -module -avoid-version
150 imuxsock_la_LIBADD = $(RSRT_LIBS)
151diff --git a/plugins/ommail/Makefile.am b/plugins/ommail/Makefile.am
152index 97c9296..6a178e0 100644
153--- a/plugins/ommail/Makefile.am
154+++ b/plugins/ommail/Makefile.am
155@@ -1,6 +1,6 @@
156 pkglib_LTLIBRARIES = ommail.la
157
158 ommail_la_SOURCES = ommail.c
159-ommail_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
160+ommail_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
161 ommail_la_LDFLAGS = -module -avoid-version
162 ommail_la_LIBADD =
163diff --git a/plugins/ommysql/Makefile.am b/plugins/ommysql/Makefile.am
164index e253b9d..f2336d0 100644
165--- a/plugins/ommysql/Makefile.am
166+++ b/plugins/ommysql/Makefile.am
167@@ -1,7 +1,7 @@
168 pkglib_LTLIBRARIES = ommysql.la
169
170 ommysql_la_SOURCES = ommysql.c ommysql.h
171-ommysql_la_CPPFLAGS = $(RSRT_CFLAGS) $(MYSQL_CFLAGS) $(PTHREADS_CFLAGS)
172+ommysql_la_CPPFLAGS = $(RSRT_CFLAGS) $(MYSQL_CFLAGS) $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS)
173 ommysql_la_LDFLAGS = -module -avoid-version
174 ommysql_la_LIBADD = $(MYSQL_LIBS)
175
176diff --git a/plugins/ompgsql/Makefile.am b/plugins/ompgsql/Makefile.am
177index 607239c..664d3d1 100644
178--- a/plugins/ompgsql/Makefile.am
179+++ b/plugins/ompgsql/Makefile.am
180@@ -1,7 +1,7 @@
181 pkglib_LTLIBRARIES = ompgsql.la
182
183 ompgsql_la_SOURCES = ompgsql.c ompgsql.h
184-ompgsql_la_CPPFLAGS = -I$(top_srcdir) $(PGSQL_CFLAGS) $(RSRT_CFLAGS)
185+ompgsql_la_CPPFLAGS = -I$(top_srcdir) $(PGSQL_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
186 ompgsql_la_LDFLAGS = -module -avoid-version
187 ompgsql_la_LIBADD = $(PGSQL_LIBS)
188
189diff --git a/plugins/omprog/Makefile.am b/plugins/omprog/Makefile.am
190index 63fe09b..2d7e89b 100644
191--- a/plugins/omprog/Makefile.am
192+++ b/plugins/omprog/Makefile.am
193@@ -1,7 +1,7 @@
194 pkglib_LTLIBRARIES = omprog.la
195
196 omprog_la_SOURCES = omprog.c
197-omprog_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
198+omprog_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS)
199 omprog_la_LDFLAGS = -module -avoid-version
200 omprog_la_LIBADD =
201
202diff --git a/plugins/omruleset/Makefile.am b/plugins/omruleset/Makefile.am
203index fdd91a6..c927dca 100644
204--- a/plugins/omruleset/Makefile.am
205+++ b/plugins/omruleset/Makefile.am
206@@ -1,7 +1,7 @@
207 pkglib_LTLIBRARIES = omruleset.la
208
209 omruleset_la_SOURCES = omruleset.c
210-omruleset_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
211+omruleset_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS)
212 omruleset_la_LDFLAGS = -module -avoid-version
213 omruleset_la_LIBADD =
214
215diff --git a/plugins/omsnmp/Makefile.am b/plugins/omsnmp/Makefile.am
216index f75fb09..12c3083 100644
217--- a/plugins/omsnmp/Makefile.am
218+++ b/plugins/omsnmp/Makefile.am
219@@ -1,6 +1,6 @@
220 pkglib_LTLIBRARIES = omsnmp.la
221
222 omsnmp_la_SOURCES = omsnmp.c omsnmp.h
223-omsnmp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
224+omsnmp_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
225 omsnmp_la_LDFLAGS = -module -avoid-version
226 omsnmp_la_LIBADD = $(SNMP_LIBS)
227diff --git a/plugins/omstdout/Makefile.am b/plugins/omstdout/Makefile.am
228index 9f5d497..c4d9bcb 100644
229--- a/plugins/omstdout/Makefile.am
230+++ b/plugins/omstdout/Makefile.am
231@@ -1,7 +1,7 @@
232 pkglib_LTLIBRARIES = omstdout.la
233
234 omstdout_la_SOURCES = omstdout.c
235-omstdout_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
236+omstdout_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS)
237 omstdout_la_LDFLAGS = -module -avoid-version
238 omstdout_la_LIBADD =
239
240diff --git a/plugins/omtesting/Makefile.am b/plugins/omtesting/Makefile.am
241index 4700e1e..2ee9017 100644
242--- a/plugins/omtesting/Makefile.am
243+++ b/plugins/omtesting/Makefile.am
244@@ -1,6 +1,6 @@
245 pkglib_LTLIBRARIES = omtesting.la
246
247 omtesting_la_SOURCES = omtesting.c
248-omtesting_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
249+omtesting_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
250 omtesting_la_LDFLAGS = -module -avoid-version
251 omtesting_la_LIBADD =
252diff --git a/plugins/omudpspoof/Makefile.am b/plugins/omudpspoof/Makefile.am
253index 79c495a..ff3c213 100644
254--- a/plugins/omudpspoof/Makefile.am
255+++ b/plugins/omudpspoof/Makefile.am
256@@ -1,7 +1,7 @@
257 pkglib_LTLIBRARIES = omudpspoof.la
258
259 omudpspoof_la_SOURCES = omudpspoof.c
260-omudpspoof_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS) $(UDPSPOOF_CFLAGS)
261+omudpspoof_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS) $(UDPSPOOF_CFLAGS) $(JSON_C_CFLAGS)
262 omudpspoof_la_LDFLAGS = -module -avoid-version
263 omudpspoof_la_LIBADD = $(UDPSPOOF_LIBS)
264
265diff --git a/runtime/Makefile.am b/runtime/Makefile.am
266index dea06fe..99b0022 100644
267--- a/runtime/Makefile.am
268+++ b/runtime/Makefile.am
269@@ -97,9 +97,9 @@ librsyslog_la_SOURCES = \
270 #
271
272 if WITH_MODDIRS
273-librsyslog_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -D_PATH_MODDIR=\"$(pkglibdir)/:$(moddirs)\" $(PTHREADS_CFLAGS) -I\$(top_srcdir)/tools
274+librsyslog_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -D_PATH_MODDIR=\"$(pkglibdir)/:$(moddirs)\" $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS) -I\$(top_srcdir)/tools
275 else
276-librsyslog_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(PTHREADS_CFLAGS) -I\$(top_srcdir)/tools -I\$(top_srcdir)/grammar
277+librsyslog_la_CPPFLAGS = -DSD_EXPORT_SYMBOLS -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(PTHREADS_CFLAGS) $(JSON_C_CFLAGS) -I\$(top_srcdir)/tools -I\$(top_srcdir)/grammar
278 endif
279 #librsyslog_la_LDFLAGS = -module -avoid-version
280 librsyslog_la_LIBADD = $(DL_LIBS) $(RT_LIBS)
281@@ -148,7 +148,7 @@ lmnetstrms_la_LIBADD =
282 # generic stream server framework
283 pkglib_LTLIBRARIES += lmstrmsrv.la
284 lmstrmsrv_la_SOURCES = strmsrv.c strmsrv.h strms_sess.c strms_sess.h
285-lmstrmsrv_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
286+lmstrmsrv_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
287 lmstrmsrv_la_LDFLAGS = -module -avoid-version
288 lmstrmsrv_la_LIBADD =
289
290@@ -159,7 +159,7 @@ pkglib_LTLIBRARIES += lmnsd_ptcp.la
291 lmnsd_ptcp_la_SOURCES = nsd_ptcp.c nsd_ptcp.h \
292 nsdsel_ptcp.c nsdsel_ptcp.h \
293 nsdpoll_ptcp.c nsdpoll_ptcp.h
294-lmnsd_ptcp_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
295+lmnsd_ptcp_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
296 lmnsd_ptcp_la_LDFLAGS = -module -avoid-version
297 lmnsd_ptcp_la_LIBADD =
298 endif # if ENABLE_INET
299@@ -181,10 +181,10 @@ endif
300 if ENABLE_LIBGCRYPT
301 noinst_LTLIBRARIES += libgcry.la
302 libgcry_la_SOURCES = libgcry.c libgcry_common.c libgcry.h
303- libgcry_la_CPPFLAGS = $(RSRT_CFLAGS) $(LIBGCRYPT_CFLAGS)
304+ libgcry_la_CPPFLAGS = $(RSRT_CFLAGS) $(LIBGCRYPT_CFLAGS) $(JSON_C_CFLAGS)
305 pkglib_LTLIBRARIES += lmcry_gcry.la
306 lmcry_gcry_la_SOURCES = lmcry_gcry.c lmcry_gcry.h
307- lmcry_gcry_la_CPPFLAGS = $(RSRT_CFLAGS) $(LIBGCRYPT_CFLAGS)
308+ lmcry_gcry_la_CPPFLAGS = $(RSRT_CFLAGS) $(LIBGCRYPT_CFLAGS) $(JSON_C_CFLAGS)
309 lmcry_gcry_la_LDFLAGS = -module -avoid-version
310 lmcry_gcry_la_LIBADD = libgcry.la $(LIBGCRYPT_LIBS)
311 endif
312diff --git a/runtime/msg.c b/runtime/msg.c
313index a5c5281..4ca104e 100644
314--- a/runtime/msg.c
315+++ b/runtime/msg.c
316@@ -41,9 +41,7 @@
317 #endif
318 #include <netdb.h>
319 #include <libestr.h>
320-#include <json/json.h>
321-/* For struct json_object_iter, should not be necessary in future versions */
322-#include <json/json_object_private.h>
323+#include <json.h>
324 #if HAVE_MALLOC_H
325 # include <malloc.h>
326 #endif
327diff --git a/runtime/msg.h b/runtime/msg.h
328index 6faf066..ac220b6 100644
329--- a/runtime/msg.h
330+++ b/runtime/msg.h
331@@ -30,7 +30,7 @@
332
333 #include <pthread.h>
334 #include <libestr.h>
335-#include <json/json.h>
336+#include <json.h>
337 #include "obj.h"
338 #include "syslogd-types.h"
339 #include "template.h"
340diff --git a/template.c b/template.c
341index b675255..9cefa05 100644
342--- a/template.c
343+++ b/template.c
344@@ -34,7 +34,7 @@
345 #include <string.h>
346 #include <ctype.h>
347 #include <assert.h>
348-#include <json/json.h>
349+#include <json.h>
350 #include "stringbuf.h"
351 #include "syslogd-types.h"
352 #include "template.h"
353diff --git a/template.h b/template.h
354index 318db6f..87a1c77 100644
355--- a/template.h
356+++ b/template.h
357@@ -30,7 +30,7 @@
358 #ifndef TEMPLATE_H_INCLUDED
359 #define TEMPLATE_H_INCLUDED 1
360
361-#include <json/json.h>
362+#include <json.h>
363 #include <libestr.h>
364 #include "regexp.h"
365 #include "stringbuf.h"
366diff --git a/tools/Makefile.am b/tools/Makefile.am
367index 6832494..76c13cc 100644
368--- a/tools/Makefile.am
369+++ b/tools/Makefile.am
370@@ -38,7 +38,7 @@ rsyslogd_SOURCES = \
371 pidfile.h \
372 \
373 ../dirty.h
374-rsyslogd_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
375+rsyslogd_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) $(JSON_C_CFLAGS)
376 # note: it looks like librsyslog.la must be explicitely given on LDDADD,
377 # otherwise dependencies are not properly calculated (resulting in a
378 # potentially incomplete build, a problem we had several times...)
diff --git a/testing/rsyslog/rsyslog.conf b/testing/rsyslog/rsyslog.conf
deleted file mode 100644
index 19187467b3..0000000000
--- a/testing/rsyslog/rsyslog.conf
+++ /dev/null
@@ -1,87 +0,0 @@
1# rsyslog v5: load input modules
2# If you do not load inputs, nothing happens!
3# You may need to set the module load path if modules are not found.
4
5$ModLoad immark.so # provides --MARK-- message capability
6$ModLoad imuxsock.so # provides support for local system logging (e.g. via logger command)
7$ModLoad imklog.so # kernel logging (formerly provided by rklogd)
8
9# Include configuration files from directory
10$IncludeConfig /etc/rsyslog.d/*
11
12# Check config syntax on startup and abort if unclean (default off)
13#$AbortOnUncleanConfig on
14
15# Reduce repeating messages (default off)
16#$RepeatedMsgReduction on
17
18# Log all kernel messages to the console.
19# Logging much else clutters up the screen.
20#kern.* /dev/console
21
22# Log anything (except mail) of level info or higher.
23# Don't log private authentication messages!
24*.info;mail.none;authpriv.none;cron.none -/var/log/messages
25
26# The authpriv file has restricted access.
27authpriv.* /var/log/secure
28
29# Log all the mail messages in one place.
30mail.* -/var/log/maillog
31
32# Log cron stuff
33cron.* -/var/log/cron
34
35# Everybody gets emergency messages
36*.emerg *
37
38# Save news errors of level crit and higher in a special file.
39uucp,news.crit -/var/log/spooler
40
41# Save boot messages also to boot.log
42local7.* /var/log/boot.log
43
44# More configuration examples:
45#
46# Remote Logging (we use TCP for reliable delivery)
47# An on-disk queue is created for this action. If the remote host is
48# down, messages are spooled to disk and sent when it is up again.
49#$WorkDirectory /var/spool/rsyslog # where to place spool files
50#$ActionQueueFileName uniqName # unique name prefix for spool files
51#$ActionQueueMaxDiskSpace 1g # 1gb space limit (use as much as possible)
52#$ActionQueueSaveOnShutdown on # save messages to disk on shutdown
53#$ActionQueueType LinkedList # run asynchronously
54#$ActionResumeRetryCount -1 # infinety retries if host is down
55#$ActionResumeInterval 30 # retry interval
56# remote host is: name/ip:port, e.g. 192.168.0.1:514, port optional
57#*.* @@remote-host
58
59# Remote Logging with TCP + SSL/TLS
60#$DefaultNetstreamDriver gtls
61#$DefaultNetstreamDriverCAFile /etc/ssl/rsyslog/rsyslog_ca.cert.pem
62#$DefaultNetstreamDriverCertFile /etc/ssl/rsyslog/rsyslog_CLIENT.cert.pem
63#$DefaultNetstreamDriverKeyFile /etc/ssl/rsyslog/rsyslog_CLIENT.key.pem
64#$ActionSendStreamDriverAuthMode x509/name # enable peer authentication
65#$ActionSendStreamDriverPermittedPeer foo # authorize to send encrypted data to server foo
66#$ActionSendStreamDriverMode 1 # run driver in TLS-only mode
67
68# ######### Receiving Messages from Remote Hosts ##########
69# TCP Syslog Server:
70#$ModLoad imtcp # provides TCP syslog reception
71#$TCPServerRun 10514 # start a TCP syslog server at port 10514
72
73# TCP + SSL/TLS Syslog Server:
74#$ModLoad imtcp # provides TCP syslog reception
75#$DefaultNetstreamDriver gtls # use gnuTLS for data encryption
76#$DefaultNetstreamDriverCAFile /etc/ssl/rsyslog/rsyslog_ca.cert.pem
77#$DefaultNetstreamDriverCertFile /etc/ssl/rsyslog/rsyslog_SERVER.cert.pem
78#$DefaultNetstreamDriverKeyFile /etc/ssl/rsyslog/rsyslog_SERVER.key.pem
79#$InputTCPServerStreamDriverMode 1 # run driver in TLS-only mode
80#$InputTCPServerStreamDriverAuthMode x509/name # enable peer authentication
81#$InputTCPServerStreamDriverPermittedPeer bar # authorize client named bar (one line per client)
82#$TCPServerRun 10514 # start a TCP syslog server at port 10514
83
84# UDP Syslog Server:
85#$ModLoad imudp.so # provides UDP syslog reception
86#$UDPServerRun 514 # start a UDP syslog server at standard port 514
87
diff --git a/testing/rsyslog/rsyslog.confd b/testing/rsyslog/rsyslog.confd
deleted file mode 100644
index 85e90edc07..0000000000
--- a/testing/rsyslog/rsyslog.confd
+++ /dev/null
@@ -1,17 +0,0 @@
1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/app-admin/rsyslog/files/5-stable/rsyslog.confd,v 1.1 2010/10/21 07:38:29 dev-zero Exp $
4
5# Configuration file
6CONFIGFILE="/etc/rsyslog.conf"
7
8# PID file
9PIDFILE="/var/run/rsyslogd.pid"
10
11# Options to rsyslogd
12# See rsyslogd(8) for more details
13# Notes:
14# * Do not specify another PIDFILE but use the variable above to change the location
15# * Do not specify another CONFIGFILE but use the variable above to change the location
16# * "-c5" tells rsyslog to _not_ run in sysklogd compatibility mode
17RSYSLOG_OPTS="-c5"
diff --git a/testing/rsyslog/rsyslog.initd b/testing/rsyslog/rsyslog.initd
deleted file mode 100644
index 5671f19dbc..0000000000
--- a/testing/rsyslog/rsyslog.initd
+++ /dev/null
@@ -1,39 +0,0 @@
1#!/sbin/runscript
2# Copyright 1999-2010 Gentoo Foundation
3# Distributed under the terms of the GNU General Public License v2
4# $Header: /var/cvsroot/gentoo-x86/app-admin/rsyslog/files/5-stable/rsyslog.initd,v 1.1 2010/10/21 07:38:29 dev-zero Exp $
5
6extra_started_commands="reload"
7
8depend() {
9 need clock hostname localmount
10 provide logger
11}
12
13start() {
14 ebegin "Starting rsyslogd"
15 start-stop-daemon \
16 --start --quiet --exec /usr/sbin/rsyslogd \
17 -- ${RSYSLOG_OPTS} -i "${PIDFILE}" -f "${CONFIGFILE}"
18 eend $?
19}
20
21stop() {
22 ebegin "Stopping rsyslogd"
23 start-stop-daemon \
24 --stop --quiet \
25 --pidfile "${PIDFILE}"
26 eend $?
27}
28
29reload() {
30 if [ ! -f "${PIDFILE}" ]; then
31 eerror "rsyslogd not running"
32 return 1
33 fi
34
35 ebegin "Re-opening rsyslogd log files"
36 start-stop-daemon --stop --signal HUP \
37 --pidfile "${PIDFILE}"
38 eend $?
39}
diff --git a/testing/rsyslog/rsyslog.logrotate b/testing/rsyslog/rsyslog.logrotate
deleted file mode 100644
index 86095def1c..0000000000
--- a/testing/rsyslog/rsyslog.logrotate
+++ /dev/null
@@ -1,9 +0,0 @@
1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/app-admin/rsyslog/files/5-stable/rsyslog.logrotate,v 1.1 2010/10/21 07:38:29 dev-zero Exp $
4/var/log/messages /var/log/secure /var/log/maillog /var/log/cron /var/log/spooler /var/log/boot.log {
5 sharedscripts
6 postrotate
7 /etc/init.d/rsyslog reload &>/dev/null || true
8 endscript
9}