aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-06-03 14:16:10 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-06-03 14:18:15 +0200
commitdfbaeba59fa9e3a19bc912f7d30c0e05c12033f1 (patch)
tree1c150484ea000e7c877b9dc05e1b0c70d0a9cd2f
parent9f9b6f52f31fb032b8ba02161e920e81dbc53271 (diff)
downloadalpine_aports-dfbaeba59fa9e3a19bc912f7d30c0e05c12033f1.tar.bz2
alpine_aports-dfbaeba59fa9e3a19bc912f7d30c0e05c12033f1.tar.xz
alpine_aports-dfbaeba59fa9e3a19bc912f7d30c0e05c12033f1.zip
testing/nebula: move back to testing and fix musl build
-rw-r--r--testing/nebula/APKBUILD (renamed from unmaintained/nebula/APKBUILD)12
-rw-r--r--testing/nebula/musl-fixes.patch32
2 files changed, 41 insertions, 3 deletions
diff --git a/unmaintained/nebula/APKBUILD b/testing/nebula/APKBUILD
index 4dd3e5c228..9e66f7dfa6 100644
--- a/unmaintained/nebula/APKBUILD
+++ b/testing/nebula/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch> 2# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
3pkgname=nebula 3pkgname=nebula
4pkgver=0.2.3 4pkgver=0.2.3
5pkgrel=0 5pkgrel=1
6pkgdesc="An Intrusion Signature Generator" 6pkgdesc="An Intrusion Signature Generator"
7url="http://nebula.carnivore.it/" 7url="http://nebula.carnivore.it/"
8arch="all" 8arch="all"
@@ -12,7 +12,8 @@ depends_dev=""
12makedepends="zlib-dev" 12makedepends="zlib-dev"
13install="" 13install=""
14subpackages="$pkgname-client" 14subpackages="$pkgname-client"
15source="http://downloads.sourceforge.net/nebula/$pkgname-$pkgver.tar.gz" 15source="http://downloads.sourceforge.net/nebula/$pkgname-$pkgver.tar.gz
16 musl-fixes.patch"
16_builddir="$srcdir"/$pkgname-$pkgver 17_builddir="$srcdir"/$pkgname-$pkgver
17 18
18prepare() { 19prepare() {
@@ -48,4 +49,9 @@ client() {
48 mv "$pkgdir"/usr/bin/"$pkgname"client "$subpkgdir"/usr/bin/ 49 mv "$pkgdir"/usr/bin/"$pkgname"client "$subpkgdir"/usr/bin/
49} 50}
50 51
51md5sums="06eabd66634e7969203465fb94900f18 nebula-0.2.3.tar.gz" 52md5sums="06eabd66634e7969203465fb94900f18 nebula-0.2.3.tar.gz
53393c6ba03578214aa720cd8a703d8b1b musl-fixes.patch"
54sha256sums="6d90fe1c5c1d81045134485e8ee4e888e9fce5d4323a2b6b321bf8a9765fc856 nebula-0.2.3.tar.gz
55e35212e0b65711fd9ead733e15fe76c79a15de7ac7c417a4c26df400df6f590b musl-fixes.patch"
56sha512sums="9202be7ca3c78e7dadf559180a3a9a331ed0ddd4b04aa16ac0c65856f513e600e4e04b7908d4be412360c3fc7e91a286723be1151c74333f0111a4307e323023 nebula-0.2.3.tar.gz
57790c3682e3a32da44e83bcfc44c1483b866d526efdfee6522a42878a9ac3aab65341515c9a080e22e44f5e9daff3b4c55c3e53da6ee68e6580df74850e3b44dd musl-fixes.patch"
diff --git a/testing/nebula/musl-fixes.patch b/testing/nebula/musl-fixes.patch
new file mode 100644
index 0000000000..a23d8a1a0f
--- /dev/null
+++ b/testing/nebula/musl-fixes.patch
@@ -0,0 +1,32 @@
1--- nebula-0.2.3/src/hash.h
2+++ nebula-0.2.3/src/hash.h
3@@ -24,7 +24,7 @@
4 #if HAVE_CONFIG_H
5 # include <config.h>
6 #endif
7-
8+#include "sys/types.h"
9
10 struct cluster;
11
12--- nebula-0.2.3/src/spamsum.h
13+++ nebula-0.2.3/src/spamsum.h
14@@ -24,7 +24,7 @@
15 #if HAVE_CONFIG_H
16 # include <config.h>
17 #endif
18-
19+#include "sys/types.h"
20
21 char *spamsum(const u_char *in, size_t length, uint32_t bsize);
22 uint32_t spamsum_match(const char *str1, const char *str2);
23--- nebula-0.2.3/src/trie.h
24+++ nebula-0.2.3/src/trie.h
25@@ -24,6 +24,7 @@
26 #if HAVE_CONFIG_H
27 # include <config.h>
28 #endif
29+#include "sys/types.h"
30
31 struct trie_node;
32 typedef struct trie_node *trie;