aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-03 06:10:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-03 06:10:26 +0000
commitefb895ec4aadba6d76f3679c75e784a19e8422fb (patch)
tree6200d78ddb61c8adff4fcad6dcc42ebd4137a7e6
parentdb344855fd58b2e4d429da927356a247106fb07b (diff)
downloadalpine_aports-efb895ec4aadba6d76f3679c75e784a19e8422fb.tar.bz2
alpine_aports-efb895ec4aadba6d76f3679c75e784a19e8422fb.tar.xz
alpine_aports-efb895ec4aadba6d76f3679c75e784a19e8422fb.zip
main/liblogging: new aport
An easy to use logging library http://www.liblogging.org/ needed by rsyslog
-rw-r--r--main/liblogging/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/main/liblogging/APKBUILD b/main/liblogging/APKBUILD
new file mode 100644
index 0000000000..44ba5a7fb2
--- /dev/null
+++ b/main/liblogging/APKBUILD
@@ -0,0 +1,52 @@
1# Contributor: Natanael Copa <ncopa@alpinelinux.org>
2# Maintainer:
3pkgname=liblogging
4pkgver=1.0.4
5pkgrel=0
6pkgdesc="An easy to use logging library"
7url="http://www.liblogging.org/"
8arch="all"
9license="BSD"
10depends=""
11depends_dev=""
12makedepends="$depends_dev"
13install=""
14subpackages="$pkgname-dev $pkgname-doc"
15source="http://download.rsyslog.com/liblogging/liblogging-$pkgver.tar.gz"
16
17_builddir="$srcdir"/liblogging-$pkgver
18prepare() {
19 local i
20 cd "$_builddir"
21 for i in $source; do
22 case $i in
23 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
24 esac
25 done
26}
27
28build() {
29 cd "$_builddir"
30 ./configure \
31 --build=$CBUILD \
32 --host=$CHOST \
33 --prefix=/usr \
34 --sysconfdir=/etc \
35 --mandir=/usr/share/man \
36 --infodir=/usr/share/info \
37 --localstatedir=/var \
38 --disable-journal \
39 --enable-stdlog \
40 || return 1
41 make || return 1
42}
43
44package() {
45 cd "$_builddir"
46 make DESTDIR="$pkgdir" install || return 1
47 rm -f "$pkgdir"/usr/lib/*.la
48}
49
50md5sums="034083ef1424a566fdeefc56a719691f liblogging-1.0.4.tar.gz"
51sha256sums="aceb5d2aa8bdc771ff66f407f9adf4176b654db63e34a8605795b68be537b81c liblogging-1.0.4.tar.gz"
52sha512sums="7d57a4d5d41ab2033dd57370c4511749f7965949a30eacaf36e7608acc64a32c42903dc1b5bb50c649dcb9a5ed91a2f0339d21aa0fc20a6a6144616dae556ccf liblogging-1.0.4.tar.gz"