aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-10 05:07:53 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-10 05:13:19 -0300
commit77892117d9c249972f5e8a0cc93ece8a09576b97 (patch)
treec559027ba8e5d4f8c83da4e04aa1cff977c52b3c
parent58b283e520ba84e2f35a41f28b5ccbd9639d1b93 (diff)
downloadalpine_aports-77892117d9c249972f5e8a0cc93ece8a09576b97.tar.bz2
alpine_aports-77892117d9c249972f5e8a0cc93ece8a09576b97.tar.xz
alpine_aports-77892117d9c249972f5e8a0cc93ece8a09576b97.zip
testing/pcsxr: upgrade to 1.9.95
-rw-r--r--testing/pcsxr/APKBUILD34
-rw-r--r--testing/pcsxr/fix-assert-64bit.patch13
-rw-r--r--testing/pcsxr/fix-musl.patch14
-rw-r--r--testing/pcsxr/fix-uncompress2.patch23
-rw-r--r--testing/pcsxr/fix-undefined-operations.patch194
5 files changed, 266 insertions, 12 deletions
diff --git a/testing/pcsxr/APKBUILD b/testing/pcsxr/APKBUILD
index 7f439b465b..1ff0496cec 100644
--- a/testing/pcsxr/APKBUILD
+++ b/testing/pcsxr/APKBUILD
@@ -1,36 +1,46 @@
1# Contributor: Cág <ca6c@bitmessage.ch> 1# Contributor: Cág <ca6c@bitmessage.ch>
2# Maintainer: Cág <ca6c@bitmessage.ch> 2# Maintainer: Cág <ca6c@bitmessage.ch>
3pkgname=pcsxr 3pkgname=pcsxr
4pkgver=1.9.92 4pkgver=1.9.95
5pkgrel=2 5pkgrel=0
6pkgdesc="Sony PlayStation emulator" 6pkgdesc="Sony PlayStation emulator"
7url="https://pcsxr.codeplex.com/" 7url="https://pcsxr.codeplex.com/"
8arch="all" 8arch="all"
9license="GPL-3.0-or-later" 9license="GPL-3.0-or-later"
10depends="libtxc_dxtn" 10depends="libtxc_dxtn"
11makedepends="autoconf automake libglade-dev libtool gtk+2.0-dev sdl-dev mesa-dev 11makedepends="autoconf automake libglade-dev libtool gtk+3.0-dev sdl-dev mesa-dev
12 libxv-dev libxtst-dev nasm libxxf86vm-dev" 12 libxv-dev libxtst-dev nasm libxxf86vm-dev libcdio-dev"
13subpackages="$pkgname-doc $pkgname-lang" 13subpackages="$pkgname-doc $pkgname-lang"
14source="http://http.debian.net/debian/pool/main/p/pcsxr/pcsxr_1.9.92.orig.tar.bz2" 14source="
15builddir="$srcdir/$pkgname-$pkgver" 15 ${pkgname}-${pkgver}.tar.gz::https://github.com/frealgagu/PCSX-Reloaded/archive/${pkgver}.tar.gz
16 fix-assert-64bit.patch
17 fix-undefined-operations.patch
18 fix-uncompress2.patch
19 fix-musl.patch
20 "
21builddir="$srcdir/PCSX-Reloaded-$pkgver/pcsxr"
16 22
17prepare() { 23prepare() {
18 cd "$builddir"
19 default_prepare 24 default_prepare
20 ./autogen.sh 25 mkdir include
26 autoreconf -fi
21} 27}
22 28
23build() { 29build() {
24 cd "$builddir" 30 export CFLAGS="$CFLAGS -O2"
25 ./configure \ 31 ./configure \
26 --prefix=/usr \ 32 --prefix=/usr \
27 --enable-opengl 33 --enable-opengl \
34 --enable-libcdio
28 make 35 make
29} 36}
30 37
31package() { 38package() {
32 cd "$builddir"
33 make DESTDIR="$pkgdir" install 39 make DESTDIR="$pkgdir" install
34} 40}
35 41
36sha512sums="25b0caa1cc3715afddedfef7c069f4d334ce9f6bef9355c813c60b1462a2b68634d517a31373823d64a815bec4449234d13edb6ff5159f746820124d1993ef4c pcsxr_1.9.92.orig.tar.bz2" 42sha512sums="950f5776f1cf11d31c44cb5f47ab2480a4302ee01af5fa6a3bac0a96936ac280649c9456d78ddf75c038a43977114a780b259467cee5da7f84b8802ca1ec86a1 pcsxr-1.9.95.tar.gz
43ddd349a5e7ad5fea809596ccf44e4963992a4a9f96316db4d3c8211bc9d22ef3830115cd7b3b09d1c4c05e6419d21b2e81695d876352ea00128728709f66d58e fix-assert-64bit.patch
441918231c3411eb2cedc3d3766d48bd766ee7aaaae34b964aec791f1e50851c7b367eb823cf0434e26e7ea8928becb30f7fcc88d27bf990072e9f651637d1f44e fix-undefined-operations.patch
4562593bc0c9422b025fdbcf04bbeff49fa195c8807cc44bc74555ad4d970e07054427299aed65bed0f75487c98e3a68ae78be86eb77822b1cf54ba26ba0e3e5ba fix-uncompress2.patch
46af69e67b12d3398248dab36f79552bff59a8246ea4aecd66f8e0621b7a1c3f5c5f03a16dc9f91b6b520290b5f688cbf7a3d9f3dbd4819f5f89dd1a5c20ccfb78 fix-musl.patch"
diff --git a/testing/pcsxr/fix-assert-64bit.patch b/testing/pcsxr/fix-assert-64bit.patch
new file mode 100644
index 0000000000..beb35b598d
--- /dev/null
+++ b/testing/pcsxr/fix-assert-64bit.patch
@@ -0,0 +1,13 @@
1diff --git a/pcsxr/libpcsxcore/ix86_64/ix86-64.c b/pcsxr/libpcsxcore/ix86_64/ix86-64.c
2index f48b742e..c69192e0 100644
3--- a/libpcsxcore/ix86_64/ix86-64.c
4+++ b/libpcsxcore/ix86_64/ix86-64.c
5@@ -231,7 +231,6 @@ void x86SetJ8( u8* j8 )
6
7 if ( jump > 0x7f ) {
8 SysPrintf( "j8 greater than 0x7f!!\n" );
9- assert(0);
10 }
11 *j8 = (u8)jump;
12 }
13
diff --git a/testing/pcsxr/fix-musl.patch b/testing/pcsxr/fix-musl.patch
new file mode 100644
index 0000000000..cb5a18d7dc
--- /dev/null
+++ b/testing/pcsxr/fix-musl.patch
@@ -0,0 +1,14 @@
1diff --git a/plugins/dfinput/pad.c b/plugins/dfinput/pad.c
2index bd3aef7..2a01910 100644
3--- a/plugins/dfinput/pad.c
4+++ b/plugins/dfinput/pad.c
5@@ -16,6 +16,8 @@
6 * along with this program; if not, see <http://www.gnu.org/licenses>.
7 */
8
9+#include <fcntl.h>
10+
11 #include "pad.h"
12 #if !SDL_VERSION_ATLEAST(2,0,0) && defined(__linux__)
13 #include <linux/input.h>
14
diff --git a/testing/pcsxr/fix-uncompress2.patch b/testing/pcsxr/fix-uncompress2.patch
new file mode 100644
index 0000000000..439f2c5adf
--- /dev/null
+++ b/testing/pcsxr/fix-uncompress2.patch
@@ -0,0 +1,23 @@
1diff --git a/pcsxr/libpcsxcore/cdriso.c b/pcsxr/libpcsxcore/cdriso.c
2index b7eedea2..8ad16d15 100644
3--- a/libpcsxcore/cdriso.c
4+++ b/libpcsxcore/cdriso.c
5@@ -1146,7 +1146,7 @@ static int cdread_sub_mixed(FILE *f, unsigned int base, void *dest, int sector)
6 return ret;
7 }
8
9-static int uncompress2(void *out, unsigned long *out_size, void *in, unsigned long in_size)
10+static int uncompress2_internal(void *out, unsigned long *out_size, void *in, unsigned long in_size)
11 {
12 static z_stream z;
13 int ret = 0;
14@@ -1225,7 +1225,7 @@ static int cdread_compressed(FILE *f, unsigned int base, void *dest, int sector)
15 if (is_compressed) {
16 cdbuffer_size_expect = sizeof(compr_img->buff_raw[0]) << compr_img->block_shift;
17 cdbuffer_size = cdbuffer_size_expect;
18- ret = uncompress2(compr_img->buff_raw[0], &cdbuffer_size, compr_img->buff_compressed, size);
19+ ret = uncompress2_internal(compr_img->buff_raw[0], &cdbuffer_size, compr_img->buff_compressed, size);
20 if (ret != 0) {
21 SysPrintf("uncompress failed with %d for block %d, sector %d\n",
22 ret, block, sector);
23
diff --git a/testing/pcsxr/fix-undefined-operations.patch b/testing/pcsxr/fix-undefined-operations.patch
new file mode 100644
index 0000000000..cd15906a02
--- /dev/null
+++ b/testing/pcsxr/fix-undefined-operations.patch
@@ -0,0 +1,194 @@
1diff --git a/pcsxr/plugins/peopsxgl/texture.c b/pcsxr/plugins/peopsxgl/texture.c
2index 8d8fb41b..0d313b97 100644
3--- a/plugins/peopsxgl/texture.c
4+++ b/plugins/peopsxgl/texture.c
5@@ -1002,7 +1002,10 @@ void LoadStretchPackedWndTexturePage(int pageid, int mode, short cx, short cy)
6 if(ldy)
7 {ldy--;
8 for(TXU=g_x1;TXU<=g_x2;TXU++)
9- *ta++=*(ta-(g_x2-g_x1));
10+ {
11+ *ta=*(ta-(g_x2-g_x1));
12+ ta++;
13+ }
14 }
15 }
16
17@@ -1079,7 +1082,10 @@ void LoadStretchPackedWndTexturePage(int pageid, int mode, short cx, short cy)
18 if(ldy)
19 {ldy--;
20 for(TXU=g_x1;TXU<=g_x2;TXU++)
21- *ta++=*(ta-(g_x2-g_x1));
22+ {
23+ *ta=*(ta-(g_x2-g_x1));
24+ ta++;
25+ }
26 }
27
28 }
29@@ -1204,7 +1210,10 @@ void LoadStretchWndTexturePage(int pageid, int mode, short cx, short cy)
30 if(ldy)
31 {ldy--;
32 for(TXU=g_x1;TXU<=g_x2;TXU++)
33- *ta++=*(ta-(g_x2-g_x1));
34+ {
35+ *ta=*(ta-(g_x2-g_x1));
36+ ta++;
37+ }
38 }
39 }
40
41@@ -1288,7 +1297,10 @@ void LoadStretchWndTexturePage(int pageid, int mode, short cx, short cy)
42 if(ldy)
43 {ldy--;
44 for(TXU=g_x1;TXU<=g_x2;TXU++)
45- *ta++=*(ta-(g_x2-g_x1));
46+ {
47+ *ta=*(ta-(g_x2-g_x1));
48+ ta++;
49+ }
50 }
51
52 }
53@@ -2247,14 +2259,19 @@ GLuint LoadTextureMovie(void)
54 lu=*((uint32_t *)pD);pD+=3;
55 *ta++=XMBLUE(lu)|XMGREEN(lu)|XMRED(lu)|1;
56 }
57- *ta++=*(ta-1);
58+ *ta=*(ta-1);
59+ ta++;
60 }
61 if(b_Y)
62 {
63 dx=xrMovieArea.x1-xrMovieArea.x0+1;
64 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
65- *ta++=*(ta-dx);
66- *ta++=*(ta-1);
67+ {
68+ *ta=*(ta-dx);
69+ ta++;
70+ }
71+ *ta=*(ta-1);
72+ ta++;
73 }
74 }
75 else
76@@ -2273,7 +2290,10 @@ GLuint LoadTextureMovie(void)
77 {
78 dx=xrMovieArea.x1-xrMovieArea.x0;
79 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
80- *ta++=*(ta-dx);
81+ {
82+ *ta=*(ta-dx);
83+ ta++;
84+ }
85 }
86 }
87 }
88@@ -2296,14 +2316,19 @@ GLuint LoadTextureMovie(void)
89 *ta++=((c&0x1f)<<11)|((c&0x3e0)<<1)|((c&0x7c00)>>9)|1;
90 }
91
92- *ta++=*(ta-1);
93+ *ta=*(ta-1);
94+ ta++;
95 }
96 if(b_Y)
97 {
98 dx=xrMovieArea.x1-xrMovieArea.x0+1;
99 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
100- *ta++=*(ta-dx);
101- *ta++=*(ta-1);
102+ {
103+ *ta=*(ta-dx);
104+ ta++;
105+ }
106+ *ta=*(ta-1);
107+ ta++;
108 }
109 }
110 else
111@@ -2321,7 +2346,10 @@ GLuint LoadTextureMovie(void)
112 {
113 dx=xrMovieArea.x1-xrMovieArea.x0;
114 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
115- *ta++=*(ta-dx);
116+ {
117+ *ta=*(ta-dx);
118+ ta++;
119+ }
120 }
121 }
122 }
123@@ -2347,14 +2375,19 @@ GLuint LoadTextureMovie(void)
124 *ta++=*((uint32_t *)pD)|0xff000000;
125 pD+=3;
126 }
127- *ta++=*(ta-1);
128+ *ta=*(ta-1);
129+ ta++;
130 }
131 if(b_Y)
132 {
133 dx=xrMovieArea.x1-xrMovieArea.x0+1;
134 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
135- *ta++=*(ta-dx);
136- *ta++=*(ta-1);
137+ {
138+ *ta=*(ta-dx);
139+ ta++;
140+ }
141+ *ta=*(ta-1);
142+ ta++;
143 }
144 }
145 else
146@@ -2373,7 +2406,10 @@ GLuint LoadTextureMovie(void)
147 {
148 dx=xrMovieArea.x1-xrMovieArea.x0;
149 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
150- *ta++=*(ta-dx);
151+ {
152+ *ta=*(ta-dx);
153+ ta++;
154+ }
155 }
156 }
157 }
158@@ -2394,15 +2430,20 @@ GLuint LoadTextureMovie(void)
159 startxy=((1024)*column)+xrMovieArea.x0;
160 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
161 *ta++=LTCOL(psxVuw[startxy++]|0x8000);
162- *ta++=*(ta-1);
163+ *ta=*(ta-1);
164+ ta++;
165 }
166
167 if(b_Y)
168 {
169 dx=xrMovieArea.x1-xrMovieArea.x0+1;
170 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
171- *ta++=*(ta-dx);
172- *ta++=*(ta-1);
173+ {
174+ *ta=*(ta-dx);
175+ ta++;
176+ }
177+ *ta=*(ta-1);
178+ ta++;
179 }
180 }
181 else
182@@ -2418,7 +2459,10 @@ GLuint LoadTextureMovie(void)
183 {
184 dx=xrMovieArea.x1-xrMovieArea.x0;
185 for(row=xrMovieArea.x0;row<xrMovieArea.x1;row++)
186- *ta++=*(ta-dx);
187+ {
188+ *ta=*(ta-dx);
189+ ta++;
190+ }
191 }
192 }
193 }
194