aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-10 14:11:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-10 14:11:29 +0000
commitacf6101af78f4306242b9fd2bc9fc56dce73b41d (patch)
tree1a7d608f59eab71d66c5d7e67da8287a1aaeeeb4
parenta46c750b476e0d417c13f4efe1c461cae1cac51d (diff)
downloadalpine_aports-acf6101af78f4306242b9fd2bc9fc56dce73b41d.tar.bz2
alpine_aports-acf6101af78f4306242b9fd2bc9fc56dce73b41d.tar.xz
alpine_aports-acf6101af78f4306242b9fd2bc9fc56dce73b41d.zip
testing/xournal: build fix for armv7
-rw-r--r--testing/xournal/APKBUILD6
-rw-r--r--testing/xournal/static-inline.patch56
2 files changed, 60 insertions, 2 deletions
diff --git a/testing/xournal/APKBUILD b/testing/xournal/APKBUILD
index 08f13281d9..f1da4eb8ad 100644
--- a/testing/xournal/APKBUILD
+++ b/testing/xournal/APKBUILD
@@ -9,7 +9,8 @@ arch="all !aarch64"
9license="GPL-2.0" 9license="GPL-2.0"
10makedepends="libgnomecanvas-dev poppler-dev gtk+2.0-dev libart-lgpl-dev" 10makedepends="libgnomecanvas-dev poppler-dev gtk+2.0-dev libart-lgpl-dev"
11subpackages="$pkgname-lang" 11subpackages="$pkgname-lang"
12source="https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz" 12source="https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
13 static-inline.patch"
13builddir="$srcdir/"$pkgname-$pkgver 14builddir="$srcdir/"$pkgname-$pkgver
14 15
15build() { 16build() {
@@ -32,4 +33,5 @@ package() {
32 make DESTDIR="$pkgdir" install 33 make DESTDIR="$pkgdir" install
33} 34}
34 35
35sha512sums="cfd5760a0e832ef02786a29cb744d4932aeee97c4d6992b430e647bd59aaef1042735203824d0eaf9da9b884dcdadcfb8f5acea221638db91438ae46a6ee42bf xournal-0.4.8.tar.gz" 36sha512sums="cfd5760a0e832ef02786a29cb744d4932aeee97c4d6992b430e647bd59aaef1042735203824d0eaf9da9b884dcdadcfb8f5acea221638db91438ae46a6ee42bf xournal-0.4.8.tar.gz
37de5dbe8a6ee98215cca22e0776817f655b7dfe741ebb186e7fdfa0569bc078888f84669d0ddbcf7abfd31232a533b02f00acc8b2a7204339b2e69a4a7f8f7df4 static-inline.patch"
diff --git a/testing/xournal/static-inline.patch b/testing/xournal/static-inline.patch
new file mode 100644
index 0000000000..5a87495028
--- /dev/null
+++ b/testing/xournal/static-inline.patch
@@ -0,0 +1,56 @@
1diff --git a/src/xo-shapes.c b/src/xo-shapes.c
2index 33840fd..4ed17da 100644
3--- a/src/xo-shapes.c
4+++ b/src/xo-shapes.c
5@@ -72,42 +72,42 @@ void calc_inertia(double *pt, int start, int end, struct Inertia *s)
6
7 /* compute normalized quantities */
8
9-inline double center_x(struct Inertia s)
10-{
11+static inline double center_x(struct Inertia s)
12+{
13 return s.sx/s.mass;
14 }
15
16-inline double center_y(struct Inertia s)
17-{
18+static inline double center_y(struct Inertia s)
19+{
20 return s.sy/s.mass;
21 }
22
23-inline double I_xx(struct Inertia s)
24+static inline double I_xx(struct Inertia s)
25 {
26 if (s.mass <= 0.) return 0.;
27 return (s.sxx - s.sx*s.sx/s.mass)/s.mass;
28 }
29
30-inline double I_xy(struct Inertia s)
31+static inline double I_xy(struct Inertia s)
32 {
33 if (s.mass <= 0.) return 0.;
34 return (s.sxy - s.sx*s.sy/s.mass)/s.mass;
35 }
36
37-inline double I_yy(struct Inertia s)
38+static inline double I_yy(struct Inertia s)
39 {
40 if (s.mass <= 0.) return 0.;
41 return (s.syy - s.sy*s.sy/s.mass)/s.mass;
42 }
43
44-inline double I_rad(struct Inertia s)
45+static inline double I_rad(struct Inertia s)
46 {
47 double ixx = I_xx(s), iyy = I_yy(s);
48 if (ixx+iyy <= 0.) return 0.;
49 return sqrt(ixx+iyy);
50 }
51
52-inline double I_det(struct Inertia s)
53+static inline double I_det(struct Inertia s)
54 {
55 double ixx = I_xx(s), iyy = I_yy(s), ixy = I_xy(s);
56 if (s.mass <= 0.) return 0.;