aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-06-19 08:27:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-19 08:38:42 +0000
commit8faf6299e2a8ba608b761f542bde1192416b5965 (patch)
treecfab94c690991d8603a1d674da1bec00cd91de5f
parent66e8be8d84c0caf89824ce4a6557089f227bef68 (diff)
downloadalpine_aports-8faf6299e2a8ba608b761f542bde1192416b5965.tar.bz2
alpine_aports-8faf6299e2a8ba608b761f542bde1192416b5965.tar.xz
alpine_aports-8faf6299e2a8ba608b761f542bde1192416b5965.zip
main/mosquitto: upgrade to 1.6.3
-rw-r--r--main/mosquitto/APKBUILD8
-rw-r--r--main/mosquitto/fix-musl.patch32
2 files changed, 3 insertions, 37 deletions
diff --git a/main/mosquitto/APKBUILD b/main/mosquitto/APKBUILD
index 61e94de2cb..66c143d01a 100644
--- a/main/mosquitto/APKBUILD
+++ b/main/mosquitto/APKBUILD
@@ -1,8 +1,8 @@
1# Contributor: Pedro Filipe <xpecex@outlook.com> 1# Contributor: Pedro Filipe <xpecex@outlook.com>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=mosquitto 3pkgname=mosquitto
4pkgver=1.6.2 4pkgver=1.6.3
5pkgrel=1 5pkgrel=0
6pkgdesc="An Open Source MQTT v3.1 Broker" 6pkgdesc="An Open Source MQTT v3.1 Broker"
7url="https://mosquitto.org/" 7url="https://mosquitto.org/"
8arch="all" 8arch="all"
@@ -16,7 +16,6 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-libs++:_pp $pkgname-openrc
16 $pkgname-libs $pkgname-clients" 16 $pkgname-libs $pkgname-clients"
17source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz 17source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
18 config.patch 18 config.patch
19 fix-musl.patch
20 disable-ci-tests.patch 19 disable-ci-tests.patch
21 mosquitto.initd" 20 mosquitto.initd"
22builddir="$srcdir/$pkgname-$pkgver" 21builddir="$srcdir/$pkgname-$pkgver"
@@ -91,8 +90,7 @@ clients() {
91 mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/ 90 mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
92} 91}
93 92
94sha512sums="d1c13df4409eb20ccc00a67b07a4af5c5ce668a403a4605e2bae4f5869b256ebe5d9a001d009cb0e34bc7b3cfee96779fc81099b170ff03af3ca43f05567912b mosquitto-1.6.2.tar.gz 93sha512sums="d78d95789cfadaa8c989becb799e6eace1a82cfed9d79582cf7278dd2f9f31060b0b6492c5e3461c687629445efbdda0db68cba65962eb6a305ada46611f6d94 mosquitto-1.6.3.tar.gz
95fb000f9fa1ef94cbf3811a23b5692c0c8f9e2df945959cef6005462715e99d6f75cf6b31bd496271ffc17634024aed986771a73962fef865c0d386f6c194fb33 config.patch 94fb000f9fa1ef94cbf3811a23b5692c0c8f9e2df945959cef6005462715e99d6f75cf6b31bd496271ffc17634024aed986771a73962fef865c0d386f6c194fb33 config.patch
9641328fec7c461225a5c73f8b94a1747e7a697eee48a16f1e5cc4e9f4039e0ed5dc66d3518119ccf2bbca935d1fe18c85cfced781f8279ee84ed983894419d88f fix-musl.patch
9721df2006a5eb9e1248cf261e555ded8e80e79f2a2d2a55b1f8a153af7c0feb867f3b3bd71efbe4d8569e3031c65f3e144794724f012e7539244a9bd97b6b6bb3 disable-ci-tests.patch 9521df2006a5eb9e1248cf261e555ded8e80e79f2a2d2a55b1f8a153af7c0feb867f3b3bd71efbe4d8569e3031c65f3e144794724f012e7539244a9bd97b6b6bb3 disable-ci-tests.patch
9816f96d8f7f3a8b06e2b2e04d42d7e0d89a931b52277fc017e4802f7a3bc85aff4dd290b1a0c40382ea8f5568d0ceb7319c031d9be916f346d805231a002b0433 mosquitto.initd" 9616f96d8f7f3a8b06e2b2e04d42d7e0d89a931b52277fc017e4802f7a3bc85aff4dd290b1a0c40382ea8f5568d0ceb7319c031d9be916f346d805231a002b0433 mosquitto.initd"
diff --git a/main/mosquitto/fix-musl.patch b/main/mosquitto/fix-musl.patch
deleted file mode 100644
index f0eacfb673..0000000000
--- a/main/mosquitto/fix-musl.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1diff --git a/lib/util_mosq.c b/lib/util_mosq.c
2index 8f3610a..5dbf123 100644
3--- a/lib/util_mosq.c
4+++ b/lib/util_mosq.c
5@@ -29,8 +29,10 @@ Contributors:
6 #endif
7
8 #if !defined(WITH_TLS) && defined(__linux__)
9-# if defined(__GLIBC__) && __GLIBC_PREREQ(2, 25)
10-# include <sys/random.h>
11+# if defined(__GLIBC__)
12+# if __GLIBC_PREREQ(2, 25)
13+# include <sys/random.h>
14+# endif
15 # endif
16 #endif
17
18@@ -325,10 +327,12 @@ int util__random_bytes(void *bytes, int count)
19 if(RAND_bytes(bytes, count) == 1){
20 rc = MOSQ_ERR_SUCCESS;
21 }
22-#elif defined(__GLIBC__) && __GLIBC_PREREQ(2, 25)
23+#elif defined(__GLIBC__)
24+# if __GLIBC_PREREQ(2, 25)
25 if(getrandom(bytes, count, 0) == 0){
26 rc = MOSQ_ERR_SUCCESS;
27 }
28+# endif
29 #elif defined(WIN32)
30 HRYPTPROV provider;
31
32