aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-17 14:44:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-17 14:45:59 +0000
commit83aab393ce2e4ef8d4107d23075f103269503a4e (patch)
treeba4991f671e50c7188cf4890c0eb807bea270f0e
parent8cefef913520db312cf770a820f209753de5491f (diff)
downloadalpine_aports-83aab393ce2e4ef8d4107d23075f103269503a4e.tar.bz2
alpine_aports-83aab393ce2e4ef8d4107d23075f103269503a4e.tar.xz
alpine_aports-83aab393ce2e4ef8d4107d23075f103269503a4e.zip
main/busybox: avoid run depmod if kmod is installed
dont run busybox depmod if we have kmod. This prevents us from running depmod twice.
-rw-r--r--main/busybox/APKBUILD2
-rw-r--r--main/busybox/busybox.trigger5
2 files changed, 5 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index bae37e1f02..b1c844ba21 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -3,7 +3,7 @@
3# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 3# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
4pkgname=busybox 4pkgname=busybox
5pkgver=1.31.1 5pkgver=1.31.1
6pkgrel=6 6pkgrel=7
7pkgdesc="Size optimized toolbox of many common UNIX utilities" 7pkgdesc="Size optimized toolbox of many common UNIX utilities"
8url="https://busybox.net/" 8url="https://busybox.net/"
9arch="all" 9arch="all"
diff --git a/main/busybox/busybox.trigger b/main/busybox/busybox.trigger
index e531a45b84..4daec8c56d 100644
--- a/main/busybox/busybox.trigger
+++ b/main/busybox/busybox.trigger
@@ -5,7 +5,10 @@ do_bb_install=
5for i in "$@"; do 5for i in "$@"; do
6 case "$i" in 6 case "$i" in
7 /lib/modules/*) 7 /lib/modules/*)
8 if [ -d "$i" ]; then 8 # don't run busybox dpemod if we have kmod installed
9 # we dont need to run it twice.
10 target=$(readlink -f $(command -v depmod))
11 if [ -d "$i" ] && [ "$target" = "/bin/busybox" ]; then
9 /bin/busybox depmod ${i#/lib/modules/} 12 /bin/busybox depmod ${i#/lib/modules/}
10 fi 13 fi
11 ;; 14 ;;