aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-01-08 08:22:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-01-08 09:26:16 +0100
commit7cf8ea7952bcf74c13e904276fa8395210662040 (patch)
tree0c718bff2557b204a524c09421d04bf0cea6cf82
parent714f6a3d2f4b927a09ba55bf0662494272b17e6f (diff)
downloadalpine_aports-7cf8ea7952bcf74c13e904276fa8395210662040.tar.bz2
alpine_aports-7cf8ea7952bcf74c13e904276fa8395210662040.tar.xz
alpine_aports-7cf8ea7952bcf74c13e904276fa8395210662040.zip
main/kamailio: increase timout for stopping service
Kamailio may need more time to shut down if there are many clients (1000+). Increase it to 10 seconds to avoid the error message: start-stop-daemon: 1 process refused to stop (cherry picked from commit a7dca5f03d6af851a0ae3eb91a03148a51f4c51a)
-rw-r--r--main/kamailio/APKBUILD4
-rw-r--r--main/kamailio/kamailio.initd2
2 files changed, 3 insertions, 3 deletions
diff --git a/main/kamailio/APKBUILD b/main/kamailio/APKBUILD
index defe55c09d..31cf8e0832 100644
--- a/main/kamailio/APKBUILD
+++ b/main/kamailio/APKBUILD
@@ -5,7 +5,7 @@
5 5
6pkgname=kamailio 6pkgname=kamailio
7pkgver=5.2.5 7pkgver=5.2.5
8pkgrel=0 8pkgrel=1
9 9
10# If building from a git snapshot, specify the gitcommit 10# If building from a git snapshot, specify the gitcommit
11# If building a proper release, leave gitcommit blank 11# If building a proper release, leave gitcommit blank
@@ -562,4 +562,4 @@ sha512sums="045f52f633897fdfce8afe508bf2f803f79a2b7d16be129314464c0da7a124fd64d9
562bbb00a3b680d2805aebf412a7cd77d5ac16e5edb45077516635101f78782dcaa779f84a3678fdd820fa7d7f021ae89271811b2e344092a8f5b7fe6eeee4c2599 0001-mohqueue.patch 562bbb00a3b680d2805aebf412a7cd77d5ac16e5edb45077516635101f78782dcaa779f84a3678fdd820fa7d7f021ae89271811b2e344092a8f5b7fe6eeee4c2599 0001-mohqueue.patch
563af8362201957eae6b66baf7368c9ca884024209a396d77c5c52180c9aabe13772e9c6513e59721d39503e5bb7a8c1030f5c10301ea9055bddafb7f01ee2f3076 0004-src_core_tcp_read_c.patch 563af8362201957eae6b66baf7368c9ca884024209a396d77c5c52180c9aabe13772e9c6513e59721d39503e5bb7a8c1030f5c10301ea9055bddafb7f01ee2f3076 0004-src_core_tcp_read_c.patch
564100a40ec63eaf62f8ac794f1bb17e8109030413617e61a7d2f55a8c8efbe26c1f0f611e6d99548638001f1af678fb7129a98db175eb02190c85d31f60af52202 dont-force-mips-revision.patch 564100a40ec63eaf62f8ac794f1bb17e8109030413617e61a7d2f55a8c8efbe26c1f0f611e6d99548638001f1af678fb7129a98db175eb02190c85d31f60af52202 dont-force-mips-revision.patch
565321b1b160434150bcde3c0ad7f47ddf259791b68d4ce74ba4c35034026421a2bc6f5e86f26f393f5fcdb523d8cd75f944709473065553ce860b0ea06b3dc2a1b kamailio.initd" 5650c87bfb78481568c03e603049eb8597a90d24ae2941fc81694181b2326fa9db89fbddaaa3cf08c7bc2f5fa0e7ffac4cf4e2d010d08c4faa6cf6df98593432539 kamailio.initd"
diff --git a/main/kamailio/kamailio.initd b/main/kamailio/kamailio.initd
index 6373932335..8c400173c5 100644
--- a/main/kamailio/kamailio.initd
+++ b/main/kamailio/kamailio.initd
@@ -24,7 +24,7 @@ start() {
24 24
25stop() { 25stop() {
26 ebegin "Stopping Kamailio" 26 ebegin "Stopping Kamailio"
27 start-stop-daemon --stop --quiet --pidfile $pidfile 27 start-stop-daemon --retry 10 --stop --quiet --pidfile $pidfile
28 eend $? 28 eend $?
29} 29}
30 30