aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-19 17:53:27 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-19 22:32:48 +0000
commitf84c8adcd1dfaf56c467b05070965c397aca86b7 (patch)
tree352d59b94fc72fc48fbc279045abd74ff0e5eb29
parent69bb0930956aefae5b1a6785ef4460230e04e2ec (diff)
downloadalpine_aports-f84c8adcd1dfaf56c467b05070965c397aca86b7.tar.bz2
alpine_aports-f84c8adcd1dfaf56c467b05070965c397aca86b7.tar.xz
alpine_aports-f84c8adcd1dfaf56c467b05070965c397aca86b7.zip
main/clamav: add missing secfixes info
-rw-r--r--main/clamav/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/main/clamav/APKBUILD b/main/clamav/APKBUILD
index c8b079d70f..4b72a3d9ca 100644
--- a/main/clamav/APKBUILD
+++ b/main/clamav/APKBUILD
@@ -21,7 +21,7 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-libunrar $pkgname-libs
21 $pkgname-daemon $pkgname-scanner $pkgname-db::noarch freshclam 21 $pkgname-daemon $pkgname-scanner $pkgname-db::noarch freshclam
22 $pkgname-daemon-openrc:daemon_rc:noarch freshclam-openrc:freshclam_rc:noarch 22 $pkgname-daemon-openrc:daemon_rc:noarch freshclam-openrc:freshclam_rc:noarch
23 $pkgname-milter" 23 $pkgname-milter"
24source="https://www.clamav.net/downloads/production/$pkgname-$pkgver.tar.gz 24source="https://www.clamav.net/downloads/production/clamav-$pkgver.tar.gz
25 clamd.initd 25 clamd.initd
26 clamd.confd 26 clamd.confd
27 freshclam.initd 27 freshclam.initd
@@ -30,10 +30,11 @@ source="https://www.clamav.net/downloads/production/$pkgname-$pkgver.tar.gz
30 freshclam.logrotate 30 freshclam.logrotate
31 " 31 "
32 32
33builddir="$srcdir/$pkgname-$pkgver"
34 33
35# secfixes: 34# secfixes:
36# 0.102.1-r0: 35# 0.102.1-r0:
36# - CVE-2020-3123
37# 0.102.0-r0:
37# - CVE-2019-15961 38# - CVE-2019-15961
38# 0.100.3-r0: 39# 0.100.3-r0:
39# - CVE-2019-1787 40# - CVE-2019-1787
@@ -70,7 +71,6 @@ prepare() {
70} 71}
71 72
72build() { 73build() {
73 cd "$builddir"
74 LIBS=-lfts ./configure \ 74 LIBS=-lfts ./configure \
75 --build=$CBUILD \ 75 --build=$CBUILD \
76 --host=$CHOST \ 76 --host=$CHOST \
@@ -93,12 +93,10 @@ build() {
93} 93}
94 94
95check() { 95check() {
96 cd "$builddir"
97 make check 96 make check
98} 97}
99 98
100package() { 99package() {
101 cd "$builddir"
102 make DESTDIR="$pkgdir" install 100 make DESTDIR="$pkgdir" install
103 101
104 # set proper defaults 102 # set proper defaults
@@ -123,7 +121,6 @@ package() {
123} 121}
124 122
125check() { 123check() {
126 cd "$builddir"
127 make check 124 make check
128} 125}
129 126