aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-05-22 02:36:40 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-05-22 02:37:32 -0600
commit1e31398e26bb97487a29259eba339c3b65415bcf (patch)
treee726c3db96b9659c237fa807b2d47d8dc3070d7f
parent9856b648f927d10706970f8ca8631f79cf2308e1 (diff)
downloadalpine_aports-1e31398e26bb97487a29259eba339c3b65415bcf.tar.bz2
alpine_aports-1e31398e26bb97487a29259eba339c3b65415bcf.tar.xz
alpine_aports-1e31398e26bb97487a29259eba339c3b65415bcf.zip
community/krita: fix up another desktop opengl-ism
-rw-r--r--community/krita/APKBUILD2
-rw-r--r--community/krita/pure-opengles-compat.patch24
2 files changed, 21 insertions, 5 deletions
diff --git a/community/krita/APKBUILD b/community/krita/APKBUILD
index e54ea44900..11666d2c52 100644
--- a/community/krita/APKBUILD
+++ b/community/krita/APKBUILD
@@ -37,4 +37,4 @@ package() {
37 37
38sha512sums="66eef3d1b5647e62551276662ef4332f15abc022f1032f27a2ad695a8d2dc5fa758146492a9da2b8cbd4a52e47c576473029d2aa9728dea3bec869b8173f08c0 krita-4.2.9.tar.xz 38sha512sums="66eef3d1b5647e62551276662ef4332f15abc022f1032f27a2ad695a8d2dc5fa758146492a9da2b8cbd4a52e47c576473029d2aa9728dea3bec869b8173f08c0 krita-4.2.9.tar.xz
39e7a9117d012df4181e05de970f2210264b8685ee76c98b33795f8095d9a17b24b20e6ce920f944b4b5cb940cf672af5ba5fd0ffae9f53085a4f97da61b1e69f6 fix-crash-with-c-locale.patch 39e7a9117d012df4181e05de970f2210264b8685ee76c98b33795f8095d9a17b24b20e6ce920f944b4b5cb940cf672af5ba5fd0ffae9f53085a4f97da61b1e69f6 fix-crash-with-c-locale.patch
40078f8ac6c8dfbd27202aca8a068fa77ca37c92aaa36fb725a8a9b7b97801da042f3dfd52fb115cea1c4cbb2984a9cb16e8a611a4507fffacdc4b4d8a85c091fa pure-opengles-compat.patch" 4052eb74afcb2ac1821a3d741567ae8360086644aabe5dfe646ec275b10565c8a3c5a854b7758df1743eb2c0ec7a5e9585280bbf11fabce5b059934f526c671f02 pure-opengles-compat.patch"
diff --git a/community/krita/pure-opengles-compat.patch b/community/krita/pure-opengles-compat.patch
index abd7b5f87b..202489fe28 100644
--- a/community/krita/pure-opengles-compat.patch
+++ b/community/krita/pure-opengles-compat.patch
@@ -1,6 +1,3 @@
1Consistently use OpenGLES functions instead of OpenGL 2.1 functions.
2
3Upstream: Pending submission
4diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp krita-4.2.9/libs/ui/opengl/kis_opengl_canvas2.cpp 1diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp krita-4.2.9/libs/ui/opengl/kis_opengl_canvas2.cpp
5--- krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp 2020-05-22 02:19:15.233324983 -0600 2--- krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp 2020-05-22 02:19:15.233324983 -0600
6+++ krita-4.2.9/libs/ui/opengl/kis_opengl_canvas2.cpp 2020-05-22 02:20:49.730356628 -0600 3+++ krita-4.2.9/libs/ui/opengl/kis_opengl_canvas2.cpp 2020-05-22 02:20:49.730356628 -0600
@@ -82,7 +79,7 @@ diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp krita-4.2.9/lib
82 } 79 }
83diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_image_textures.cpp krita-4.2.9/libs/ui/opengl/kis_opengl_image_textures.cpp 80diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_image_textures.cpp krita-4.2.9/libs/ui/opengl/kis_opengl_image_textures.cpp
84--- krita-4.2.9.orig/libs/ui/opengl/kis_opengl_image_textures.cpp 2020-05-22 02:19:15.233324983 -0600 81--- krita-4.2.9.orig/libs/ui/opengl/kis_opengl_image_textures.cpp 2020-05-22 02:19:15.233324983 -0600
85+++ krita-4.2.9/libs/ui/opengl/kis_opengl_image_textures.cpp 2020-05-22 02:23:39.357678451 -0600 82+++ krita-4.2.9/libs/ui/opengl/kis_opengl_image_textures.cpp 2020-05-22 02:36:06.923918655 -0600
86@@ -473,36 +473,16 @@ 83@@ -473,36 +473,16 @@
87 namespace { 84 namespace {
88 void initializeRGBA16FTextures(QOpenGLContext *ctx, KisGLTexturesInfo &texturesInfo, KoID &destinationColorDepthId) 85 void initializeRGBA16FTextures(QOpenGLContext *ctx, KisGLTexturesInfo &texturesInfo, KoID &destinationColorDepthId)
@@ -124,3 +121,22 @@ diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_image_textures.cpp krita-4.
124 texturesInfo.format = GL_RGBA; 121 texturesInfo.format = GL_RGBA;
125 } 122 }
126 } 123 }
124@@ -543,16 +523,8 @@
125 initializeRGBA16FTextures(ctx, m_texturesInfo, destinationColorDepthId);
126 }
127 else if (colorDepthId == Float32BitsColorDepthID) {
128- if (KisOpenGL::hasOpenGLES() || KisOpenGL::hasOpenGL3()) {
129- m_texturesInfo.internalFormat = GL_RGBA32F;
130- dbgUI << "Using float (GLES or GL3)";
131- } else if (ctx->hasExtension("GL_ARB_texture_float")) {
132- m_texturesInfo.internalFormat = GL_RGBA32F_ARB;
133- dbgUI << "Using ARB float";
134- } else if (ctx->hasExtension("GL_ATI_texture_float")) {
135- m_texturesInfo.internalFormat = GL_RGBA_FLOAT32_ATI;
136- dbgUI << "Using ATI float";
137- }
138+ m_texturesInfo.internalFormat = GL_RGBA32F;
139+ dbgUI << "Using float (GLES or GL3)";
140
141 m_texturesInfo.type = GL_FLOAT;
142 m_texturesInfo.format = GL_RGBA;