aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-05-19 20:39:14 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-22 06:05:09 +0000
commit3c4da38a1cce81bb761cbad2f3f448b73151f711 (patch)
tree4d2e9cc0eeee8a469ec41a6c05b717026ab4ceab
parentbb369204497ad0c33355fe7e3bc0dc1ae33883a9 (diff)
downloadalpine_aports-3c4da38a1cce81bb761cbad2f3f448b73151f711.tar.bz2
alpine_aports-3c4da38a1cce81bb761cbad2f3f448b73151f711.tar.xz
alpine_aports-3c4da38a1cce81bb761cbad2f3f448b73151f711.zip
main/postfix: fix outgoing DANE incompatible with musl
applied patch posted by Rich Felker to issue #11455 added depends to musl>=1.1.24-r7 with backported DANE fix fixes: #11455
-rw-r--r--main/postfix/APKBUILD5
-rw-r--r--main/postfix/postfix-musl-2.patch53
2 files changed, 57 insertions, 1 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index a5e9bf6bb9..b6bf561c2f 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -3,11 +3,12 @@
3# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 3# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
4pkgname=postfix 4pkgname=postfix
5pkgver=3.5.2 5pkgver=3.5.2
6pkgrel=0 6pkgrel=1
7pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)" 7pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
8url="http://www.postfix.org/" 8url="http://www.postfix.org/"
9arch="all" 9arch="all"
10license="IPL-1.0 EPL-2.0" 10license="IPL-1.0 EPL-2.0"
11depends="musl>=1.1.24-r7"
11makedepends=" 12makedepends="
12 coreutils 13 coreutils
13 cyrus-sasl-dev 14 cyrus-sasl-dev
@@ -42,6 +43,7 @@ pkgusers="postfix"
42pkggroups="postfix postdrop" 43pkggroups="postfix postdrop"
43source="https://de.postfix.org/ftpmirror/official/postfix-$pkgver.tar.gz 44source="https://de.postfix.org/ftpmirror/official/postfix-$pkgver.tar.gz
44 $pkgname.initd 45 $pkgname.initd
46 postfix-musl-2.patch
45 postfix-install.patch 47 postfix-install.patch
46 " 48 "
47 49
@@ -191,4 +193,5 @@ stone() {
191 193
192sha512sums="04e37c4542952dba0f3e44f10775c0bedf343e6382df14a9c43ebc80c005c3f6de68a4e7a7469f32ae74b8e50d10c089d4930eac0cd2e2a9ff1bd8d7481b3a76 postfix-3.5.2.tar.gz 194sha512sums="04e37c4542952dba0f3e44f10775c0bedf343e6382df14a9c43ebc80c005c3f6de68a4e7a7469f32ae74b8e50d10c089d4930eac0cd2e2a9ff1bd8d7481b3a76 postfix-3.5.2.tar.gz
1932752e69c4e1857bdcf29444ffb458bca818bc60b9c77c20823c5f5b87c36cb5e0f3217a625a7fe5788d5bfcef7570a1f2149e1233fcd23ccf7ee14190aff47a2 postfix.initd 1952752e69c4e1857bdcf29444ffb458bca818bc60b9c77c20823c5f5b87c36cb5e0f3217a625a7fe5788d5bfcef7570a1f2149e1233fcd23ccf7ee14190aff47a2 postfix.initd
1967b9d658a6130295b0e0bcf19db064d9daf21a783ef865d83d62eb09176380b7ee5e6a73f6c5ad82f3c1eded1f0c351ed55b203dfffe32c0071e5bb2b16edfeb5 postfix-musl-2.patch
19425cd34f23ca909d4e33aaf3239d1e397260abc7796d9a4456dee4f005682fd3a58aab8106126e5218c95bdddae415a3ef7e2223cd3b0d7b1e2bd76158bb7eaf8 postfix-install.patch" 19725cd34f23ca909d4e33aaf3239d1e397260abc7796d9a4456dee4f005682fd3a58aab8106126e5218c95bdddae415a3ef7e2223cd3b0d7b1e2bd76158bb7eaf8 postfix-install.patch"
diff --git a/main/postfix/postfix-musl-2.patch b/main/postfix/postfix-musl-2.patch
new file mode 100644
index 0000000000..6ddd037634
--- /dev/null
+++ b/main/postfix/postfix-musl-2.patch
@@ -0,0 +1,53 @@
1diff --git a/postfix/makedefs b/postfix/makedefs
2index 64b42f44..aea15d6f 100644
3--- a/makedefs
4+++ b/makedefs
5@@ -228,19 +228,6 @@ case $# in
6 *) echo usage: $0 [system release] 1>&2; exit 1;;
7 esac
8
9-case "$SYSTEM" in
10- Linux)
11- case "`PATH=/bin:/usr/bin ldd /bin/sh`" in
12- *-musl-*)
13- case "$CCARGS" in
14- *-DNO_DNSSEC*) ;;
15- *) echo Warning: libc-musl breaks DANE/TLSA security. 1>&2
16- echo This build will not support DANE/TLSA. 1>&2
17- CCARGS="$CCARGS -DNO_DNSSEC";;
18- esac;;
19- esac;;
20-esac
21-
22 case "$SYSTEM.$RELEASE" in
23 SCO_SV.3.2) SYSTYPE=SCO5
24 # Use the native compiler by default
25diff --git a/postfix/src/dns/dns_lookup.c b/postfix/src/dns/dns_lookup.c
26index 11c92813..b3bd537a 100644
27--- a/src/dns/dns_lookup.c
28+++ b/src/dns/dns_lookup.c
29@@ -350,7 +350,9 @@ static int dns_res_query(const char *name, int class, int type,
30 if (msg_verbose)
31 msg_info("res_mkquery() failed");
32 return (len);
33- } else if ((len = res_send(msg_buf, len, answer, anslen)) < 0) {
34+ }
35+ msg_buf[3] |= 32; // AD flag
36+ if ((len = res_send(msg_buf, len, answer, anslen)) < 0) {
37 SET_H_ERRNO(TRY_AGAIN);
38 if (msg_verbose)
39 msg_info("res_send() failed");
40@@ -491,11 +493,12 @@ static int dns_query(const char *name, int type, unsigned flags,
41 for (;;) {
42 _res.options &= ~saved_options;
43 _res.options |= flags;
44- if (keep_notfound && var_dns_ncache_ttl_fix) {
45+ if (1) {
46 #ifdef HAVE_RES_SEND
47 len = dns_res_query((char *) name, C_IN, type, reply->buf,
48 reply->buf_len);
49 #else
50+#error HAVE_RES_SEND not defined
51 var_dns_ncache_ttl_fix = 0;
52 msg_warn("system library does not support %s=yes"
53 " -- ignoring this setting", VAR_DNS_NCACHE_TTL_FIX);