aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Jaekel <holger.jaekel@gmx.de>2020-05-21 15:08:26 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-22 08:14:04 +0000
commitd967d92c01b5b6ab66ef884a5f414bcbf537b8b9 (patch)
tree41c313b02472e048c76dbfc7b57745e5bbb9abc7
parent587061d250657107393c7d177270dc18176513be (diff)
downloadalpine_aports-d967d92c01b5b6ab66ef884a5f414bcbf537b8b9.tar.bz2
alpine_aports-d967d92c01b5b6ab66ef884a5f414bcbf537b8b9.tar.xz
alpine_aports-d967d92c01b5b6ab66ef884a5f414bcbf537b8b9.zip
testing/ogdi: new aport
http://ogdi.sourceforge.net/ Open Geographic Datastore Interface Library
-rw-r--r--testing/ogdi/10-optimisation.patch16
-rw-r--r--testing/ogdi/20-external.patch28
-rw-r--r--testing/ogdi/APKBUILD93
3 files changed, 137 insertions, 0 deletions
diff --git a/testing/ogdi/10-optimisation.patch b/testing/ogdi/10-optimisation.patch
new file mode 100644
index 0000000000..8efa6ad622
--- /dev/null
+++ b/testing/ogdi/10-optimisation.patch
@@ -0,0 +1,16 @@
1Author: Holger Jaekel <holger.jaekel@gmx.de>
2Summary: allow optimisation flags from build script
3Upstream: No
4----
5
6--- a/config/unix.mak
7+++ b/config/unix.mak
8@@ -55,7 +55,7 @@ LINK_SW = -L
9 ifeq ($(CFG),debug)
10 OPTIMIZATION = -g
11 else
12-OPTIMIZATION = -O
13+OPTIMIZATION =
14 endif
15
16 #
diff --git a/testing/ogdi/20-external.patch b/testing/ogdi/20-external.patch
new file mode 100644
index 0000000000..e95562f3c4
--- /dev/null
+++ b/testing/ogdi/20-external.patch
@@ -0,0 +1,28 @@
1Author: Holger Jaekel <holger.jaekel@gmx.de>
2Summary: ignore external directory as we want to use provided libraries
3Upstream: No
4----
5
6--- a/makefile
7+++ b/makefile
8@@ -17,7 +17,7 @@
9 #
10 # Sub-directories that need to be built
11 #
12-subdirs = external vpflib ogdi contrib
13+subdirs = vpflib ogdi contrib
14
15 #
16 # Default target to build everything in all sub-directories
17diff -urN a/ogdi/makefile b/ogdi/makefile
18--- a/ogdi/makefile
19+++ b/ogdi/makefile
20@@ -15,7 +15,7 @@
21 #
22 # Sub-directories that need to be built
23 #
24-subdirs = include c-api glutil attr_driver driver gltpd examples
25+subdirs = include c-api glutil attr_driver driver gltpd
26
27 #
28 # Default target to build everything in all sub-directories
diff --git a/testing/ogdi/APKBUILD b/testing/ogdi/APKBUILD
new file mode 100644
index 0000000000..2af4a474db
--- /dev/null
+++ b/testing/ogdi/APKBUILD
@@ -0,0 +1,93 @@
1# Contributor: Holger Jaekel <holger.jaekel@gmx.de>
2# Maintainer: Holger Jaekel <holger.jaekel@gmx.de>
3pkgname=ogdi
4pkgver=4.1.0
5_testver=3.1.0
6pkgrel=0
7pkgdesc="Open Geographic Datastore Interface Library"
8url="http://ogdi.sourceforge.net/"
9arch="all"
10license="MIT"
11makedepends="
12 expat-dev
13 libtirpc-dev
14 tcl-dev
15 unixodbc-dev
16 zlib-dev
17 "
18subpackages="
19 $pkgname-dev
20 $pkgname-odbc
21 $pkgname-tcl
22 "
23source="
24 https://downloads.sourceforge.net/project/ogdi/ogdi/$pkgver/ogdi-$pkgver.tar.gz
25 https://downloads.sourceforge.net/project/ogdi/OGDI_Test_Suite/${_testver%.*}/ogdits-$_testver.tar.gz
26 10-optimisation.patch
27 20-external.patch
28 "
29
30build() {
31 export TOPDIR=$builddir TARGET=Linux LD_LIBRARY_PATH=$TOPDIR/bin/Linux
32 rm -r external
33 ./configure \
34 --build=$CBUILD \
35 --host=$CHOST \
36 --prefix=/usr \
37 --with-binconfigs \
38 --with-zlib \
39 --with-expat
40 make -j1 # fails to find own libraries if built with more buildjobs
41
42 # build tcl interface
43 make -C ogdi/tcl_interface \
44 TCL_LINKLIB="-ltcl8.6"
45
46 # build contributions
47 make -C contrib/gdal
48
49 # build odbc drivers
50 make -C ogdi/attr_driver/odbc \
51 ODBC_LINKLIB="-lodbc"
52}
53
54check() {
55 export TOPDIR=$builddir TARGET=Linux LD_LIBRARY_PATH=$TOPDIR/bin/Linux PATH=$PATH:$builddir/bin/Linux
56 ogdi_info -u gltp:/vrf/$srcdir/ogdits-${_testver%.*}/data/vpf/vm2alv2/texash | \
57 grep "Projection = \`+proj=longlat +datum=wgs84'"
58}
59
60package() {
61 export TOPDIR=$builddir TARGET=Linux
62 make install \
63 INST_INCLUDE=$pkgdir/usr/include/ogdi \
64 INST_LIB=$pkgdir/usr/lib \
65 INST_BIN=$pkgdir/usr/bin
66
67 # install gdal contribution
68 make install -C contrib/gdal \
69 INST_LIB=$pkgdir/usr/lib
70
71 # install pkgconfig file
72 mkdir -p $pkgdir/usr/lib/pkgconfig
73 install -p -m 644 ogdi.pc $pkgdir/usr/lib/pkgconfig
74}
75
76odbc() {
77 pkgdesc="ODBC driver for $pkgdesc"
78 export TOPDIR=$builddir TARGET=Linux
79 make install -C $builddir/ogdi/attr_driver/odbc \
80 INST_LIB=$subpkgdir/usr/lib
81}
82
83tcl() {
84 pkgdesc="TCL wrapper for $pkgdesc"
85 export TOPDIR=$builddir TARGET=Linux
86 make install -C $builddir/ogdi/tcl_interface \
87 INST_LIB=$subpkgdir/usr/lib
88}
89
90sha512sums="abfc409bfa5ea2f81a90c16361fe6cdc2b2ee39775c22ceb74b13b171aa04d6d6eaffe398cae0ef91dcde8509e5cc25100eedeffdad358e090b78e118d386859 ogdi-4.1.0.tar.gz
917fbd7c165466b6bf298d3d18b33c13b6f0166c3b1efe12b7c09e77539a20076950bc89db6c4e1e411ba374ebcf81744ec0410d3a414f395bd12339a7ae0e336b ogdits-3.1.0.tar.gz
9224682c9e893e410d08bfc0a1b06196e5d0555d4b552e07662ec26433e07f44a8f99686f79a1a5ed40de71f7da838516ffc33918837a6d79f35ab2a9b380f5592 10-optimisation.patch
93ca0283bd2791919bc4ae71af6ecf8d8900376fdef6b1d0808ae7d598501225c8a652e865214c43efc937e0d9514780f556100128c3dabff71a4792c8dd68380c 20-external.patch"