aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-05-22 01:58:51 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-05-22 01:58:51 -0600
commitde95a547405d676f9987667166638b5a818788a2 (patch)
treefa7ae13080b952444ccc6a13e511bc0730093b00
parent7b8a9ef2fc664b6ee19455022c088b8c07f81638 (diff)
downloadalpine_aports-de95a547405d676f9987667166638b5a818788a2.tar.bz2
alpine_aports-de95a547405d676f9987667166638b5a818788a2.tar.xz
alpine_aports-de95a547405d676f9987667166638b5a818788a2.zip
community/krita: fix FTBFS on OpenGLES (closes #11505)
-rw-r--r--community/krita/APKBUILD9
-rw-r--r--community/krita/pure-opengles-compat.patch56
2 files changed, 61 insertions, 4 deletions
diff --git a/community/krita/APKBUILD b/community/krita/APKBUILD
index cf56dff78d..0a6acf3661 100644
--- a/community/krita/APKBUILD
+++ b/community/krita/APKBUILD
@@ -2,9 +2,8 @@
2# Maintainer: Bart Ribbers <bribbers@disroot.org> 2# Maintainer: Bart Ribbers <bribbers@disroot.org>
3pkgname=krita 3pkgname=krita
4pkgver=4.2.9 4pkgver=4.2.9
5pkgrel=1 5pkgrel=2
6#arch="all !armhf !mips !mips64" # Blocked by py3-qt5 -> qt5-qtdeclarative 6arch="all !armhf !mips !mips64" # Blocked by py3-qt5 -> qt5-qtdeclarative
7arch="" # ftbfs
8url="https://krita.org/" 7url="https://krita.org/"
9pkgdesc="Free digital painting application. Digital Painting, Creative Freedom!" 8pkgdesc="Free digital painting application. Digital Painting, Creative Freedom!"
10license="GPL-2.0-or-later" 9license="GPL-2.0-or-later"
@@ -12,6 +11,7 @@ makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev qt5-qtmultimedia-d
12checkdepends="xvfb-run" 11checkdepends="xvfb-run"
13source="https://download.kde.org/stable/krita/$pkgver/krita-$pkgver.tar.xz 12source="https://download.kde.org/stable/krita/$pkgver/krita-$pkgver.tar.xz
14 fix-crash-with-c-locale.patch 13 fix-crash-with-c-locale.patch
14 pure-opengles-compat.patch
15 " 15 "
16subpackages="$pkgname-lang" 16subpackages="$pkgname-lang"
17options="!check" # Breaks compilation on Musl https://bugs.kde.org/show_bug.cgi?id=412058 17options="!check" # Breaks compilation on Musl https://bugs.kde.org/show_bug.cgi?id=412058
@@ -36,4 +36,5 @@ package() {
36} 36}
37 37
38sha512sums="66eef3d1b5647e62551276662ef4332f15abc022f1032f27a2ad695a8d2dc5fa758146492a9da2b8cbd4a52e47c576473029d2aa9728dea3bec869b8173f08c0 krita-4.2.9.tar.xz 38sha512sums="66eef3d1b5647e62551276662ef4332f15abc022f1032f27a2ad695a8d2dc5fa758146492a9da2b8cbd4a52e47c576473029d2aa9728dea3bec869b8173f08c0 krita-4.2.9.tar.xz
39e7a9117d012df4181e05de970f2210264b8685ee76c98b33795f8095d9a17b24b20e6ce920f944b4b5cb940cf672af5ba5fd0ffae9f53085a4f97da61b1e69f6 fix-crash-with-c-locale.patch" 39e7a9117d012df4181e05de970f2210264b8685ee76c98b33795f8095d9a17b24b20e6ce920f944b4b5cb940cf672af5ba5fd0ffae9f53085a4f97da61b1e69f6 fix-crash-with-c-locale.patch
405743461739a658bb471dd6b5434f3a396048cd17cd54127feb4572fa6b3a414d48658aa15b52f7f9c1b6d787caec1af1db1739176f7d6a259b2c32396603fd17 pure-opengles-compat.patch"
diff --git a/community/krita/pure-opengles-compat.patch b/community/krita/pure-opengles-compat.patch
new file mode 100644
index 0000000000..43d6886cb7
--- /dev/null
+++ b/community/krita/pure-opengles-compat.patch
@@ -0,0 +1,56 @@
1diff -urN krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp krita-4.2.9/libs/ui/opengl/kis_opengl_canvas2.cpp
2--- krita-4.2.9.orig/libs/ui/opengl/kis_opengl_canvas2.cpp 2020-05-22 01:52:07.430282697 -0600
3+++ krita-4.2.9/libs/ui/opengl/kis_opengl_canvas2.cpp 2020-05-22 01:53:24.310617820 -0600
4@@ -46,10 +46,6 @@
5 #include "KisOpenGLModeProber.h"
6 #include <KoColorModelStandardIds.h>
7
8-#ifndef Q_OS_MACOS
9-#include <QOpenGLFunctions_2_1>
10-#endif
11-
12 #define NEAR_VAL -1000.0
13 #define FAR_VAL 1000.0
14
15@@ -104,10 +100,6 @@
16 QVector3D vertices[6];
17 QVector2D texCoords[6];
18
19-#ifndef Q_OS_MACOS
20- QOpenGLFunctions_2_1 *glFn201;
21-#endif
22-
23 qreal pixelGridDrawingThreshold;
24 bool pixelGridEnabled;
25 QColor gridColor;
26@@ -271,16 +263,6 @@
27 {
28 KisOpenGL::initializeContext(context());
29 initializeOpenGLFunctions();
30-#ifndef Q_OS_MACOS
31- if (!KisOpenGL::hasOpenGLES()) {
32- d->glFn201 = context()->versionFunctions<QOpenGLFunctions_2_1>();
33- if (!d->glFn201) {
34- warnUI << "Cannot obtain QOpenGLFunctions_2_1, glLogicOp cannot be used";
35- }
36- } else {
37- d->glFn201 = nullptr;
38- }
39-#endif
40
41 KisConfig cfg(true);
42 d->openGLImageTextures->setProofingConfig(canvas()->proofingConfiguration());
43@@ -446,13 +428,7 @@
44 glHint(GL_LINE_SMOOTH_HINT, GL_NICEST);
45
46 glEnable(GL_COLOR_LOGIC_OP);
47-#ifndef Q_OS_MACOS
48- if (d->glFn201) {
49- d->glFn201->glLogicOp(GL_XOR);
50- }
51-#else
52 glLogicOp(GL_XOR);
53-#endif
54 } else {
55 glEnable(GL_BLEND);
56 glBlendFuncSeparate(GL_ONE_MINUS_DST_COLOR, GL_ZERO, GL_ONE, GL_ONE);