aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-17 23:14:29 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-27 15:55:46 +0000
commit99407bb3d36aade42d606c65101b9af627cce3fd (patch)
treefc4457643385587674d07b444ec5d611f90f119d
parentd378948d72aafb68e0f6ee3abbadfbd33ceda2fa (diff)
downloadalpine_aports-99407bb3d36aade42d606c65101b9af627cce3fd.tar.bz2
alpine_aports-99407bb3d36aade42d606c65101b9af627cce3fd.tar.xz
alpine_aports-99407bb3d36aade42d606c65101b9af627cce3fd.zip
testing/zita-resampler: new aport
https://kokkinizita.linuxaudio.org/linuxaudio library for resampling audio signals
-rw-r--r--testing/zita-resampler/APKBUILD30
-rw-r--r--testing/zita-resampler/patch-Makefile.patch35
2 files changed, 65 insertions, 0 deletions
diff --git a/testing/zita-resampler/APKBUILD b/testing/zita-resampler/APKBUILD
new file mode 100644
index 0000000000..2a641d7091
--- /dev/null
+++ b/testing/zita-resampler/APKBUILD
@@ -0,0 +1,30 @@
1# Contributor: David Demelier <markand@malikania.fr>
2# Maintainer: David Demelier <markand@malikania.fr>
3pkgname=zita-resampler
4pkgver=1.6.2
5pkgrel=0
6pkgdesc="library for resampling audio signals"
7url="https://kokkinizita.linuxaudio.org/linuxaudio"
8arch="all"
9license="GPL-3.0-only"
10makedepends="libsndfile-dev"
11subpackages="$pkgname-dev $pkgname-doc"
12source="https://kokkinizita.linuxaudio.org/linuxaudio/downloads/zita-resampler-$pkgver.tar.bz2
13 patch-Makefile.patch"
14options="!check" # No tests
15
16build() {
17 make -C source
18 # Poorly written makefile that may only build apps if the library
19 # is installed system wide. Fake it locally.
20 ln -sv lib$pkgname.so.$pkgver source/lib$pkgname.so
21 make CXXFLAGS="-I../source $CXXFLAGS" LDFLAGS="-L../source $LDFLAGS" -C apps
22}
23
24package() {
25 make PREFIX=/usr LIBDIR=/usr/lib DESTDIR="$pkgdir" -C source install
26 make PREFIX=/usr LIBDIR=/usr/lib DESTDIR="$pkgdir" -C apps install
27}
28
29sha512sums="d547419dd222c8a399d8f196efa1ec88a3f781275b696ae2fe1bb6e2fc329285affb8aace85972c304ad256becc4a155534dd5ef4ce3c57cbc9dcca0122b670c zita-resampler-1.6.2.tar.bz2
302b69d34c768465ac92a3f6e3fbccb89099b221c097c22323f10b6db0a7d8941d805dc1869f51d172bfe0e86ce53e0f112c5cce9647f24795c1faa09573b1531d patch-Makefile.patch"
diff --git a/testing/zita-resampler/patch-Makefile.patch b/testing/zita-resampler/patch-Makefile.patch
new file mode 100644
index 0000000000..a7b0925575
--- /dev/null
+++ b/testing/zita-resampler/patch-Makefile.patch
@@ -0,0 +1,35 @@
1Calls ldconfig which is not available and remove -march=native because it's not
2portable across platforms.
3
4Upstream: not yet, in touch with the author.
5--- a/apps/Makefile 2020-04-17 19:56:50.213695405 +0200
6+++ b/apps/Makefile 2020-04-17 19:56:59.230416753 +0200
7@@ -55,8 +55,8 @@
8
9
10 install: all
11- install -d $(BINDIR)
12- install -d $(MANDIR)
13+ install -d $(DESTDIR)$(BINDIR)
14+ install -d $(DESTDIR)$(MANDIR)
15 install -m 755 zresample $(DESTDIR)$(BINDIR)
16 install -m 755 zretune $(DESTDIR)$(BINDIR)
17 install -m 644 zresample.1.gz $(DESTDIR)$(MANDIR)
18--- a/source/Makefile 2020-04-19 10:26:26.758860827 +0200
19+++ b/source/Makefile 2020-04-19 10:26:38.365583098 +0200
20@@ -33,7 +33,6 @@
21
22 CPPFLAGS += -I. -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS
23 CXXFLAGS += -Wall -fPIC -O2 -ffast-math
24-CXXFLAGS += -march=native
25 LDFLAGS +=
26 LDLIBS +=
27
28@@ -58,7 +57,6 @@
29 install -d $(DESTDIR)$(LIBDIR)
30 install -m 644 $(ZITA-RESAMPLER_H) $(DESTDIR)$(INCDIR)/zita-resampler
31 install -m 755 $(ZITA-RESAMPLER_MIN) $(DESTDIR)$(LIBDIR)
32- ldconfig
33 ln -sf $(ZITA-RESAMPLER_MIN) $(DESTDIR)$(LIBDIR)/$(ZITA-RESAMPLER_SO)
34
35 uninstall: