aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-05-28 01:16:42 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-05-28 06:11:26 +0000
commit45f3dffaea99494ed56e7622aca07e1c41117b1d (patch)
treecbdc2e675e97a151c47af6154e7909fa632156a2
parent6d71a7552b89392baca707a6f9cd8bf80d5d9a8e (diff)
downloadalpine_aports-45f3dffaea99494ed56e7622aca07e1c41117b1d.tar.bz2
alpine_aports-45f3dffaea99494ed56e7622aca07e1c41117b1d.tar.xz
alpine_aports-45f3dffaea99494ed56e7622aca07e1c41117b1d.zip
testing/hyperfine: add shell completions
-rw-r--r--testing/hyperfine/APKBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/testing/hyperfine/APKBUILD b/testing/hyperfine/APKBUILD
index cb916bdb5b..fd101a203c 100644
--- a/testing/hyperfine/APKBUILD
+++ b/testing/hyperfine/APKBUILD
@@ -2,13 +2,17 @@
2# Maintainer: 2# Maintainer:
3pkgname=hyperfine 3pkgname=hyperfine
4pkgver=1.10.0 4pkgver=1.10.0
5pkgrel=1 5pkgrel=2
6pkgdesc="Command-line benchmarking tool" 6pkgdesc="Command-line benchmarking tool"
7url="https://github.com/sharkdp/hyperfine" 7url="https://github.com/sharkdp/hyperfine"
8arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # Limited by cargo 8arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # Limited by cargo
9license="Apache-2.0 AND MIT" 9license="Apache-2.0 AND MIT"
10makedepends="cargo" 10makedepends="cargo"
11subpackages="$pkgname-doc" 11subpackages="$pkgname-doc
12 $pkgname-bash-completion
13 $pkgname-zsh-completion
14 $pkgname-fish-completion
15 "
12source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/hyperfine/archive/v$pkgver.tar.gz" 16source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/hyperfine/archive/v$pkgver.tar.gz"
13 17
14build() { 18build() {
@@ -24,6 +28,13 @@ package() {
24 "$pkgdir"/usr/bin/hyperfine 28 "$pkgdir"/usr/bin/hyperfine
25 install -Dm644 doc/hyperfine.1 \ 29 install -Dm644 doc/hyperfine.1 \
26 "$pkgdir"/usr/share/man/man1/hyperfine.1 30 "$pkgdir"/usr/share/man/man1/hyperfine.1
31
32 install -Dm644 target/release/build/hyperfine-*/out/hyperfine.bash \
33 "$pkgdir/usr/share/bash-completion/completions/hyperfine"
34 install -Dm644 target/release/build/hyperfine-*/out/_hyperfine \
35 "$pkgdir/usr/share/zsh/site-functions/_hyperfine"
36 install -Dm644 target/release/build/hyperfine-*/out/hyperfine.fish \
37 "$pkgdir/usr/share/fish/completions/hyperfine.fish"
27} 38}
28 39
29sha512sums="4d5a1549f8b35601fd1b3e2978c2a1be494adbcf3b614657005e4cf5b909bfb3999d4e31eb988d63cf20c2f41c0dcce1785306a46664d89357cec34c9a03c04a hyperfine-1.10.0.tar.gz" 40sha512sums="4d5a1549f8b35601fd1b3e2978c2a1be494adbcf3b614657005e4cf5b909bfb3999d4e31eb988d63cf20c2f41c0dcce1785306a46664d89357cec34c9a03c04a hyperfine-1.10.0.tar.gz"