aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-05-27 23:10:14 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-05-27 23:10:14 +0000
commit6d71a7552b89392baca707a6f9cd8bf80d5d9a8e (patch)
treeb9daa253c068714f630b104f656f80cd5c8c7d05
parent5fb44497ae3a81502ee6e3ab967f4199e2c52177 (diff)
downloadalpine_aports-6d71a7552b89392baca707a6f9cd8bf80d5d9a8e.tar.bz2
alpine_aports-6d71a7552b89392baca707a6f9cd8bf80d5d9a8e.tar.xz
alpine_aports-6d71a7552b89392baca707a6f9cd8bf80d5d9a8e.zip
community/gitlab-runner: upgrade embedded docker to one which will build on mips
-rw-r--r--community/gitlab-runner/APKBUILD8
-rw-r--r--community/gitlab-runner/change-deps.patch12
2 files changed, 17 insertions, 3 deletions
diff --git a/community/gitlab-runner/APKBUILD b/community/gitlab-runner/APKBUILD
index b78fca755d..c7a74057ce 100644
--- a/community/gitlab-runner/APKBUILD
+++ b/community/gitlab-runner/APKBUILD
@@ -11,7 +11,7 @@ pkgrel=1
11_rev=c5874a4b 11_rev=c5874a4b
12pkgdesc="GitLab runner for CI/CD jobs" 12pkgdesc="GitLab runner for CI/CD jobs"
13url="https://docs.gitlab.com/runner/" 13url="https://docs.gitlab.com/runner/"
14arch="all !mips !mips64" 14arch="all"
15license="MIT" 15license="MIT"
16makedepends="go" 16makedepends="go"
17install="$pkgname.pre-install $pkgname.pre-upgrade" 17install="$pkgname.pre-install $pkgname.pre-upgrade"
@@ -21,7 +21,8 @@ options="!check chmod-clean" # Need to be run in a git repo
21subpackages="$pkgname-helper $pkgname-openrc" 21subpackages="$pkgname-helper $pkgname-openrc"
22source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-runner-v$pkgver.tar.gz 22source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-runner-v$pkgver.tar.gz
23 $pkgname.initd 23 $pkgname.initd
24 $pkgname.confd" 24 $pkgname.confd
25 change-deps.patch"
25 26
26builddir="$srcdir/src/gitlab.com/gitlab-org/$pkgname" 27builddir="$srcdir/src/gitlab.com/gitlab-org/$pkgname"
27 28
@@ -67,4 +68,5 @@ helper() {
67 68
68sha512sums="c4bdf4d552a2612ef035d30303d69c3c352800761bdc9853004cc255ef2cf9056b036510ad6a898c140adbd4d07bb097fe0143769909c96dfad1540f5913ffa6 gitlab-runner-v12.10.2.tar.gz 69sha512sums="c4bdf4d552a2612ef035d30303d69c3c352800761bdc9853004cc255ef2cf9056b036510ad6a898c140adbd4d07bb097fe0143769909c96dfad1540f5913ffa6 gitlab-runner-v12.10.2.tar.gz
692ae753efc220c46378e84831f01b289f3689af70cd7cbb0bbcc04dc17c910d65eb5105c198d5a23098e27797a7d1c695f49b244993ea4676eb9ec9cda064f44e gitlab-runner.initd 702ae753efc220c46378e84831f01b289f3689af70cd7cbb0bbcc04dc17c910d65eb5105c198d5a23098e27797a7d1c695f49b244993ea4676eb9ec9cda064f44e gitlab-runner.initd
70243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445 gitlab-runner.confd" 71243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445 gitlab-runner.confd
72ef6d0ed90f29d94816f871a2589eaad69690141e395bae8cdf2de37ed51a8909284ec483dbab0999997b8a854e7672e8f5656b87170f8fb890f9f45071a827cb change-deps.patch"
diff --git a/community/gitlab-runner/change-deps.patch b/community/gitlab-runner/change-deps.patch
new file mode 100644
index 0000000000..fd573f7e95
--- /dev/null
+++ b/community/gitlab-runner/change-deps.patch
@@ -0,0 +1,12 @@
1--- gitlab-runner/go.mod
2+++ gitlab-runner/go.mod
3@@ -81,6 +81,8 @@
4 sigs.k8s.io/yaml v1.1.0 // indirect
5 )
6
7-replace github.com/docker/docker v1.4.2-0.20190822180741-9552f2b2fdde => github.com/docker/engine v1.4.2-0.20190822180741-9552f2b2fdde
8+replace github.com/docker/docker v1.4.2-0.20190822180741-9552f2b2fdde => github.com/docker/engine v19.03.9
9
10 replace github.com/minio/go-homedir v0.0.0-20190425115525-017018655514 => gitlab.com/steveazz/go-homedir v0.0.0-20190425115525-017018655514
11+
12+replace github.com/vishvananda/netns => github.com/vishvananda/netns v0.0.0-20200218060606-52d707b772fe