aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-28 14:49:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 14:49:33 +0000
commit8f7cf916fc0895b6d8061ded0ba65673f06764f4 (patch)
tree63428afe95b7ebd5ad701051c18059d8cee030a4
parent27b94d8789f36af8cdf9e9eab23b2a9d484cfbff (diff)
downloadalpine_aports-8f7cf916fc0895b6d8061ded0ba65673f06764f4.tar.bz2
alpine_aports-8f7cf916fc0895b6d8061ded0ba65673f06764f4.tar.xz
alpine_aports-8f7cf916fc0895b6d8061ded0ba65673f06764f4.zip
main/abuild: upgrade to 3.6.0
-rw-r--r--main/abuild/0001-abuild.conf-enable-PIE-binaries-by-default-for-go-as.patch37
-rw-r--r--main/abuild/0002-Revert-abuild-include-pkgname-in-temporary-rootbld-d.patch28
-rw-r--r--main/abuild/APKBUILD14
3 files changed, 5 insertions, 74 deletions
diff --git a/main/abuild/0001-abuild.conf-enable-PIE-binaries-by-default-for-go-as.patch b/main/abuild/0001-abuild.conf-enable-PIE-binaries-by-default-for-go-as.patch
deleted file mode 100644
index a3c2643d14..0000000000
--- a/main/abuild/0001-abuild.conf-enable-PIE-binaries-by-default-for-go-as.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 828b826662638b78834332f9cf72f18ac1fbf86f Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
3Date: Sun, 17 Mar 2019 17:03:59 +0100
4Subject: [PATCH] abuild.conf: enable PIE binaries by default for go as well
5
6From `go help environment`:
7
8 GOFLAGS
9 A space-separated list of -flag=value settings to apply
10 to go commands by default, when the given flag is known by
11 the current command. Flags listed on the command-line
12 are applied after this list and therefore override it.
13
14And from `go help build`:
15
16 -buildmode mode
17 build mode to use. See 'go help buildmode' for more.
18
19Setting this environment variable in /etc/abuild.conf allows us to build
20all go binaries on the builders as PIE without needing to patch the go
21compiler itself.
22---
23 abuild.conf | 1 +
24 1 file changed, 1 insertion(+)
25
26diff --git a/abuild.conf b/abuild.conf
27index 6721e7f..c00e31b 100644
28--- a/abuild.conf
29+++ b/abuild.conf
30@@ -2,6 +2,7 @@ export CFLAGS="-Os -fomit-frame-pointer"
31 export CXXFLAGS="$CFLAGS"
32 export CPPFLAGS="$CFLAGS"
33 export LDFLAGS="-Wl,--as-needed"
34+export GOFLAGS="-buildmode=pie"
35
36 export JOBS=2
37 export MAKEFLAGS=-j$JOBS
diff --git a/main/abuild/0002-Revert-abuild-include-pkgname-in-temporary-rootbld-d.patch b/main/abuild/0002-Revert-abuild-include-pkgname-in-temporary-rootbld-d.patch
deleted file mode 100644
index 2402b2db6d..0000000000
--- a/main/abuild/0002-Revert-abuild-include-pkgname-in-temporary-rootbld-d.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 5177936a2bd4aa9e0badea94e48aee1a939e467a Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
3Date: Fri, 17 Apr 2020 12:21:48 +0200
4Subject: [PATCH] Revert "abuild: include $pkgname in temporary rootbld
5 directory"
6
7This commit broke abuild-rmtemp which has a prefix check to ensure it
8doesn't remove non-abuild directory. Revert the commit instead of
9adjusting the prefix check for now.
10
11This reverts commit d0828c06557773f252b645618500699a941bd091.
12---
13 abuild.in | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/abuild.in b/abuild.in
17index 2af9452..fbe2fbd 100644
18--- a/abuild.in
19+++ b/abuild.in
20@@ -2257,7 +2257,7 @@ rootbld() {
21
22 mkusers
23
24- BUILD_ROOT=$(mktemp -d "/var/tmp/abuild-$pkgname.XXXXXXXXXX")
25+ BUILD_ROOT=$(mktemp -d /var/tmp/abuild.XXXXXXXXXX)
26
27 mkdir -p "$BUILD_ROOT/proc" "$BUILD_ROOT/etc/apk/keys" \
28 "$BUILD_ROOT/$HOME/.abuild" "$BUILD_ROOT/$aportsgit" \
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 6bd10e3c71..d6fdc9b5e6 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,8 +1,8 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=abuild 2pkgname=abuild
3pkgver=3.6.0_rc1 3pkgver=3.6.0
4_ver=${pkgver%_git*} 4_ver=${pkgver%_git*}
5pkgrel=2 5pkgrel=0
6pkgdesc="Script to build Alpine Packages" 6pkgdesc="Script to build Alpine Packages"
7url="https://git.alpinelinux.org/cgit/abuild/" 7url="https://git.alpinelinux.org/cgit/abuild/"
8arch="all" 8arch="all"
@@ -24,10 +24,8 @@ subpackages="
24 " 24 "
25options="suid !check" 25options="suid !check"
26pkggroups="abuild" 26pkggroups="abuild"
27source="https://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.xz 27source="https://dev.alpinelinux.org/archive/abuild/abuild-$_ver.tar.bz2"
28 0001-abuild.conf-enable-PIE-binaries-by-default-for-go-as.patch 28builddir="$srcdir"/abuild-$pkgver
29 0002-Revert-abuild-include-pkgname-in-temporary-rootbld-d.patch"
30builddir="$srcdir"/abuild-v$pkgver
31 29
32prepare() { 30prepare() {
33 default_prepare 31 default_prepare
@@ -68,6 +66,4 @@ _rootbld() {
68 mkdir -p "$subpkgdir" 66 mkdir -p "$subpkgdir"
69} 67}
70 68
71sha512sums="28a17439156462e487c47970691943c5a0df13a27a515093a192b29c9bc18dfe489900cfc8f3972be08c8e310439109660b55f6e3b6ce5f64f014ab76f0e4988 abuild-3.6.0_rc1.tar.xz 69sha512sums="fd5b8326171c9ab8f975e147995520990e7e1210929662ce4687267dad68812721ee9eb019bf7430f01abebc9278e6be1c0358d5b9bb2918bc96ccd5e2f1b3df abuild-3.6.0.tar.bz2"
721f1e4fd291b6e52d7628d43b5b29db4aa0762f3dc8b87827aafc7052b752057026d15594d142dda96e149815f4352f98c10379bdea75b032e303a9351027ef9d 0001-abuild.conf-enable-PIE-binaries-by-default-for-go-as.patch
73635c7a8e741eb3af04f5ec606251266676940b3cce0644108825003115a45d79b6469cf9ced1e1c8c3327995e459d493de93ebb4a3dd6a50eac3b4bd745d91cd 0002-Revert-abuild-include-pkgname-in-temporary-rootbld-d.patch"