aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-22 18:19:24 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 19:01:29 +0000
commita5e6bb7ba5d7bf0f099b2fe4c12a8d935514c409 (patch)
treef2048f522f971032b3342a31906a5ced5ceca869
parent6c885cfb750137fd1bc76cbbe30cc3596fa1228f (diff)
downloadalpine_aports-a5e6bb7ba5d7bf0f099b2fe4c12a8d935514c409.tar.bz2
alpine_aports-a5e6bb7ba5d7bf0f099b2fe4c12a8d935514c409.tar.xz
alpine_aports-a5e6bb7ba5d7bf0f099b2fe4c12a8d935514c409.zip
main/alpine-baselayout: fix file extension of locale script
/etc/profile loops over files that end with .sh, so if these don't have a .sh file extension on locale it's not sourced. As such, changing the extension of the locale script to .sh means that it's sourced by default. Strictly speaking musl already uses "C.UTF-8" as default[0], but some software will not use UTF-8 features without an UTF-8 locale set. E.g. DBus wont enable UTF-8 mode without an UTF-8 locale set, which breaks applications which expect it to be set, like gnome-terminal. Other software which is hit by this is e.g. tmux, see #7374. fixes #11583 0: https://wiki.musl-libc.org/functional-differences-from-glibc.html#Default-locale
-rw-r--r--main/alpine-baselayout/APKBUILD6
-rw-r--r--main/alpine-baselayout/locale3
-rw-r--r--main/alpine-baselayout/locale.sh3
3 files changed, 6 insertions, 6 deletions
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index e017a208e2..5878e85e58 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -14,7 +14,7 @@ install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade
14source="mkmntdirs.c 14source="mkmntdirs.c
15 crontab 15 crontab
16 color_prompt 16 color_prompt
17 locale 17 locale.sh
18 18
19 aliases.conf 19 aliases.conf
20 blacklist.conf 20 blacklist.conf
@@ -118,7 +118,7 @@ package() {
118 install -m600 "$srcdir"/crontab "$pkgdir"/etc/crontabs/root 118 install -m600 "$srcdir"/crontab "$pkgdir"/etc/crontabs/root
119 install -m644 \ 119 install -m644 \
120 "$srcdir"/color_prompt \ 120 "$srcdir"/color_prompt \
121 "$srcdir"/locale \ 121 "$srcdir"/locale.sh \
122 "$pkgdir"/etc/profile.d/ 122 "$pkgdir"/etc/profile.d/
123 install -m644 \ 123 install -m644 \
124 "$srcdir"/aliases.conf \ 124 "$srcdir"/aliases.conf \
@@ -224,7 +224,7 @@ package() {
224sha512sums="199a34716b1f029407b08679fed4fda58384a1ccefbbec9abe1c64f4a3f7ad2a89bc7c02fc19a7f791f7c6bb87f9f0c708cb3f18c027cb7f54f25976eba4b839 mkmntdirs.c 224sha512sums="199a34716b1f029407b08679fed4fda58384a1ccefbbec9abe1c64f4a3f7ad2a89bc7c02fc19a7f791f7c6bb87f9f0c708cb3f18c027cb7f54f25976eba4b839 mkmntdirs.c
2256e169c0975a1ad1ad871a863e8ee83f053de9ad0b58d94952efa4c28a8c221445d9e9732ad8b52832a50919c2f39aa965a929b3d5b3f9e62f169e2b2e0813d82 crontab 2256e169c0975a1ad1ad871a863e8ee83f053de9ad0b58d94952efa4c28a8c221445d9e9732ad8b52832a50919c2f39aa965a929b3d5b3f9e62f169e2b2e0813d82 crontab
2267fcb5df98b0f19e609cb9444b2e6ca5ee97f5f308eb407436acdd0115781623fd89768a9285e9816e36778e565b6f27055f2a586a58f19d6d880de5446d263c4 color_prompt 2267fcb5df98b0f19e609cb9444b2e6ca5ee97f5f308eb407436acdd0115781623fd89768a9285e9816e36778e565b6f27055f2a586a58f19d6d880de5446d263c4 color_prompt
227ff94cd77c79a523b79f18ddb6df5d489bd78879e63f2916c0584bf5177cace702663986bd366cbdfdbd9da950a6f32fb21037cab8d43658e892818f02dfae297 locale 227b2fc9b72846a43a45ba9a8749e581cef34d1915836833b51b7919dfbf4e275b7d55fec4dea7b23df3796380910971a41331e53e8cf0d304834e3da02cc135e5a locale.sh
228bfe947bdd69e7d93b32c8cb4e2cabe5717cb6c1e1f49a74015ac2cfb13e96d1f12c4be23ae93a1d61aaa3760d33a032fa9bd99f227fb21223a76b5f5908acc65 aliases.conf 228bfe947bdd69e7d93b32c8cb4e2cabe5717cb6c1e1f49a74015ac2cfb13e96d1f12c4be23ae93a1d61aaa3760d33a032fa9bd99f227fb21223a76b5f5908acc65 aliases.conf
2290b93db8ba1b5d16b2c23f9b6daea27a3a76c059a1f5ea0369af526ea3f4ff92a6040face89e95c45cf7daaa7a663f229df0f6c1ba24073ef4b2f7b74b298fdae blacklist.conf 2290b93db8ba1b5d16b2c23f9b6daea27a3a76c059a1f5ea0369af526ea3f4ff92a6040face89e95c45cf7daaa7a663f229df0f6c1ba24073ef4b2f7b74b298fdae blacklist.conf
23049109d434b577563849c43dd8141961ca798dada74d4d3f49003dac1911f522c43438b8241fa254e4faacdd90058f4d39a7d69b1f493f6d57422c1f706547c95 i386.conf 23049109d434b577563849c43dd8141961ca798dada74d4d3f49003dac1911f522c43438b8241fa254e4faacdd90058f4d39a7d69b1f493f6d57422c1f706547c95 i386.conf
diff --git a/main/alpine-baselayout/locale b/main/alpine-baselayout/locale
deleted file mode 100644
index 0b29557277..0000000000
--- a/main/alpine-baselayout/locale
+++ /dev/null
@@ -1,3 +0,0 @@
1CHARSET=UTF-8
2LANG=C.UTF-8
3LC_COLLATE=C
diff --git a/main/alpine-baselayout/locale.sh b/main/alpine-baselayout/locale.sh
new file mode 100644
index 0000000000..bf75c08272
--- /dev/null
+++ b/main/alpine-baselayout/locale.sh
@@ -0,0 +1,3 @@
1export CHARSET=UTF-8
2export LANG=C.UTF-8
3export LC_COLLATE=C