aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-07-10 06:18:34 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-07-10 11:06:06 +0000
commit88bc7e0870aa598ac3cee8391c6a39a92f44435f (patch)
treebe31e78a80021796c2117dbec35afb6263fc24c8
parentfc119caff000a962aa4bf96e06011a44af0ef24c (diff)
downloadalpine_aports-88bc7e0870aa598ac3cee8391c6a39a92f44435f.tar.bz2
alpine_aports-88bc7e0870aa598ac3cee8391c6a39a92f44435f.tar.xz
alpine_aports-88bc7e0870aa598ac3cee8391c6a39a92f44435f.zip
main/alpine-baselayout: misc fixes
- suggest the setup-alpine command in motd - fix sysctl location and contents put sysctl to /etc/sysctl.d with 00 prefix so later sysctl.d files can override it if needed. also remove ip_forward, it default to zero in kernel, and is controlled by iptables init.d or quagga. - mkmntdirs: add missing header string.h is needed for strcmp definition - profile: remove LANG. ref #4428 (cherry picked from commit ee65d272cda3aee4ac47ac67433ee7853d35702a)
-rw-r--r--main/alpine-baselayout/APKBUILD23
-rw-r--r--main/alpine-baselayout/mkmntdirs.c1
-rw-r--r--main/alpine-baselayout/profile1
3 files changed, 15 insertions, 10 deletions
diff --git a/main/alpine-baselayout/APKBUILD b/main/alpine-baselayout/APKBUILD
index 26abe98691..dfb7d1ea82 100644
--- a/main/alpine-baselayout/APKBUILD
+++ b/main/alpine-baselayout/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=alpine-baselayout 2pkgname=alpine-baselayout
3pkgver=2.3.1 3pkgver=2.3.2
4pkgrel=6 4pkgrel=0
5pkgdesc="Alpine base dir structure and init scripts" 5pkgdesc="Alpine base dir structure and init scripts"
6url="http://git.alpinelinux.org/cgit/aports/tree/main/alpine-baselayout" 6url="http://git.alpinelinux.org/cgit/aports/tree/main/alpine-baselayout"
7arch="all" 7arch="all"
@@ -71,6 +71,7 @@ package() {
71 etc/periodic/hourly \ 71 etc/periodic/hourly \
72 etc/periodic/monthly \ 72 etc/periodic/monthly \
73 etc/periodic/weekly \ 73 etc/periodic/weekly \
74 etc/sysctl.d \
74 home \ 75 home \
75 lib/firmware \ 76 lib/firmware \
76 lib/mdev \ 77 lib/mdev \
@@ -129,11 +130,15 @@ The Alpine Wiki contains a large amount of how-to guides and general
129information about administrating Alpine systems. 130information about administrating Alpine systems.
130See <http://wiki.alpinelinux.org>. 131See <http://wiki.alpinelinux.org>.
131 132
133You can setup the system with the command: setup-alpine
134
132You may change this message by editing /etc/motd. 135You may change this message by editing /etc/motd.
133 136
134EOF 137EOF
135 cat > "$pkgdir"/etc/sysctl.conf <<EOF 138 cat > "$pkgdir"/etc/sysctl.conf <<EOF
136net.ipv4.ip_forward = 0 139# content of this file will override /etc/sysctl.d/*
140EOF
141 cat > "$pkgdir"/etc/sysctl.d/00-alpine.conf <<EOF
137net.ipv4.tcp_syncookies = 1 142net.ipv4.tcp_syncookies = 1
138net.ipv4.conf.default.rp_filter = 1 143net.ipv4.conf.default.rp_filter = 1
139net.ipv4.conf.all.rp_filter = 1 144net.ipv4.conf.all.rp_filter = 1
@@ -161,7 +166,7 @@ EOF
161 ln -s /proc/mounts "$pkgdir"/etc/mtab 166 ln -s /proc/mounts "$pkgdir"/etc/mtab
162 167
163} 168}
164md5sums="686863b10c1cfdf07322ea0ecc977da5 mkmntdirs.c 169md5sums="db115e3302157a836a746bfd1d3f39be mkmntdirs.c
1656e67923e98287d5133b565acd44cb506 crontab 1706e67923e98287d5133b565acd44cb506 crontab
166d7da26e76752b2e31c66b63f40a73397 color_prompt 171d7da26e76752b2e31c66b63f40a73397 color_prompt
1676945faabb2a18cee73c0a6d78b499084 aliases.conf 1726945faabb2a18cee73c0a6d78b499084 aliases.conf
@@ -171,10 +176,10 @@ f9e3eac60200d41dd5569eeabb4eddff i386.conf
17167ee12ef936978ec0e7d295eaba1e420 group 17667ee12ef936978ec0e7d295eaba1e420 group
172d93ca19f6867a1a3918fa782d9b7c512 inittab 177d93ca19f6867a1a3918fa782d9b7c512 inittab
173d05579984e737021401d8c40153c5b5d passwd 178d05579984e737021401d8c40153c5b5d passwd
174dcb55fbc491316cdb3874f3ddae8f566 profile 1792939a40b911cac04c85263072c663973 profile
175394f8cd9fbf549f1d1b9a5bba680fc92 protocols 180394f8cd9fbf549f1d1b9a5bba680fc92 protocols
1765278bea4f45f4e289f72897b84dcb909 services" 1815278bea4f45f4e289f72897b84dcb909 services"
177sha256sums="9c5f25b07bfc28fff4232b5fd64fce45dd10ddd0f4a59741f2ca74ff99e4db3e mkmntdirs.c 182sha256sums="44ca046e8188a4c9d32577470c1cbb864fe20889a3c4e6309d1d665c4c13a852 mkmntdirs.c
178575d810a9fae5f2f0671c9b2c0ce973e46c7207fbe5cb8d1b0d1836a6a0470e3 crontab 183575d810a9fae5f2f0671c9b2c0ce973e46c7207fbe5cb8d1b0d1836a6a0470e3 crontab
179a00b56dbd437d3f2c32ced50974daa3cfc84a8dd1cbaf75cf307be20b398fc75 color_prompt 184a00b56dbd437d3f2c32ced50974daa3cfc84a8dd1cbaf75cf307be20b398fc75 color_prompt
1803e2daa0326fc4d73921cd693dff47b211d0ba3d92ad62fca072c259600695693 aliases.conf 1853e2daa0326fc4d73921cd693dff47b211d0ba3d92ad62fca072c259600695693 aliases.conf
@@ -184,10 +189,10 @@ a00b56dbd437d3f2c32ced50974daa3cfc84a8dd1cbaf75cf307be20b398fc75 color_prompt
184591fce261465cd838bcfddc9a4e560cc4f0c1d603921c200c350b935213b9ca1 group 189591fce261465cd838bcfddc9a4e560cc4f0c1d603921c200c350b935213b9ca1 group
1858a54b20451ba9469b5260f76faa90fbde96915bf33e7f03f88bdbaf813400485 inittab 1908a54b20451ba9469b5260f76faa90fbde96915bf33e7f03f88bdbaf813400485 inittab
186348e451c8d4d2d9807d78114d100942f1c5481fd52550c821922b84a16f02d42 passwd 191348e451c8d4d2d9807d78114d100942f1c5481fd52550c821922b84a16f02d42 passwd
1878165abfa26a1754c317228e78142f4a89dd72a669951d269f0b68d7a92faf1e8 profile 1928ef550a4efc4bed1630b47c48aefbf1c63ae6e8d9c1246be92135465965712d2 profile
188a6695dbd53b87c7b41dfdafd40b1c8ba34fed2f0fa8eaaa296ad17c0b154603e protocols 193a6695dbd53b87c7b41dfdafd40b1c8ba34fed2f0fa8eaaa296ad17c0b154603e protocols
189e96af627f7774e8c87b0de843556a355fea6150c4d64fa4e2ff2c5fd610e7a79 services" 194e96af627f7774e8c87b0de843556a355fea6150c4d64fa4e2ff2c5fd610e7a79 services"
190sha512sums="670fce7a9d5c492289b7dca06077a5109672fbec2accf21bfb3531651f0434939ff07e71c61949df2c0bfe3c2f178a503f0086867b84e3874abd5c90233149b7 mkmntdirs.c 195sha512sums="94a75cbd309e7b7d3b1bbbddb6f361335336d804c2a331b9963de7cee38633217bcd533b4b29a4333ba477c6a13fe9a160c822108027a03a84b334bc76bf8ebd mkmntdirs.c
1916e169c0975a1ad1ad871a863e8ee83f053de9ad0b58d94952efa4c28a8c221445d9e9732ad8b52832a50919c2f39aa965a929b3d5b3f9e62f169e2b2e0813d82 crontab 1966e169c0975a1ad1ad871a863e8ee83f053de9ad0b58d94952efa4c28a8c221445d9e9732ad8b52832a50919c2f39aa965a929b3d5b3f9e62f169e2b2e0813d82 crontab
1927fcb5df98b0f19e609cb9444b2e6ca5ee97f5f308eb407436acdd0115781623fd89768a9285e9816e36778e565b6f27055f2a586a58f19d6d880de5446d263c4 color_prompt 1977fcb5df98b0f19e609cb9444b2e6ca5ee97f5f308eb407436acdd0115781623fd89768a9285e9816e36778e565b6f27055f2a586a58f19d6d880de5446d263c4 color_prompt
1938d55acb0457eec4008ba09c3de92fed6893b72d062edd5dcd74016e9c6c4dfeba7e86620e59d21a7adce11377ec793812c90e9d9771a804097fa64cff646666c aliases.conf 1988d55acb0457eec4008ba09c3de92fed6893b72d062edd5dcd74016e9c6c4dfeba7e86620e59d21a7adce11377ec793812c90e9d9771a804097fa64cff646666c aliases.conf
@@ -197,6 +202,6 @@ b407351a5a64b00100753a13a91f4b1cb51017ae918a91fd37f3a6e76e3b6f562be643e74f969a88
197214d7b26bfdefbe08d150974d1e1635ee4b8ca68a04a22eacf2e465f3a191421fb453ad93f14a1c70f98b628a509d623e005f912270e7552513daa1e50bb1859 group 202214d7b26bfdefbe08d150974d1e1635ee4b8ca68a04a22eacf2e465f3a191421fb453ad93f14a1c70f98b628a509d623e005f912270e7552513daa1e50bb1859 group
198bdb6fe1f3e07466d9badf9a18b1f3fc9585f0a4cb69c00f1fa6d8b1e9903a3c497edefbfd345e324961013999e5692d2ed68ae7defaf1c6e57cc7916f206fd75 inittab 203bdb6fe1f3e07466d9badf9a18b1f3fc9585f0a4cb69c00f1fa6d8b1e9903a3c497edefbfd345e324961013999e5692d2ed68ae7defaf1c6e57cc7916f206fd75 inittab
1993b9be283e171516dd45ee29775a1149ba20d5672bef422a698ed944ce66697e5a80dec21a9a20c079cca895890dbfa73ccbb8000a55504d95ced4e7436d8e16b passwd 2043b9be283e171516dd45ee29775a1149ba20d5672bef422a698ed944ce66697e5a80dec21a9a20c079cca895890dbfa73ccbb8000a55504d95ced4e7436d8e16b passwd
2009e197ec99c97ec2b03b97546d632a865d6e7abe5742ac48bcb458a505ce38abd1010ef93ea8a752251578ea993708324e1d36ccf77ee3e7cde7e8db98cc42d67 profile 205c4088a7148c0f161809852d248d2c2272d9c72be3f968c2e2ba40806f508238496eda0f8f2a42aa092773a56800b1dae9f843a42d93f1bb16ba5f58c111d531b profile
201f1548a2b5a107479446f15905f0f2fbf8762815b2215188d49d905c803786d35de6d98005dc0828fb2486b04aaa356f1216a964befddf1e72cb169656e23b6ac protocols 206f1548a2b5a107479446f15905f0f2fbf8762815b2215188d49d905c803786d35de6d98005dc0828fb2486b04aaa356f1216a964befddf1e72cb169656e23b6ac protocols
202cecfc06b1f455d65b0c54a5651e601298b455771333e39d0109eeffd7ebd8d81b7738738eb647e6d3076230b6f3707782b83662ea3764ec33dc5e0b3453d3965 services" 207cecfc06b1f455d65b0c54a5651e601298b455771333e39d0109eeffd7ebd8d81b7738738eb647e6d3076230b6f3707782b83662ea3764ec33dc5e0b3453d3965 services"
diff --git a/main/alpine-baselayout/mkmntdirs.c b/main/alpine-baselayout/mkmntdirs.c
index 6e3a3ef21d..b3704a07f7 100644
--- a/main/alpine-baselayout/mkmntdirs.c
+++ b/main/alpine-baselayout/mkmntdirs.c
@@ -14,6 +14,7 @@
14#include <err.h> 14#include <err.h>
15#include <mntent.h> 15#include <mntent.h>
16#include <stdio.h> 16#include <stdio.h>
17#include <string.h>
17 18
18 19
19#ifdef DEBUG 20#ifdef DEBUG
diff --git a/main/alpine-baselayout/profile b/main/alpine-baselayout/profile
index 5144f7d9ae..bb99d2915b 100644
--- a/main/alpine-baselayout/profile
+++ b/main/alpine-baselayout/profile
@@ -1,5 +1,4 @@
1export CHARSET=UTF-8 1export CHARSET=UTF-8
2export LANG=en.utf8
3export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin 2export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
4export PAGER=less 3export PAGER=less
5export PS1='\h:\w\$ ' 4export PS1='\h:\w\$ '