aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-12-09 09:32:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-09 09:39:22 +0000
commit7dbdbd5de60b14d427c246022d3d7be13fa6e73e (patch)
treee74570dd207d568798b21008fb80181450f8e1dd
parent9803ba32da13636d4013b2489470ed3544114d06 (diff)
downloadalpine_aports-7dbdbd5de60b14d427c246022d3d7be13fa6e73e.tar.bz2
alpine_aports-7dbdbd5de60b14d427c246022d3d7be13fa6e73e.tar.xz
alpine_aports-7dbdbd5de60b14d427c246022d3d7be13fa6e73e.zip
main/gdk-pixbuf: upgrade to 2.32.2
-rw-r--r--main/gdk-pixbuf/APKBUILD12
-rw-r--r--main/gdk-pixbuf/glibc-malloc.patch28
2 files changed, 4 insertions, 36 deletions
diff --git a/main/gdk-pixbuf/APKBUILD b/main/gdk-pixbuf/APKBUILD
index 547c227777..6e013a43ba 100644
--- a/main/gdk-pixbuf/APKBUILD
+++ b/main/gdk-pixbuf/APKBUILD
@@ -1,6 +1,6 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=gdk-pixbuf 2pkgname=gdk-pixbuf
3pkgver=2.32.1 3pkgver=2.32.2
4pkgrel=0 4pkgrel=0
5pkgdesc="GDK Pixbuf library" 5pkgdesc="GDK Pixbuf library"
6url="http://www.gtk.org/" 6url="http://www.gtk.org/"
@@ -13,7 +13,6 @@ install="$pkgname.pre-deinstall"
13triggers="$pkgname.trigger=/usr/lib/gdk-pixbuf-2.0/*/loaders" 13triggers="$pkgname.trigger=/usr/lib/gdk-pixbuf-2.0/*/loaders"
14subpackages="$pkgname-dev $pkgname-doc $pkgname-lang" 14subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
15source="http://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz 15source="http://ftp.gnome.org/pub/gnome/sources/gdk-pixbuf/${pkgver%.*}/gdk-pixbuf-$pkgver.tar.xz
16 glibc-malloc.patch
17 " 16 "
18replaces="gtk+" 17replaces="gtk+"
19 18
@@ -57,9 +56,6 @@ dev() {
57 default_dev 56 default_dev
58} 57}
59 58
60md5sums="b1590189a2e89fab9f871959c168508c gdk-pixbuf-2.32.1.tar.xz 59md5sums="bbd9b471c60d11ab8ce133a5f04310af gdk-pixbuf-2.32.2.tar.xz"
61c65938b5827467f1a0743c8ba96aa27d glibc-malloc.patch" 60sha256sums="d3ab06fc123b13effed4c27c77cebdfad2173ff20628d82c397b7660ae926145 gdk-pixbuf-2.32.2.tar.xz"
62sha256sums="4432b74f25538c7d6bcb3ca51adabdd666168955f25812a2568dc9637697f3bc gdk-pixbuf-2.32.1.tar.xz 61sha512sums="146cbddc1b4a68715a827fc53d98f213f5e27f4f4a8b3fe6148b96c866b4ca4ab624613ddf196d4b0a01bbddfc6f8438b96ad436d23dfced02d584ff8c2fdf3d gdk-pixbuf-2.32.2.tar.xz"
6360fe43700c5a380d4b9e14669b54c99eba755d7fa5d780aabea6ef13bdc59387 glibc-malloc.patch"
64sha512sums="4c744f166e86c17cafebe0db9434794666b64850a60597e34675cf9b902e48e89c3ff45032a10899944ae59b6c0db63c1ff33c4d2c50846393e77bad3a3adec2 gdk-pixbuf-2.32.1.tar.xz
655bdcc5e3fad53e9faf7c86fe3310e4a111dbce5c979f93d3b9e816af0f368f40782fa2195a1e5097838b17ca7f6195c2546a6055c7323025bdcd4323fdf5f5e0 glibc-malloc.patch"
diff --git a/main/gdk-pixbuf/glibc-malloc.patch b/main/gdk-pixbuf/glibc-malloc.patch
deleted file mode 100644
index 6986d17464..0000000000
--- a/main/gdk-pixbuf/glibc-malloc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1Work around for a test that should not build on non-glibc systems.
2
3Problem and proper fix is reported to:
4https://bugzilla.gnome.org/show_bug.cgi?id=756078
5
6diff --git a/tests/pixbuf-lowmem.c b/tests/pixbuf-lowmem.c
7index ae71788..9e9571f 100644
8--- a/tests/pixbuf-lowmem.c
9+++ b/tests/pixbuf-lowmem.c
10@@ -24,6 +24,7 @@
11 #include <time.h>
12 #include <string.h>
13
14+#ifdef __GLIBC__
15 #define PRETEND_MEM_SIZE (16 * 1024 * 1024)
16 #define REMAINING_MEM_SIZE 100000
17
18@@ -225,3 +226,10 @@ main (int argc, char **argv)
19
20 return 0;
21 }
22+#else
23+int
24+main (int argc, char **argv)
25+{
26+ return 0;
27+}
28+#endif