aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-12-09 08:52:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-09 08:53:03 +0000
commitdeb5bb9e4f042f905421bfd5b6530b6bd98e6dd5 (patch)
tree6338033c655ddcb9551e2875696a6ca0e9d00f18
parentbed92b0e0ee6ee536bd20d8543f865df5f9867c7 (diff)
downloadalpine_aports-deb5bb9e4f042f905421bfd5b6530b6bd98e6dd5.tar.bz2
alpine_aports-deb5bb9e4f042f905421bfd5b6530b6bd98e6dd5.tar.xz
alpine_aports-deb5bb9e4f042f905421bfd5b6530b6bd98e6dd5.zip
main/tdb: upgrade to 1.3.8
-rw-r--r--main/tdb/APKBUILD12
-rw-r--r--main/tdb/fix-libreplace.patch55
2 files changed, 4 insertions, 63 deletions
diff --git a/main/tdb/APKBUILD b/main/tdb/APKBUILD
index da579d7161..e2c9ab72d2 100644
--- a/main/tdb/APKBUILD
+++ b/main/tdb/APKBUILD
@@ -1,6 +1,6 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=tdb 2pkgname=tdb
3pkgver=1.3.7 3pkgver=1.3.8
4pkgrel=0 4pkgrel=0
5pkgdesc="The tdb library" 5pkgdesc="The tdb library"
6url="http://tdb.samba.org/" 6url="http://tdb.samba.org/"
@@ -12,7 +12,6 @@ makedepends="$depends_dev python-dev"
12install="" 12install=""
13subpackages="$pkgname-dev py-$pkgname:_py $pkgname-libs" 13subpackages="$pkgname-dev py-$pkgname:_py $pkgname-libs"
14source="http://samba.org/ftp/tdb/tdb-$pkgver.tar.gz 14source="http://samba.org/ftp/tdb/tdb-$pkgver.tar.gz
15 fix-libreplace.patch
16 " 15 "
17 16
18_builddir="$srcdir"/tdb-$pkgver 17_builddir="$srcdir"/tdb-$pkgver
@@ -59,9 +58,6 @@ libs() {
59 replaces="tdb" 58 replaces="tdb"
60} 59}
61 60
62md5sums="e3741a19c427255acd1e92c5e09d9df7 tdb-1.3.7.tar.gz 61md5sums="fa4c9e2f59fcf41441285bca5f5ab481 tdb-1.3.8.tar.gz"
63f4d7a813003048db39160daa0d232b92 fix-libreplace.patch" 62sha256sums="0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1 tdb-1.3.8.tar.gz"
64sha256sums="a64d95ca0cc06a28fed24c6e952aed7660cae04983108735d6bc30b925136412 tdb-1.3.7.tar.gz 63sha512sums="9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b tdb-1.3.8.tar.gz"
65a5575ca417fa5d13feb7c52429e1a9f618c0b8640462ba780777be5000499b87 fix-libreplace.patch"
66sha512sums="661404df8328a2e7bbb0d7865759e299edafee186f3798c11034c36b2076402a826306007986d6cdd5bf8774d2af7ebf4312a501ca9d9e62a26e504bc13652e4 tdb-1.3.7.tar.gz
679035bfe86b95b11e1a2cfc5a2950b72916faf721667bf813fa7fad482e815ce57cb1cd94504df0e30a0e699a0afe921e6e564d4d284dac6e446f947d63235793 fix-libreplace.patch"
diff --git a/main/tdb/fix-libreplace.patch b/main/tdb/fix-libreplace.patch
deleted file mode 100644
index e922be0f1a..0000000000
--- a/main/tdb/fix-libreplace.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1--- talloc-2.1.0.orig/lib/replace/replace.c
2+++ talloc-2.1.0/lib/replace/replace.c
3@@ -546,28 +524,6 @@
4 # error "You need a strtoull function"
5 #endif
6 }
7-#else
8-#ifdef HAVE_BSD_STRTOLL
9-#ifdef HAVE_STRTOUQ
10-unsigned long long int rep_strtoull(const char *str, char **endptr, int base)
11-{
12- unsigned long long int nb = strtouq(str, endptr, base);
13- /* In linux EINVAL is only returned if base is not ok */
14- if (errno == EINVAL) {
15- if (base == 0 || (base >1 && base <37)) {
16- /* Base was ok so it's because we were not
17- * able to make the convertion.
18- * Let's reset errno.
19- */
20- errno = 0;
21- }
22- }
23- return nb;
24-}
25-#else
26-#error "You need the strtouq function"
27-#endif /* HAVE_STRTOUQ */
28-#endif /* HAVE_BSD_STRTOLL */
29 #endif /* HAVE_STRTOULL */
30
31 #ifndef HAVE_SETENV
32--- talloc-2.1.0.orig/lib/replace/replace.h
33+++ talloc-2.1.0/lib/replace/replace.h
34@@ -355,21 +355,11 @@
35 #ifndef HAVE_STRTOLL
36 #define strtoll rep_strtoll
37 long long int rep_strtoll(const char *str, char **endptr, int base);
38-#else
39-#ifdef HAVE_BSD_STRTOLL
40-#define strtoll rep_strtoll
41-long long int rep_strtoll(const char *str, char **endptr, int base);
42 #endif
43-#endif
44
45 #ifndef HAVE_STRTOULL
46 #define strtoull rep_strtoull
47 unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
48-#else
49-#ifdef HAVE_BSD_STRTOLL /* yes, it's not HAVE_BSD_STRTOULL */
50-#define strtoull rep_strtoull
51-unsigned long long int rep_strtoull(const char *str, char **endptr, int base);
52-#endif
53 #endif
54
55 #ifndef HAVE_FTRUNCATE