aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:51:11 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 07:51:11 +0000
commitac81757085dbc0e1b2671acf175065a11099f2d6 (patch)
treec30a5cb76682dce8d3d42e2803bfebc2682dcb8a
parent738671da2e8eee6fef6ea642d866dafc58b3886f (diff)
downloadalpine_aports-ac81757085dbc0e1b2671acf175065a11099f2d6.tar.bz2
alpine_aports-ac81757085dbc0e1b2671acf175065a11099f2d6.tar.xz
alpine_aports-ac81757085dbc0e1b2671acf175065a11099f2d6.zip
testing/py-pyparted: new aport
-rw-r--r--testing/py-pyparted/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/py-pyparted/APKBUILD b/testing/py-pyparted/APKBUILD
new file mode 100644
index 0000000000..7b45cd65cd
--- /dev/null
+++ b/testing/py-pyparted/APKBUILD
@@ -0,0 +1,47 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=py-pyparted
4_pkgname=pyparted
5pkgver=3.10.7
6pkgrel=0
7pkgdesc="Python bindings for GNU parted (libparted)"
8url="https://github.com/rhinstaller/pyparted"
9arch="all"
10license="GPL2"
11makedepends="python2-dev python3-dev py-setuptools parted-dev"
12subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
13source="$pkgname-$pkgver.tar.gz::https://github.com/rhinstaller/${pkgname/py-/}/archive/v$pkgver.tar.gz"
14builddir="$srcdir/$_pkgname-$pkgver"
15
16build() {
17 cd "$builddir"
18 python2 setup.py build || return 1
19 python3 setup.py build || return 1
20}
21
22package() {
23 mkdir -p "$pkgdir"
24}
25
26_py2() {
27 _py python2
28}
29
30_py3() {
31 _py python3
32}
33
34_py() {
35 local python="$1"
36 pkgdesc="$pkgdesc (for $python)"
37 install_if="$pkgname=$pkgver-r$pkgrel $python"
38
39 cd "$builddir"
40 $python setup.py install --prefix=/usr --root="$subpkgdir"
41}
42
43
44
45md5sums="fa09a5a416500e6bd0f63c9c12caf2bb py-pyparted-3.10.7.tar.gz"
46sha256sums="5914e3a60437fe3e3758a9e86ee4a539dfa46cfe18e3df386a5cf1f75a963431 py-pyparted-3.10.7.tar.gz"
47sha512sums="c57fed2a8d04511b12891fd59b6dd6840439aada7e5ebeab14a56e6e4f201c249046ee87d9d25af1b3f02960994efb0a2973f25928a9df85d48bbd1bc196ab07 py-pyparted-3.10.7.tar.gz"