aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 09:55:35 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 09:55:40 +0000
commitc54c79a3c98c53a13446f74b9eb34097402dcd55 (patch)
tree57a2b643f5d727c4d408ca38d61856e5d5bb1657
parentc88a53d470c120314f760b233a34edf7cdc0a32a (diff)
downloadalpine_aports-c54c79a3c98c53a13446f74b9eb34097402dcd55.tar.bz2
alpine_aports-c54c79a3c98c53a13446f74b9eb34097402dcd55.tar.xz
alpine_aports-c54c79a3c98c53a13446f74b9eb34097402dcd55.zip
testing/spice-html5: new aport
-rw-r--r--testing/spice-html5/APKBUILD29
-rw-r--r--testing/spice-html5/support-busybox-install.patch10
2 files changed, 39 insertions, 0 deletions
diff --git a/testing/spice-html5/APKBUILD b/testing/spice-html5/APKBUILD
new file mode 100644
index 0000000000..31184c791a
--- /dev/null
+++ b/testing/spice-html5/APKBUILD
@@ -0,0 +1,29 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=spice-html5
4pkgver=0.1.6
5pkgrel=0
6pkgdesc="A html5 client for the spice protocol"
7url="https:://github.com/SPICE/spice-html5"
8arch="noarch"
9license="GPL"
10source="$pkgname-$pkgver.tar.gz::https://github.com/SPICE/$pkgname/archive/$pkgname-$pkgver.tar.gz
11support-busybox-install.patch"
12builddir="$srcdir/$pkgname-$pkgname-$pkgver"
13
14build() {
15 cd "$builddir"
16 return 0
17}
18
19package() {
20 cd "$builddir"
21 make DESTDIR="$pkgdir/" install
22}
23
24md5sums="619ba708dd0512c2c95807a11871e015 spice-html5-0.1.6.tar.gz
259ec802249b1730ee6dc4f92a2eb9a2e2 support-busybox-install.patch"
26sha256sums="f3a349d878e851df047a03944f326d118fd490e9543f87cf4ce0c0d5601afcc7 spice-html5-0.1.6.tar.gz
271fa80f719d94cf7e34248d54741d320de200ab315dc1ad77390bb2c3b9674626 support-busybox-install.patch"
28sha512sums="bfa2a5047eeb667c460156e599dd6806b265bd9a5ffc25ab8018d750868e58b2f7a21c830fa9c64abe1d2f717356bd188fc05400cc64fd1df2467138181e99b7 spice-html5-0.1.6.tar.gz
2950ba269441d0e52988e494eb74657e413325fd1fd00f92ab8e7695e7e33d8a39159c0b0aca458d821f150dd02a30e11bb23dde6cf9c335f999625cdd8901bc1b support-busybox-install.patch"
diff --git a/testing/spice-html5/support-busybox-install.patch b/testing/spice-html5/support-busybox-install.patch
new file mode 100644
index 0000000000..6eaad9ff1c
--- /dev/null
+++ b/testing/spice-html5/support-busybox-install.patch
@@ -0,0 +1,10 @@
1diff --git a/Makefile b/Makefile
2index add307f..fc5ec1e 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -65,4 +65,4 @@ local: tar rpm
6 git: gittar rpm
7
8 install:
9- find . \( -iname '*.html' -or -iname '*.js' -or -iname '*.css' \) -exec install --mode=644 -D {} $(datadir)/spice-html5/{} \;
10+ find . \( -iname '*.html' -or -iname '*.js' -or -iname '*.css' \) -exec install -m 644 -D {} $(datadir)/spice-html5/{} \;