aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 08:22:05 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-12-15 08:22:10 +0000
commitccc3af0ca34b74ca8d74c4f6d531a311b8204c70 (patch)
tree1c9c7afb1f28cc0b24415c228b9c853e716e2435
parent9ce790800cee74595f4e888c37cece949d87997b (diff)
downloadalpine_aports-ccc3af0ca34b74ca8d74c4f6d531a311b8204c70.tar.bz2
alpine_aports-ccc3af0ca34b74ca8d74c4f6d531a311b8204c70.tar.xz
alpine_aports-ccc3af0ca34b74ca8d74c4f6d531a311b8204c70.zip
testing/wok: new aport
-rw-r--r--testing/wok/APKBUILD48
-rw-r--r--testing/wok/alpine-specific-wokd.patch27
-rw-r--r--testing/wok/wokd.initd12
3 files changed, 87 insertions, 0 deletions
diff --git a/testing/wok/APKBUILD b/testing/wok/APKBUILD
new file mode 100644
index 0000000000..3a376f5db4
--- /dev/null
+++ b/testing/wok/APKBUILD
@@ -0,0 +1,48 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=wok
4pkgver=2.3.0
5pkgrel=0
6pkgdesc="Webserver of Kimchi - a cherrypy framework for multi-purpose plug-ins"
7url="http://kimchi-project.github.io/wok/"
8arch="noarch"
9license="APACHE LGPL2.1"
10depends="python2 nginx logrotate py-cherrypy py2-jsonschema
11py2-pyparted py2-pyldap py2-psutil py2-m2crypto py-cheetah
12py2-augeas py2-pam py2-functools32 py2-lxml py2-libvirt py-cherrypy
13ttf-opensans ttf-font-awesome"
14makedepends="automake autoconf libtool gettext-dev
15python2-dev pyflakes libxslt"
16install=""
17subpackages="$pkgname-lang $pkgname-doc"
18source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/$pkgname/archive/$pkgver.tar.gz
19wokd.initd
20alpine-specific-wokd.patch"
21builddir="$srcdir/$pkgname-$pkgver"
22
23build() {
24 cd "$builddir"
25 sh ./autogen.sh --system
26 ./configure \
27 --prefix=/usr \
28 --sysconfdir=/etc \
29 --localstatedir=/var
30 make || return 1
31}
32
33package() {
34 cd "$builddir"
35 make DESTDIR="$pkgdir" install
36 install -D -m755 "$srcdir"/wokd.initd \
37 "$pkgdir"/etc/init.d/wokd || return 1
38}
39
40md5sums="25d785bf2800157cebdb959f3a749cd8 wok-2.3.0.tar.gz
41eeff0e363218197c4e34101efd5ddbd2 wokd.initd
4263ed561751a90ca6ddb23a62a9a49e7a alpine-specific-wokd.patch"
43sha256sums="14ca498ab1f37ad18855616f132f8d89a2ed692f80252fcd9f99f7f4e8859257 wok-2.3.0.tar.gz
44d3328855f2d6fa2b0b7fbf589bc610d2ff0ed20cb702d88e8ab3fd084a73981c wokd.initd
45e896f92fc1e3c79d73068c4a5f552c945d013d87f094ae139db21cb05e0dfb84 alpine-specific-wokd.patch"
46sha512sums="c10c3a8a0e34b5f91b4054fd74cba9e4fbd072ce5e4b32798aff8d85deb275f4059d0e08c22eb56a43431ccb2f7452da77618d617d0f8c1b9e7f6fbdbe2a6d40 wok-2.3.0.tar.gz
47f1c6247ef1d26c997856d178adacddbbff6855a5f421a718fc58ecc541f5d29ab977699b426c1d51a5ab9c8abf49c5d6be2970df98c447d5467c0529df1cb141 wokd.initd
48c47deb3ef8160162af5dbfd8b6975f86a12c69bff641ff627d4869a5edcbea8dc47551da6ee98ad5787d03a3dc93434edc42913031a19bc903a17c70a692c699 alpine-specific-wokd.patch"
diff --git a/testing/wok/alpine-specific-wokd.patch b/testing/wok/alpine-specific-wokd.patch
new file mode 100644
index 0000000000..5f9599c3ec
--- /dev/null
+++ b/testing/wok/alpine-specific-wokd.patch
@@ -0,0 +1,27 @@
1diff --git a/src/nginx/wok.conf.in b/src/nginx/wok.conf.in
2index 512b00b..116fce9 100644
3--- a/src/nginx/wok.conf.in
4+++ b/src/nginx/wok.conf.in
5@@ -22,7 +22,8 @@
6 # This is a template file to be used to generate a nginx
7 # proxy config file at wokd script.
8
9-client_max_body_size ${max_body_size}k;
10+#Check nginx.conf which already have this directive
11+#client_max_body_size ${max_body_size}k;
12
13 # Set timeout, based on configuration values, to avoid the 504 Gateway Timeout
14 # when Wok is processing a request.
15diff --git a/src/wok/proxy.py b/src/wok/proxy.py
16index 4b06fc2..15c1f8c 100644
17--- a/src/wok/proxy.py
18+++ b/src/wok/proxy.py
19@@ -130,7 +130,7 @@ def start_proxy(options):
20 """Start nginx reverse proxy."""
21 _create_proxy_config(options)
22 # Restart system's nginx service to reload wok configuration
23- cmd = ['systemctl', 'restart', 'nginx.service']
24+ cmd = ['rc-service', 'nginx', 'restart']
25 output, error, retcode = run_command(cmd, silent=True)
26 if retcode != 0:
27 raise OperationFailed('WOKPROXY0001E', {'error': error})
diff --git a/testing/wok/wokd.initd b/testing/wok/wokd.initd
new file mode 100644
index 0000000000..17e0ecf767
--- /dev/null
+++ b/testing/wok/wokd.initd
@@ -0,0 +1,12 @@
1#!/sbin/openrc-run
2# (c) 2016 Alpine Linux
3
4name=wokd
5command=/usr/bin/$name
6command_background=YES
7
8depend() {
9 use logger dns
10 need net
11 after libvirtd firewall
12}