aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-05-23 15:22:15 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-05-23 15:22:15 +0200
commit2604d2f13b95a35836fe9d8a7e733635300c346c (patch)
treeda56146fda1300d9a06717f1e9359f92d1ddbd4d
parentce44a928921cd0c87be29f2fc6aa10d200456aab (diff)
downloadalpine_aports-2604d2f13b95a35836fe9d8a7e733635300c346c.tar.bz2
alpine_aports-2604d2f13b95a35836fe9d8a7e733635300c346c.tar.xz
alpine_aports-2604d2f13b95a35836fe9d8a7e733635300c346c.zip
main/lxc: fix lxc-bridge config
-rw-r--r--main/lxc/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 381d4c832c..6e3185bd20 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -5,7 +5,7 @@
5pkgname=lxc 5pkgname=lxc
6pkgver=2.0.7 6pkgver=2.0.7
7_pkgver=${pkgver/_rc/.rc} 7_pkgver=${pkgver/_rc/.rc}
8pkgrel=3 8pkgrel=4
9pkgdesc="Userspace interface for the Linux kernel containment features" 9pkgdesc="Userspace interface for the Linux kernel containment features"
10url="https://linuxcontainers.org/lxc/" 10url="https://linuxcontainers.org/lxc/"
11arch="all" 11arch="all"
@@ -127,7 +127,7 @@ bridge() {
127 "$subpkgdir"/etc/lxc 127 "$subpkgdir"/etc/lxc
128 128
129 ln -s dnsmasq "$subpkgdir"/etc/init.d/dnsmasq.lxcbr0 129 ln -s dnsmasq "$subpkgdir"/etc/init.d/dnsmasq.lxcbr0
130 cat ->>"$subpkgdir"/etc/conf.d/dnsmasq.lxcbr0 <<EOF 130 cat >>"$subpkgdir"/etc/conf.d/dnsmasq.lxcbr0 <<- EOF
131 BRIDGE_ADDR="10.0.3.1" 131 BRIDGE_ADDR="10.0.3.1"
132 BRIDGE_NETMASK="255.255.255.0" 132 BRIDGE_NETMASK="255.255.255.0"
133 BRIDGE_NETWORK="10.0.3.0/24" 133 BRIDGE_NETWORK="10.0.3.0/24"
@@ -136,12 +136,12 @@ bridge() {
136 BRIDGE_MAC="00:16:3e:00:00:00" 136 BRIDGE_MAC="00:16:3e:00:00:00"
137 DNSMASQ_CONFFILE="/etc/lxc/dnsmasq.conf" 137 DNSMASQ_CONFFILE="/etc/lxc/dnsmasq.conf"
138EOF 138EOF
139 cat ->>"$subpkgdir"/etc/lxc/dnsmasq.conf <<EOF 139 cat >>"$subpkgdir"/etc/lxc/dnsmasq.conf <<- EOF
140 #dhcp-host=somehost,10.0.3.3 140 #dhcp-host=somehost,10.0.3.3
141 #dhcp-host=otherhost,10.0.3.4 141 #dhcp-host=otherhost,10.0.3.4
142EOF 142EOF
143 cat ->>"$subpkgdir"/etc/conf.d/lxc <<EOF 143 cat >>"$subpkgdir"/etc/conf.d/lxc <<- EOF
144 rc_need="lxc-bridge" 144 rc_need="dnsmasq.lxcbr0"
145EOF 145EOF
146 146
147} 147}