aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-06-08 11:39:02 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-16 15:50:36 +0200
commit0ff9b6e986f0ab191b68ded418ca5a0f30c73908 (patch)
treeeaecd74e7ee85451021a9786fd3152d2eec37d64
parent9ce246ea4f2a2a7cf32abdbf508b0f870d28d1ac (diff)
downloadalpine_aports-0ff9b6e986f0ab191b68ded418ca5a0f30c73908.tar.bz2
alpine_aports-0ff9b6e986f0ab191b68ded418ca5a0f30c73908.tar.xz
alpine_aports-0ff9b6e986f0ab191b68ded418ca5a0f30c73908.zip
community/go: default buildmode=pie on s390x
(cherry picked from commit b5f0896153bb6ab8a9da807641feb62b83a7f422)
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/go/default-buildmode-pie.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index e4c2636b7b..f0e3ace4a8 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@ pkgname=go
4pkgver=1.8.1 4pkgver=1.8.1
5# This should be the latest commit on the corresponding release branch 5# This should be the latest commit on the corresponding release branch
6_toolsver="5682db0e919ed9cfc6f52ac32e170511a106eb3b" 6_toolsver="5682db0e919ed9cfc6f52ac32e170511a106eb3b"
7pkgrel=1 7pkgrel=2
8pkgdesc="Go programming language compiler" 8pkgdesc="Go programming language compiler"
9url="http://www.golang.org/" 9url="http://www.golang.org/"
10arch="all" 10arch="all"
@@ -169,5 +169,5 @@ _crosspkg() {
169 169
170sha512sums="f01fe7b35ac23101610f6fc169b88dafe2edc49b3b044d5d0aff771b05dcb2c8d2e7a5090ed6dbe67f861e78e792ace32e209ed464399ca02dcd186b13ec8037 go1.8.1.src.tar.gz 170sha512sums="f01fe7b35ac23101610f6fc169b88dafe2edc49b3b044d5d0aff771b05dcb2c8d2e7a5090ed6dbe67f861e78e792ace32e209ed464399ca02dcd186b13ec8037 go1.8.1.src.tar.gz
171343fca47f250278b22df1c1cd92cce91e01009043d05d8ccce095e4386fa0f5ca8ccaa58232635332c7288ceca9d2a240f774f8bb3b08129a681a582cba60248 go-tools-1.8.1.tar.gz 171343fca47f250278b22df1c1cd92cce91e01009043d05d8ccce095e4386fa0f5ca8ccaa58232635332c7288ceca9d2a240f774f8bb3b08129a681a582cba60248 go-tools-1.8.1.tar.gz
17213cd386c38875b951da4057586007f3c67503dc79ddf57befbf763af85ec2cd2a2e6b00614450c179c93f1f8747ee7456ee412adccd08a5f115b33812598a148 default-buildmode-pie.patch 1729857c71108652b8907117abf0b41ded5e332bcf864320235aadbf3a7b6afbfc0e5051f91fe143f0654b4c8d6fe9adbe7d22ca2ce50cd75c0ab7a050dfb437773 default-buildmode-pie.patch
1736b36f3780ab10e5c4902473a8ab5c0417220ece584b537517e9e60979bdc5a548ed14dd2546605392c89ec5ea6691769d337d34e2e19b92eba5bbca1898f4ada set-external-linker.patch" 1736b36f3780ab10e5c4902473a8ab5c0417220ece584b537517e9e60979bdc5a548ed14dd2546605392c89ec5ea6691769d337d34e2e19b92eba5bbca1898f4ada set-external-linker.patch"
diff --git a/community/go/default-buildmode-pie.patch b/community/go/default-buildmode-pie.patch
index 034692a098..1fa8241cd1 100644
--- a/community/go/default-buildmode-pie.patch
+++ b/community/go/default-buildmode-pie.patch
@@ -4,7 +4,7 @@
4 ldBuildmode = "c-shared" 4 ldBuildmode = "c-shared"
5 case "default": 5 case "default":
6 switch platform { 6 switch platform {
7+ case "linux/386", "linux/amd64", "linux/arm", "linux/arm64", "linux/ppc64le", 7+ case "linux/386", "linux/amd64", "linux/arm", "linux/arm64", "linux/ppc64le", "linux/s390x",
8+ "android/amd64", "android/arm", "android/arm64", "android/386": 8+ "android/amd64", "android/arm", "android/arm64", "android/386":
9- case "android/arm", "android/arm64", "android/amd64", "android/386": 9- case "android/arm", "android/arm64", "android/amd64", "android/386":
10 codegenArg = "-shared" 10 codegenArg = "-shared"