aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-06-08 14:33:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-16 15:50:28 +0200
commit9ce246ea4f2a2a7cf32abdbf508b0f870d28d1ac (patch)
tree0b4c66eaa64647977624c29fdb2d2d91261cdadd
parentab1c971a013f0c32cdb20a14f7fe690275eaf9d5 (diff)
downloadalpine_aports-9ce246ea4f2a2a7cf32abdbf508b0f870d28d1ac.tar.bz2
alpine_aports-9ce246ea4f2a2a7cf32abdbf508b0f870d28d1ac.tar.xz
alpine_aports-9ce246ea4f2a2a7cf32abdbf508b0f870d28d1ac.zip
community/go: fix external linker for ppc64le
The external linker for ppc64le was pointing to /lib64/ld-musl-ppc64le.so.1 but the valid path for alpine ppc64le is /lib/ld-musl-powerpc64le.so.1. This issue was found by Lynn Boger from IBM go compiler team. (cherry picked from commit 80d3e2de0e7ec8f262ab4e39553062a81758f703)
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/go/set-external-linker.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index f5c98c3735..e4c2636b7b 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,7 +4,7 @@ pkgname=go
4pkgver=1.8.1 4pkgver=1.8.1
5# This should be the latest commit on the corresponding release branch 5# This should be the latest commit on the corresponding release branch
6_toolsver="5682db0e919ed9cfc6f52ac32e170511a106eb3b" 6_toolsver="5682db0e919ed9cfc6f52ac32e170511a106eb3b"
7pkgrel=0 7pkgrel=1
8pkgdesc="Go programming language compiler" 8pkgdesc="Go programming language compiler"
9url="http://www.golang.org/" 9url="http://www.golang.org/"
10arch="all" 10arch="all"
@@ -170,4 +170,4 @@ _crosspkg() {
170sha512sums="f01fe7b35ac23101610f6fc169b88dafe2edc49b3b044d5d0aff771b05dcb2c8d2e7a5090ed6dbe67f861e78e792ace32e209ed464399ca02dcd186b13ec8037 go1.8.1.src.tar.gz 170sha512sums="f01fe7b35ac23101610f6fc169b88dafe2edc49b3b044d5d0aff771b05dcb2c8d2e7a5090ed6dbe67f861e78e792ace32e209ed464399ca02dcd186b13ec8037 go1.8.1.src.tar.gz
171343fca47f250278b22df1c1cd92cce91e01009043d05d8ccce095e4386fa0f5ca8ccaa58232635332c7288ceca9d2a240f774f8bb3b08129a681a582cba60248 go-tools-1.8.1.tar.gz 171343fca47f250278b22df1c1cd92cce91e01009043d05d8ccce095e4386fa0f5ca8ccaa58232635332c7288ceca9d2a240f774f8bb3b08129a681a582cba60248 go-tools-1.8.1.tar.gz
17213cd386c38875b951da4057586007f3c67503dc79ddf57befbf763af85ec2cd2a2e6b00614450c179c93f1f8747ee7456ee412adccd08a5f115b33812598a148 default-buildmode-pie.patch 17213cd386c38875b951da4057586007f3c67503dc79ddf57befbf763af85ec2cd2a2e6b00614450c179c93f1f8747ee7456ee412adccd08a5f115b33812598a148 default-buildmode-pie.patch
173ab06554c1c37fda2bf0112d7343f253111911e07cdd77805e9811aaabe298980a0fac60f6294e68b95df017ab40d73655874e3d1d230c54181d6ffc7639e3ed6 set-external-linker.patch" 1736b36f3780ab10e5c4902473a8ab5c0417220ece584b537517e9e60979bdc5a548ed14dd2546605392c89ec5ea6691769d337d34e2e19b92eba5bbca1898f4ada set-external-linker.patch"
diff --git a/community/go/set-external-linker.patch b/community/go/set-external-linker.patch
index 5632368fb0..5727036d48 100644
--- a/community/go/set-external-linker.patch
+++ b/community/go/set-external-linker.patch
@@ -72,7 +72,7 @@ index 6eff2f4..1f3c0be 100644
72 72
73 // TODO(austin): ABI v1 uses /usr/lib/ld.so.1 73 // TODO(austin): ABI v1 uses /usr/lib/ld.so.1
74- ld.Thearch.Linuxdynld = "/lib64/ld64.so.1" 74- ld.Thearch.Linuxdynld = "/lib64/ld64.so.1"
75+ ld.Thearch.Linuxdynld = "/lib64/ld-musl-ppc64le.so.1" 75+ ld.Thearch.Linuxdynld = "/lib/ld-musl-powerpc64le.so.1"
76 76
77 ld.Thearch.Freebsddynld = "XXX" 77 ld.Thearch.Freebsddynld = "XXX"
78 ld.Thearch.Openbsddynld = "XXX" 78 ld.Thearch.Openbsddynld = "XXX"