aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-29 11:59:34 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-11-29 22:12:43 +0100
commit89770720674ee3172342ff90836689a534f7cae9 (patch)
tree7845464cf57f934bfab56e01aee1e50b7fe72f57
parentbbf8eeea84969a531fe38d03574977d317ea1049 (diff)
downloadalpine_aports-89770720674ee3172342ff90836689a534f7cae9.tar.bz2
alpine_aports-89770720674ee3172342ff90836689a534f7cae9.tar.xz
alpine_aports-89770720674ee3172342ff90836689a534f7cae9.zip
main/perl-future: upgrade to 0.37 and modernize
-rw-r--r--main/perl-future/APKBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/main/perl-future/APKBUILD b/main/perl-future/APKBUILD
index 3cf621ef36..5f26facfdc 100644
--- a/main/perl-future/APKBUILD
+++ b/main/perl-future/APKBUILD
@@ -2,37 +2,43 @@
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=perl-future 3pkgname=perl-future
4_pkgreal=Future 4_pkgreal=Future
5pkgver=0.35 5pkgver=0.37
6pkgrel=0 6pkgrel=0
7pkgdesc="represent an operation awaiting completion" 7pkgdesc="Represent an operation awaiting completion"
8url="http://search.cpan.org/dist/Future/" 8url="http://search.cpan.org/dist/Future/"
9arch="noarch" 9arch="noarch"
10license="GPL PerlArtistic" 10license="GPL PerlArtistic"
11cpandepends="" 11cpandepends=""
12cpanmakedepends="perl-test-fatal perl-test-refcount perl-test-identity " 12cpanmakedepends="perl-test-fatal perl-test-refcount perl-test-identity"
13depends="$cpandepends" 13depends="$cpandepends"
14makedepends="perl-dev $cpanmakedepends perl-module-build" 14makedepends="perl-dev $cpanmakedepends perl-module-build"
15subpackages="$pkgname-doc" 15subpackages="$pkgname-doc"
16source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz" 16source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
17 17builddir="$srcdir/$_pkgreal-$pkgver"
18_builddir="$srcdir/$_pkgreal-$pkgver"
19 18
20prepare() { 19prepare() {
21 cd "$_builddir" 20 default_prepare
22 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'` 21
23 perl Build.PL installdirs=vendor || return 1 22 cd "$builddir"
23 export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
24 perl Build.PL installdirs=vendor
24} 25}
25 26
26build() { 27build() {
27 cd "$_builddir" 28 cd "$builddir"
28 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'` 29 export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
29 ./Build && ./Build test 30 ./Build
31}
32
33check() {
34 cd "$builddir"
35 ./Build test
30} 36}
31 37
32package() { 38package() {
33 cd "$_builddir" 39 cd "$builddir"
34 ./Build install destdir="$pkgdir" || return 1 40 ./Build install destdir="$pkgdir"
35 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete 41 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
36} 42}
37 43
38sha512sums="f4d6f8a8b186e1b0f6ca22ccdf0ad06b4ea47f915a03e4d29546ed45e4eced9b81a5bf02b122f334cf4ab11ee5e94843760a542923911ec2c388654ee3dd4526 Future-0.35.tar.gz" 44sha512sums="05d797b26b653ab6e7d2451001e556ba5a9a80d44dc8754be850e1990ff1e4cf6c3b5e601035e3e50ab4c610fe55a39c1c27f15770f88b739d09a5a5086c62f5 Future-0.37.tar.gz"