aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 00:33:02 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 00:33:02 +0000
commit37539843c397679ac01c8f590d634db31f18be49 (patch)
tree8f8f2609981f394f39bf2650bc5b040253680bd7
parent12a77edce72a5e943496a92ac1ec04a92740035a (diff)
downloadalpine_aports-37539843c397679ac01c8f590d634db31f18be49.tar.bz2
alpine_aports-37539843c397679ac01c8f590d634db31f18be49.tar.xz
alpine_aports-37539843c397679ac01c8f590d634db31f18be49.zip
community/perl-data-uniqid: modernize and add check
-rw-r--r--community/perl-data-uniqid/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/perl-data-uniqid/APKBUILD b/community/perl-data-uniqid/APKBUILD
index 06240f68d2..34bd827f18 100644
--- a/community/perl-data-uniqid/APKBUILD
+++ b/community/perl-data-uniqid/APKBUILD
@@ -2,8 +2,8 @@
2# Maintainer: Stuart Cardall <developer@it-offshore.co.uk> 2# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
3pkgname=perl-data-uniqid 3pkgname=perl-data-uniqid
4pkgver=0.12 4pkgver=0.12
5_realname=Data-Uniqid-$pkgver 5_realname=Data-Uniqid
6pkgrel=0 6pkgrel=1
7pkgdesc="Perl extension for simple generation of unique id's" 7pkgdesc="Perl extension for simple generation of unique id's"
8url="http://search.cpan.org/dist/Data-Uniqid/" 8url="http://search.cpan.org/dist/Data-Uniqid/"
9arch="noarch" 9arch="noarch"
@@ -13,22 +13,25 @@ cpanmakedepends=""
13depends="$cpandepends" 13depends="$cpandepends"
14makedepends="perl-dev $cpanmakedepends" 14makedepends="perl-dev $cpanmakedepends"
15subpackages="$pkgname-doc" 15subpackages="$pkgname-doc"
16source="http://search.cpan.org/CPAN/authors/id/M/MW/MWX/$_realname.tar.gz" 16source="http://search.cpan.org/CPAN/authors/id/M/MW/MWX/$_realname-$pkgver.tar.gz"
17 17
18_builddir="$srcdir"/$_realname 18builddir="$srcdir/$_realname-$pkgver"
19 19
20build() { 20build() {
21 cd "$_builddir" 21 cd "$builddir"
22 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1 22 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
23 make || return 1 23 make
24}
25
26check() {
27 cd "$builddir"
28 make test
24} 29}
25 30
26package() { 31package() {
27 cd "$_builddir" 32 cd "$builddir"
28 make DESTDIR="$pkgdir" install || return 1 33 make DESTDIR="$pkgdir" install
29 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete 34 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
30} 35}
31 36
32md5sums="6bab3b5da09fedfdf60ce2629a7367db Data-Uniqid-0.12.tar.gz"
33sha256sums="b6919ba49b9fe98bfdf3e8accae7b9b7f78dc9e71ebbd0b7fef7a45d99324ccb Data-Uniqid-0.12.tar.gz"
34sha512sums="fd12aae4a810fda88dd0f8296e73760d8d62357cb5ebc675a4b2804d9eee93ebfa01942c7057ad9092e80331504f2a38a3c8a576ccb630de10f5e563752ed6e3 Data-Uniqid-0.12.tar.gz" 37sha512sums="fd12aae4a810fda88dd0f8296e73760d8d62357cb5ebc675a4b2804d9eee93ebfa01942c7057ad9092e80331504f2a38a3c8a576ccb630de10f5e563752ed6e3 Data-Uniqid-0.12.tar.gz"