aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-22 21:02:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-22 21:02:37 +0000
commit5957958c77d4b3a1a9037fb2f8aff9b6b1458332 (patch)
treeb4e9713fb62cce13d56ded5e7487c2d5dbe6c5be
parent94fe647934e9b6bdcb0d3e42162c9b8e4f2f7614 (diff)
downloadalpine_aports-5957958c77d4b3a1a9037fb2f8aff9b6b1458332.tar.bz2
alpine_aports-5957958c77d4b3a1a9037fb2f8aff9b6b1458332.tar.xz
alpine_aports-5957958c77d4b3a1a9037fb2f8aff9b6b1458332.zip
main/perl-datetime-format-natural: build fix, modernize
-rw-r--r--main/perl-datetime-format-natural/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/main/perl-datetime-format-natural/APKBUILD b/main/perl-datetime-format-natural/APKBUILD
index b1de6f3f1e..ad30114532 100644
--- a/main/perl-datetime-format-natural/APKBUILD
+++ b/main/perl-datetime-format-natural/APKBUILD
@@ -4,7 +4,7 @@
4pkgname=perl-datetime-format-natural 4pkgname=perl-datetime-format-natural
5_pkgreal=DateTime-Format-Natural 5_pkgreal=DateTime-Format-Natural
6pkgver=1.05 6pkgver=1.05
7pkgrel=0 7pkgrel=1
8pkgdesc="Create machine readable date/time with natural parsing logic" 8pkgdesc="Create machine readable date/time with natural parsing logic"
9url="http://search.cpan.org/dist/DateTime-Format-Natural/" 9url="http://search.cpan.org/dist/DateTime-Format-Natural/"
10arch="noarch" 10arch="noarch"
@@ -18,23 +18,24 @@ makedepends="perl-dev $cpanmakedepends"
18subpackages="$pkgname-doc" 18subpackages="$pkgname-doc"
19source="http://search.cpan.org/CPAN/authors/id/S/SC/SCHUBIGER/$_pkgreal-$pkgver.tar.gz" 19source="http://search.cpan.org/CPAN/authors/id/S/SC/SCHUBIGER/$_pkgreal-$pkgver.tar.gz"
20 20
21_builddir="$srcdir/$_pkgreal-$pkgver" 21builddir="$srcdir/$_pkgreal-$pkgver"
22 22
23prepare() { 23build() {
24 cd "$_builddir" 24 cd "$builddir"
25 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'` 25 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
26 perl Build.PL installdirs=vendor || return 1 26 PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
27 make
27} 28}
28 29
29build() { 30check() {
30 cd "$_builddir" 31 cd "$builddir"
31 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'` 32 export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
32 ./Build && ./Build test 33 make test
33} 34}
34 35
35package() { 36package() {
36 cd "$_builddir" 37 cd "$builddir"
37 ./Build install destdir="$pkgdir" || return 1 38 make DESTDIR="$pkgdir" install
38 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete 39 find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
39} 40}
40 41