aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpawciobiel <pawciobiel@gmail.com>2016-08-15 14:05:45 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-23 10:22:15 +0000
commit91d57c3ab0335169b5805e0bfb8f9af826500837 (patch)
treef867472de4ac840d8439169a3c29f50840ed41e7
parent4dc975ed9793f58c6add55638af4999edf8575a8 (diff)
downloadalpine_aports-91d57c3ab0335169b5805e0bfb8f9af826500837.tar.bz2
alpine_aports-91d57c3ab0335169b5805e0bfb8f9af826500837.tar.xz
alpine_aports-91d57c3ab0335169b5805e0bfb8f9af826500837.zip
community/php5: Change php5-module.conf to use SetHandler
Avoids serving non php files using php handler. imported from https://github.com/alpinelinux/aports/pull/206
-rw-r--r--community/php5/APKBUILD4
-rw-r--r--community/php5/php5-module.conf12
2 files changed, 12 insertions, 4 deletions
diff --git a/community/php5/APKBUILD b/community/php5/APKBUILD
index 4cab1c65bc..d0b07c57c6 100644
--- a/community/php5/APKBUILD
+++ b/community/php5/APKBUILD
@@ -4,7 +4,7 @@
4# Maintainer: Matt Smith <mcs@darkregion.net> 4# Maintainer: Matt Smith <mcs@darkregion.net>
5pkgname=php5 5pkgname=php5
6pkgver=5.6.32 6pkgver=5.6.32
7pkgrel=1 7pkgrel=2
8pkgdesc="The PHP language runtime engine" 8pkgdesc="The PHP language runtime engine"
9url="http://www.php.net/" 9url="http://www.php.net/"
10arch="all" 10arch="all"
@@ -507,6 +507,6 @@ opcache() { _mv_ext opcache; }
507 507
508sha512sums="d3f53a9c14e05726ec80785ee2db482d73cfd9bfca751041150da63e5e9273a2ea9a0027d3d9c80434ae8c1f93e7a4556b050969c271e696a841ec785efbeedc php-5.6.32.tar.bz2 508sha512sums="d3f53a9c14e05726ec80785ee2db482d73cfd9bfca751041150da63e5e9273a2ea9a0027d3d9c80434ae8c1f93e7a4556b050969c271e696a841ec785efbeedc php-5.6.32.tar.bz2
509f7d922cab98617ef910b4c14974e768c85e60424cd1b216f688b34b2d823b642a5b896463008c134ce47c150f9407f5c438823b7e7bc89b3fb440cd3e97b9d7e php-fpm.initd 509f7d922cab98617ef910b4c14974e768c85e60424cd1b216f688b34b2d823b642a5b896463008c134ce47c150f9407f5c438823b7e7bc89b3fb440cd3e97b9d7e php-fpm.initd
510895e94c791bd82060ad820fef049d366a09c932097faa6b7b9a2c2e9e00a18cb7c0f9b128679c7659b404379266fd0f95dba5c0333f626194cf60f7bf6044102 php5-module.conf 510d1dd6a5764e18414476aaaa109efcc568696ac17a61a1afdf7d0621d3e38c5be717a81ee4d11d28963f11e76879af7d3806970e651061f8c4abffb03c4bd5af4 php5-module.conf
511f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 php-install-pear-xml.patch 511f1177cbf6b1f44402f421c3d317aab1a2a40d0b1209c11519c1158df337c8945f3a313d689c939768584f3e4edbe52e8bd6103fb6777462326a9d94e8ab1f505 php-install-pear-xml.patch
5126ecd0be2da1dc5b1d7512e46a2a5cd107a8b2a8c364efc9c624a7d6b2ab081685a329c94c22c970dc14c5c1115f702c512e97ae858da1bc69c6423323dbeeba2 gd-iconv.patch" 5126ecd0be2da1dc5b1d7512e46a2a5cd107a8b2a8c364efc9c624a7d6b2ab081685a329c94c22c970dc14c5c1115f702c512e97ae858da1bc69c6423323dbeeba2 gd-iconv.patch"
diff --git a/community/php5/php5-module.conf b/community/php5/php5-module.conf
index 9dae61fa81..32a88145a5 100644
--- a/community/php5/php5-module.conf
+++ b/community/php5/php5-module.conf
@@ -1,5 +1,13 @@
1LoadModule php5_module modules/libphp5.so 1LoadModule php5_module modules/libphp5.so
2 2
3DirectoryIndex index.php index.html 3DirectoryIndex index.php index.html
4AddHandler application/x-httpd-php .php 4
5AddHandler application/x-httpd-php-source .phps 5<FilesMatch \.php$>
6 SetHandler application/x-httpd-php
7</FilesMatch>
8
9# Uncomment the following to allow .phps files to be handled by the php source filter,
10# and displayed as syntax-highlighted source code
11#<FilesMatch "\.phps$">
12# SetHandler application/x-httpd-php-source
13#</FilesMatch>