aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 00:55:30 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-23 00:55:30 +0000
commit930ee52dac192d9d3a404820855f8c9cd7a98c56 (patch)
tree53485b3ad3e0f747a489fc4d28a43b400e50e7d8
parent37539843c397679ac01c8f590d634db31f18be49 (diff)
downloadalpine_aports-930ee52dac192d9d3a404820855f8c9cd7a98c56.tar.bz2
alpine_aports-930ee52dac192d9d3a404820855f8c9cd7a98c56.tar.xz
alpine_aports-930ee52dac192d9d3a404820855f8c9cd7a98c56.zip
community/py-argh: modernize and add check
-rw-r--r--community/py-argh/APKBUILD28
1 files changed, 11 insertions, 17 deletions
diff --git a/community/py-argh/APKBUILD b/community/py-argh/APKBUILD
index b36232081a..13aaa1580e 100644
--- a/community/py-argh/APKBUILD
+++ b/community/py-argh/APKBUILD
@@ -3,7 +3,7 @@
3pkgname=py-argh 3pkgname=py-argh
4_pkgname=argh 4_pkgname=argh
5pkgver=0.26.2 5pkgver=0.26.2
6pkgrel=0 6pkgrel=1
7pkgdesc="A Python argparse wrapper" 7pkgdesc="A Python argparse wrapper"
8url="https://github.com/neithere/argh/" 8url="https://github.com/neithere/argh/"
9arch="noarch" 9arch="noarch"
@@ -15,27 +15,21 @@ install=""
15subpackages="" 15subpackages=""
16source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz" 16source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
17 17
18_builddir="$srcdir"/$_pkgname-$pkgver 18builddir="$srcdir/$_pkgname-$pkgver"
19prepare() {
20 local i
21 cd "$_builddir"
22 for i in $source; do
23 case $i in
24 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
25 esac
26 done
27}
28 19
29build() { 20build() {
30 cd "$_builddir" 21 cd "$builddir"
31 python2 setup.py build || return 1 22 python2 setup.py build
23}
24
25check() {
26 cd "$builddir"
27 python2 setup.py test
32} 28}
33 29
34package() { 30package() {
35 cd "$_builddir" 31 cd "$builddir"
36 python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1 32 python2 setup.py install --prefix=/usr --root="$pkgdir"
37} 33}
38 34
39md5sums="edda25f3f0164a963dd89c0e3c619973 argh-0.26.2.tar.gz"
40sha256sums="e9535b8c84dc9571a48999094fda7f33e63c3f1b74f3e5f3ac0105a58405bb65 argh-0.26.2.tar.gz"
41sha512sums="90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707 argh-0.26.2.tar.gz" 35sha512sums="90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707 argh-0.26.2.tar.gz"