aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-22 16:46:16 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-22 16:46:20 +0000
commit9bcb48b6dd46da20356da721445c74556b07d90a (patch)
tree450646b74dfae0f5ffbf16f242a54362184cfbf8
parentee79ddd27835fbdb7a8c02ffa6bcd66fbab8c8da (diff)
downloadalpine_aports-9bcb48b6dd46da20356da721445c74556b07d90a.tar.bz2
alpine_aports-9bcb48b6dd46da20356da721445c74556b07d90a.tar.xz
alpine_aports-9bcb48b6dd46da20356da721445c74556b07d90a.zip
community/geany-plugins: upgrade to 1.32
-rw-r--r--community/geany-plugins/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/geany-plugins/APKBUILD b/community/geany-plugins/APKBUILD
index a831ec54df..9e009f841b 100644
--- a/community/geany-plugins/APKBUILD
+++ b/community/geany-plugins/APKBUILD
@@ -1,7 +1,7 @@
1# Contributor: Natanael Copa <ncopa@alpinelinux.org> 1# Contributor: Natanael Copa <ncopa@alpinelinux.org>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=geany-plugins 3pkgname=geany-plugins
4pkgver=1.30 4pkgver=1.32
5pkgrel=0 5pkgrel=0
6pkgdesc="Plugins for Geany" 6pkgdesc="Plugins for Geany"
7url="https://plugins.geany.org/" 7url="https://plugins.geany.org/"
@@ -9,9 +9,9 @@ arch="all"
9license="GPLv3+" 9license="GPLv3+"
10depends="" 10depends=""
11makedepends="lua-dev geany-dev enchant-dev intltool gtkspell-dev libxml2-dev 11makedepends="lua-dev geany-dev enchant-dev intltool gtkspell-dev libxml2-dev
12 bash vte-dev vala libsoup-dev gpgme-dev python2-dev" 12 bash vte-dev vala libsoup-dev gpgme-dev python2-dev py-gtk-dev"
13install="" 13install=""
14subpackages="$pkgname-doc 14subpackages="$pkgname-dev $pkgname-doc
15 $pkgname-addons 15 $pkgname-addons
16 $pkgname-autoclose 16 $pkgname-autoclose
17 $pkgname-automark 17 $pkgname-automark
@@ -48,6 +48,9 @@ subpackages="$pkgname-doc
48 $pkgname-treebrowser 48 $pkgname-treebrowser
49 $pkgname-updatechecker 49 $pkgname-updatechecker
50 $pkgname-xmlsnippets 50 $pkgname-xmlsnippets
51 $pkgname-workbench
52 $pkgname-keyrecord
53 $pkgname-utils
51 54
52 $pkgname-lang 55 $pkgname-lang
53 " 56 "
@@ -83,6 +86,13 @@ package() {
83 make DESTDIR="$pkgdir" install || return 1 86 make DESTDIR="$pkgdir" install || return 1
84} 87}
85 88
89utils() {
90 pkgdesc="Reusable shared library used by geany-plugins"
91 mkdir -p "$subpkgdir"/usr/lib
92 mv "$pkgdir"/usr/lib/libgeanypluginutils.so* \
93 "$subpkgdir"/usr/lib/
94}
95
86_plugin() { 96_plugin() {
87 pkgdesc="$2" 97 pkgdesc="$2"
88 local _d 98 local _d
@@ -129,10 +139,7 @@ overview() { _plugin overview "Overview over the code in a sidebar"; }
129pairtaghighlighter() { _plugin pairtaghighlighter "Finds and highlights matching HTML tag"; } 139pairtaghighlighter() { _plugin pairtaghighlighter "Finds and highlights matching HTML tag"; }
130pohelper() { _plugin pohelper "A plugin for Geany that improves the support for GetText translation files"; } 140pohelper() { _plugin pohelper "A plugin for Geany that improves the support for GetText translation files"; }
131pretty_printer() { _plugin pretty-printer "XML pretty printing plugin for Geany"; } 141pretty_printer() { _plugin pretty-printer "XML pretty printing plugin for Geany"; }
132projectorganizer() { _plugin projectorganizer "Extension of Geany's project management"; 142projectorganizer() { _plugin projectorganizer "Extension of Geany's project management"; }
133 mkdir -p "$subpkgdir"/usr/share
134 mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
135}
136scope() { _plugin scope "Graphical GDB front-end"; } 143scope() { _plugin scope "Graphical GDB front-end"; }
137sendmail() { _plugin sendmail "Send E-Mails from within Geany"; } 144sendmail() { _plugin sendmail "Send E-Mails from within Geany"; }
138shiftcolumn() { _plugin shiftcolumn "Move Blocks of Text horizontally"; } 145shiftcolumn() { _plugin shiftcolumn "Move Blocks of Text horizontally"; }
@@ -141,5 +148,7 @@ tableconvert() { _plugin tableconvert "Helps on converting a tabulator separated
141treebrowser() { _plugin treebrowser "Alternate file browser plugin"; } 148treebrowser() { _plugin treebrowser "Alternate file browser plugin"; }
142updatechecker() { _plugin updatechecker "A plugin to check whether there is a more recent version of Geany available"; } 149updatechecker() { _plugin updatechecker "A plugin to check whether there is a more recent version of Geany available"; }
143xmlsnippets() { _plugin xmlsnippets "Extends XML/HTML tag autocompletion provided by Geany"; } 150xmlsnippets() { _plugin xmlsnippets "Extends XML/HTML tag autocompletion provided by Geany"; }
151workbench() { _plugin workbench "Support for multiple projects"; }
152keyrecord() { _plugin keyrecord "Record a sequence of keystrokes and replay it"; }
144 153
145sha512sums="02f8096c3cd13a32baad93517744306315ac4a9d566689fff44a9061b03c2a8aeba260d805c557ac6167919e8b9b75bf7dabe9d0b93a3a5089a8598c952735d8 geany-plugins-1.30.tar.bz2" 154sha512sums="ec45786cbee48673f78a11e179753e5fc5b6c520221434c9410af3f5a3a320b4dd02d90d850758ad1b0555e245c96d3fc2426c859cdc95d1aa5258e0d1ce7162 geany-plugins-1.32.tar.bz2"