aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-06-06 02:38:22 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-07 07:43:13 +0000
commit184585c046cdd56512f1a76e426dd799b368f8cf (patch)
tree1772dc71e3667f4fd4484d89f3ebb7fe60cc5a25
parent938d6f0c37a674f9e60163bc4558ef9fbd7efb7d (diff)
downloadalpine_aports-184585c046cdd56512f1a76e426dd799b368f8cf.tar.bz2
alpine_aports-184585c046cdd56512f1a76e426dd799b368f8cf.tar.xz
alpine_aports-184585c046cdd56512f1a76e426dd799b368f8cf.zip
community/tcsh: fix tests, promote to community
fixes #8660
-rw-r--r--community/tcsh/001-sysmalloc.patch (renamed from testing/tcsh/001-sysmalloc.patch)0
-rw-r--r--community/tcsh/002-test_123-posix_fix.patch34
-rw-r--r--community/tcsh/APKBUILD (renamed from testing/tcsh/APKBUILD)25
-rw-r--r--community/tcsh/tcsh.post-install (renamed from testing/tcsh/tcsh.post-install)0
l---------community/tcsh/tcsh.post-upgrade (renamed from testing/tcsh/tcsh.post-upgrade)0
-rw-r--r--community/tcsh/tcsh.pre-deinstall (renamed from testing/tcsh/tcsh.pre-deinstall)0
6 files changed, 51 insertions, 8 deletions
diff --git a/testing/tcsh/001-sysmalloc.patch b/community/tcsh/001-sysmalloc.patch
index b22c018983..b22c018983 100644
--- a/testing/tcsh/001-sysmalloc.patch
+++ b/community/tcsh/001-sysmalloc.patch
diff --git a/community/tcsh/002-test_123-posix_fix.patch b/community/tcsh/002-test_123-posix_fix.patch
new file mode 100644
index 0000000000..6ed59de387
--- /dev/null
+++ b/community/tcsh/002-test_123-posix_fix.patch
@@ -0,0 +1,34 @@
1Author: Dan Theisen <djt@hxx.in>
2Date: Wed Jun 06 03:30:25 2018 -0800
3
4The following lines have a subtle change around [:blank:], changing it
5to [[:blank:]] instead. This is required because POSIX treats characters
6inside of brackets as a group of characters to match against. In this case,
7[[:space:]] means [] group of characters, and [:space:] is the group, as per:
8IEEE Std 1003.1-2017 (Revision of IEEE Std 1003.1-2008), Chapter 9
9http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap09.html
10
11--- tcsh-6.20.00/tests/lexical.at.old 2018-06-06 02:20:16.787145186 -0700
12+++ tcsh-6.20.00/tests/lexical.at 2018-06-06 02:21:09.537890842 -0700
13@@ -567,10 +567,10 @@
14 ]])
15 AT_DATA([uniformity_test.csh],
16 [[
17-set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
18+set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
19 echo -n "$SERVICE_NAME_LOG" > ./output1
20
21-cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
22+cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
23
24 diff -uprN ./output1 ./output2 >& /dev/null
25
26@@ -587,7 +587,7 @@
27 echo "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP\)(HOST=db\)(PORT=1521\)\)(CONNECT_DATA=(SERVER=DEDICATED\)(SERVICE_NAME=bns03\)\)\)" > ./expected_result
28
29 set string = "jdbc_url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=db)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=bns03)))"
30-set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
31+set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
32
33 echo "$SERVICE_NAME_LOG" > ./actual_result
34
diff --git a/testing/tcsh/APKBUILD b/community/tcsh/APKBUILD
index 3c713ab412..2e6e2ebc67 100644
--- a/testing/tcsh/APKBUILD
+++ b/community/tcsh/APKBUILD
@@ -1,19 +1,22 @@
1# Contributor: 1# Contributor: Dan Theisen <djt@hxx.in>
2# Maintainer: 2# Maintainer: Dan Theisen <djt@hxx.in>
3pkgname=tcsh 3pkgname=tcsh
4pkgver=6.20.00 4pkgver=6.20.00
5pkgrel=2 5pkgrel=2
6pkgdesc="extended C-shell" 6pkgdesc="extended C-shell"
7url="http://www.tcsh.org" 7url="http://www.tcsh.org"
8arch="all" 8arch="all"
9license="BSD" 9license="BSD-3-Clause"
10depends="" 10depends=""
11checkdepends="diffutils autoconf"
11makedepends="ncurses-dev" 12makedepends="ncurses-dev"
12install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall" 13install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
13subpackages="$pkgname-doc" 14subpackages="$pkgname-doc"
14source="ftp://ftp.astron.com/pub/tcsh/${pkgname}-${pkgver}.tar.gz 15options="!checkroot"
15 001-sysmalloc.patch" 16source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/t/tcsh/${pkgname}_${pkgver}.orig.tar.gz
16builddir="$srcdir/tcsh-$pkgver" 17 001-sysmalloc.patch
18 002-test_123-posix_fix.patch"
19builddir="$srcdir/$pkgname-$pkgver"
17 20
18build() { 21build() {
19 cd "$builddir" 22 cd "$builddir"
@@ -24,10 +27,15 @@ build() {
24 --bindir=/bin \ 27 --bindir=/bin \
25 --mandir=/usr/share/man \ 28 --mandir=/usr/share/man \
26 --infodir=/usr/share/info \ 29 --infodir=/usr/share/info \
27 --disable-nls 30 --disable-rpath
28 make 31 make
29} 32}
30 33
34check() {
35 cd "$builddir"
36 make check
37}
38
31package() { 39package() {
32 cd "$builddir" 40 cd "$builddir"
33 make DESTDIR="$pkgdir" install 41 make DESTDIR="$pkgdir" install
@@ -35,4 +43,5 @@ package() {
35} 43}
36 44
37sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz 45sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz
3840149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch" 4640149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch
47b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch"
diff --git a/testing/tcsh/tcsh.post-install b/community/tcsh/tcsh.post-install
index 7342c5e721..7342c5e721 100644
--- a/testing/tcsh/tcsh.post-install
+++ b/community/tcsh/tcsh.post-install
diff --git a/testing/tcsh/tcsh.post-upgrade b/community/tcsh/tcsh.post-upgrade
index 180542a18b..180542a18b 120000
--- a/testing/tcsh/tcsh.post-upgrade
+++ b/community/tcsh/tcsh.post-upgrade
diff --git a/testing/tcsh/tcsh.pre-deinstall b/community/tcsh/tcsh.pre-deinstall
index 9e2e34c1c5..9e2e34c1c5 100644
--- a/testing/tcsh/tcsh.pre-deinstall
+++ b/community/tcsh/tcsh.pre-deinstall