aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-06-19 15:05:23 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-06-19 15:05:40 +0000
commit393a946d9ce6ff582ac812287fa061a8799ba057 (patch)
treec8bda45ac0578220326bb2431ef52aed17ebf513
parentc9774dcfddb414b36e11cb93f3c543429ad5a38f (diff)
downloadalpine_aports-393a946d9ce6ff582ac812287fa061a8799ba057.tar.bz2
alpine_aports-393a946d9ce6ff582ac812287fa061a8799ba057.tar.xz
alpine_aports-393a946d9ce6ff582ac812287fa061a8799ba057.zip
main/lsyncd: restore lpostcmd patch, add openrc subpkg
-rw-r--r--main/lsyncd/APKBUILD9
-rw-r--r--main/lsyncd/lpostcmd.patch26
2 files changed, 32 insertions, 3 deletions
diff --git a/main/lsyncd/APKBUILD b/main/lsyncd/APKBUILD
index 064ddd83d4..616fa4c9d4 100644
--- a/main/lsyncd/APKBUILD
+++ b/main/lsyncd/APKBUILD
@@ -2,7 +2,7 @@
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=lsyncd 3pkgname=lsyncd
4pkgver=2.2.3 4pkgver=2.2.3
5pkgrel=0 5pkgrel=1
6_luaver=5.3 6_luaver=5.3
7pkgdesc="Live Syncing (Mirror) Daemon" 7pkgdesc="Live Syncing (Mirror) Daemon"
8url="https://github.com/axkibe/lsyncd" 8url="https://github.com/axkibe/lsyncd"
@@ -11,11 +11,13 @@ license="GPL-2.0-or-later"
11depends="rsync" 11depends="rsync"
12makedepends="$depends_dev cmake lua$_luaver lua$_luaver-dev" 12makedepends="$depends_dev cmake lua$_luaver lua$_luaver-dev"
13options="!check" # needs passwordless ssh access to localhost 13options="!check" # needs passwordless ssh access to localhost
14subpackages="$pkgname-doc" 14subpackages="$pkgname-doc $pkgname-openrc"
15source="$pkgname-$pkgver.tar.gz::https://github.com/axkibe/lsyncd/archive/release-$pkgver.tar.gz 15source="$pkgname-$pkgver.tar.gz::https://github.com/axkibe/lsyncd/archive/release-$pkgver.tar.gz
16 fix-realpath.patch 16 fix-realpath.patch
17 fix-mandir.patch 17 fix-mandir.patch
18 $pkgname.initd" 18 lpostcmd.patch
19 $pkgname.initd
20 "
19builddir="$srcdir"/lsyncd-release-$pkgver 21builddir="$srcdir"/lsyncd-release-$pkgver
20 22
21build() { 23build() {
@@ -43,4 +45,5 @@ package() {
43sha512sums="2193a342f8aa7d8cfb55378c9c59ca61d2d8e4026263fd6e6560c730c712cef1f189305a3f9bca58f5b9c9ffae5af12e1d75e5355d5bdae86a47ad9595b8169a lsyncd-2.2.3.tar.gz 45sha512sums="2193a342f8aa7d8cfb55378c9c59ca61d2d8e4026263fd6e6560c730c712cef1f189305a3f9bca58f5b9c9ffae5af12e1d75e5355d5bdae86a47ad9595b8169a lsyncd-2.2.3.tar.gz
442cebaf59d960321c2eda4ef1e0d850f62eb7eedb7ba8922a5db33a7f78c769d1a52839fbb597ae06ba576632e2abc7b92a6ba2eaf58b71b93bc877db83e25576 fix-realpath.patch 462cebaf59d960321c2eda4ef1e0d850f62eb7eedb7ba8922a5db33a7f78c769d1a52839fbb597ae06ba576632e2abc7b92a6ba2eaf58b71b93bc877db83e25576 fix-realpath.patch
456283f973768467942a69cb4fd835cfef81ffd1d9acccdea21b1f40730f67d5ff0e8db33772f28be2a6abb352c9596a01dbf215aa228072f7439b69ad8c691c61 fix-mandir.patch 476283f973768467942a69cb4fd835cfef81ffd1d9acccdea21b1f40730f67d5ff0e8db33772f28be2a6abb352c9596a01dbf215aa228072f7439b69ad8c691c61 fix-mandir.patch
48047ee8b2fae169e444c81e9b3ce0ef38713a114877cc38f6aee0594cd64c7b7d99d22ac81fe5e6ac87767956e8757731374a179800ec57fe664f058788ba482b lpostcmd.patch
46441b76ec944d9d74100dfca55efe871e9092b37cd49ec79a2a94e281dc0326b4def1645a827f7d3edcddc95d6e74c99621b62991396fb3693b1832c42fd86cdc lsyncd.initd" 49441b76ec944d9d74100dfca55efe871e9092b37cd49ec79a2a94e281dc0326b4def1645a827f7d3edcddc95d6e74c99621b62991396fb3693b1832c42fd86cdc lsyncd.initd"
diff --git a/main/lsyncd/lpostcmd.patch b/main/lsyncd/lpostcmd.patch
new file mode 100644
index 0000000000..dfa8f9da8c
--- /dev/null
+++ b/main/lsyncd/lpostcmd.patch
@@ -0,0 +1,26 @@
1--- a/examples/lpostcmd.lua
2+++ b/examples/lpostcmd.lua
3@@ -6,7 +6,7 @@
4 -- after every successfullycompleted rsync operation.
5 -- for example to restart servlets on the target host or so.
6
7-local rsyncpostcmd = {
8+rsyncpostcmd = {
9
10 -- based on default rsync.
11 default.rsync,
12@@ -105,14 +105,3 @@
13 return default.rsync.prepare(config, level, skipTarget)
14 end
15 }
16-
17-
18-sync {
19- rsyncpostcmd,
20- delay = 3,
21- source = '/path/to/src',
22- host = 'localhost',
23- targetdir = '/path/to/trg',
24- postcmd = '/usr/local/bin/dopostcmd',
25-}
26-